LINUX.ORG.RU

сломался openfire

 ,


0

2

В общем история такая...

Работало сие чудо работало, потом что-то случилось с mysql, он соответственно не работал. Я починил mysql, а openfire все равно не хотел работать. Я его обновил, теперь он вроде коннектится к базе, но выдает ошибку в клиенте при подключении вот такую :

Ошибка квитирования SSL error 1408F10B:SSL routines:SSL3_GET_RECORD: wrong version number  

Крутится на Ubuntu 14.04

Помогите разобраться или может откатиться?


SSL3_GET_RECORD: wrong version number

несоответствие версии на сервере и клиенте, например сервер предлагает sslv3, а клиент хочет sslv2

Вообще SSL это устаревший вариант, по умолчанию сейчас используется TLS. У тебя в настройках клиента что указано?

JB ★★★★★ ()

ошибку в клиенте при подключении вот такую

Гугл говорит, что у тебя клиент vacuum-im и советует обновить его до 1.3. Как выше правильно заметили, у тебя клиент не поддерживает предлагаемую сервером версию протокола.

shrub ★★★★★ ()
Ответ на: комментарий от JB

Вообще SSL это устаревший вариант, по умолчанию сейчас используется TLS. У тебя в настройках клиента что указано?

Ну раньше как то все работало, я настройки не менял ни на сервере ни в клиенте. В клиенте непонятно какое шифрование, порт 5222, по идее TLS должно быть.

podik ()
Ответ на: комментарий от shrub

Гугл говорит, что у тебя клиент vacuum-im и советует обновить его до 1.3. Как выше правильно заметили, у тебя клиент не поддерживает предлагаемую сервером версию протокола.

мда...короче как корректно откатить openfire? обновлять все клиенты это плохой вариант

podik ()
Ответ на: комментарий от shrub

откатился на 3.9.3 но старые клиенты по прежнему не заходят. в логах пишет что то про SSL...но я не пойму где настроить шифрование для openfire

podik ()
Ответ на: комментарий от shrub

ну я там уже все варианты вроде перепробовал) заработало только когда отключил шифрование совсем. с TLS и SSL не хотит

podik ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.