LINUX.ORG.RU

Как правильно откатить Xorg на Debian?

 , ,


0

1

По совету из предыдущего топика решил откатиться назад к Xorg 1.12. Итак, добавляю в sources.list

# wheezy

deb http://ftp.by.debian.org/debian oldstable main contrib non-free

deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free

deb http://security.debian.org/ wheezy/updates main contrib non-free

# aptitude update

положил в etc/apt/preferences.d файлик xorg с таким содержанием:

Package: xserver-*
Pin: release a=oldstable
Pin-Priority: 900

далее делаю


$ sudo apt-get install xorg xserver-xorg-core/oldstable
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия xorg.
Выбрана версия «2:1.12.4-6+deb7u6» (Debian-Security:7.0/oldstable [i386]) для «xserver-xorg-core»
Выбрана версия «8.0.5-4+deb7u2» (Debian:7.8/oldstable, Debian-Security:7.0/oldstable [i386]) для «libgl1-mesa-dri» из-за «xserver-xorg-core»
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 xorg : Зависит: xserver-xorg (>= 1:7.7+7) но он не будет установлен
        Зависит: libgl1-mesa-dri но он не будет установлен
 xserver-xorg-core : Зависит: libaudit0 (>= 1.7.13) но он не будет установлен
                     Рекомендует: libgl1-mesa-dri (>= 7.10.2-4) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Поправте где ошибся?

попробуй апт-гет с ключом -t wheezy. хотя старые иксы притянут старую мезу и ещё кучу всего. было бы интересно наоборот сделать. поставить wheezy и обновить на нём всё кроме иксов на jessie

ionanahin ★★★ ()

Значит либо ставь oldstable, либо собирай Gentoo, можно собирать на другой машине, а потом перенести.

Удачи.

kostik87 ★★★★★ ()

Чтобы включить возможность даунгрейда, поставь приоритет больше тысячи в preferences. Например, 2000 пропиши для oldstable.

curufinwe ★★★★★ ()

Такие вещи лучше через аптитуду делать с полным разбором зависимостей ручками. А через apt-get обновление пакетов взад делать плохая идея.

Да и не до каждой версии без пересборки получится откатиться. Например откат с 1,12 до 1,7 потребует установки hal и прочей ереси, что хрен ты разрулишь. Остается только пересборка или установка промежутночной версии.

Radius ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.