LINUX.ORG.RU

ошибка при обновлении

 , , ,


0

1

Решил обновиться, был debian wheezy, sources.list:

deb http://mirror.yandex.ru/debian/ squeeze main non-free contrib
deb-src http://mirror.yandex.ru/debian/ squeeze main non-free contrib

deb http://mirror.yandex.ru/debian/ wheezy main non-free contrib
deb-src http://mirror.yandex.ru/debian/ wheezy main non-free contrib

deb http://security.debian.org/ wheezy/updates main non-free contrib
deb-src http://security.debian.org/ wheezy/updates main non-free contrib

# wheezy-updates, previously known as 'volatile'
deb http://mirror.yandex.ru/debian/ wheezy-updates main non-free contrib
deb-src http://mirror.yandex.ru/debian/ wheezy-updates main non-free contrib

deb http://mirror.yandex.ru/debian/ jessie main non-free contrib
deb-src http://mirror.yandex.ru/debian/ jessie main non-free contrib
 ~$ cat /etc/apt/preferences.d/30backports 
Package: *
Pin: release n=wheezy-backports
Pin-Priority: 990

Раньше при обновлении всё оставалось в границах wheezy, недавно обновился - сразу две проблемы.

1. Появились строчки вида

~$ sudo apt-get update ...
Ош  http://mirror.yandex.ru wheezy/contrib Translation-en                                                                        
  Неверный заголовок [IP: 213.180.204.183 80]

Ош  http://mirror.yandex.ru wheezy/non-free i386 Packages          
  404  Not Found [IP: 213.180.204.183 80]

W: Не удалось получить http://mirror.yandex.ru/debian/dists/wheezy/main/source/Sources 404 Not Found [IP: 213.180.204.183 80]
E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии. 

2. Всё-таки решил довести до конца, апгрейдился, в результате почему-то обновился до jessie, по крайней мере,

 ~$ cat /etc/*release*
PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
NAME="Debian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)" 
Я так понимаю, что обновилось не всё, например, libc6 осталась на 2.13. Ввиду всего этого не могу поставить некоторые пакеты. Подскажите, пожалуйста, что произошло и можно ли исправить ситуацию.

Ответ на: комментарий от ziemin
Расчёт обновлений…Неудачно
Пакеты, имеющие неудовлетворённые зависимости:
 libperl5.14 : Зависит: perl-base (= 5.14.2-21+deb7u2) но он не будет установлен
 qtcore4-l10n : Ломает: libqtcore4:i386 (< 4:4.8.5+dfsg-1~) но 4:4.8.2+dfsg-11 будет установлен
 rxvt-unicode : Зависит: libfontconfig1 (>= 2.9.0) но он не будет установлен
                Зависит: libgdk-pixbuf2.0-0 (>= 2.22.0) но он не будет установлен
                Зависит: libglib2.0-0 (>= 2.12.0) но он не будет установлен
                Зависит: libxft2 (> 2.1.1) но он не будет установлен
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
NatNat ()

Подскажите, пожалуйста, что произошло

Забыли понизить приоритет для testing

можно ли исправить ситуацию.

Можно полностью обновиться до testing (рассчитайте обновление в интерактивном режиме aptitude) или даунгрейдиться.

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Спасибо за совет, попробую. А почему раньше система не обновлялась до тестинга, я не менял приоритеты?

NatNat ()

Зачем использовать зеркала от яндекса? у самого уже много лет официальный de репозиторий и никогда проблем не было.

Хотя... я тут глянул твой sources.list...

squeeze
wheezy
jessie
почему-то обновился до jessie

Действительно, ВНЕЗАПНО

можно ли исправить ситуацию

Да, запросто. Удаляй все ненужное из списка реп, aptitude update ну и так далее. Все нормально будет.

sehellion ★★★★★ ()
Ответ на: комментарий от NatNat

Сейчас уже сложно сказать. Может быть, до этого base-files просто оставались старой версии, а остальные пакеты потихоньку (не создавая конфликтов, как при dist-upgrade) были обновлены?

AITap ★★★★★ ()

Друг помог разобраться. Сказал, что когда много репозиториев сразу, то apt иногда наворачивается и надо чистить кэши. После чего поставить wheezy пины больше 1000 и обновиться. Даунгрейдился до стабильной ветки, всем спасибо за советы. =)

NatNat ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.