LINUX.ORG.RU

|Gentoo| проблемы с HDMI

 , ,


0

0

cast Zubok
Имею:

  • gentoo64 kde 4.13
  • гибридная графика
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1) (prog-if 00 [VGA controller])
    
  • драйвера нуво и интел, проприетарные драйвера ставить не хочу


Проблема: при подключении ноута к телевизору через HDMI наблюдаются артефакты, курсор оставляет следы на мониторе.

xrandr показывает следующее: видно, что HDMI вообще нет
далее делаю xrandr --setprovideroutputsource nouveau Intel и вывод xrandr уже меняется: HDMI уже появляется

подключаю телек, вот вывод xrand: HDMI connected

В настройках экрана накладываю HDMI-1-1 на LVDS1 и изображение дублируется, можно конечно было бы и через xrandr. И все бы ничего, если бы не этот курсор, который оставляет след.
Когда был на арче, создавал подобную тему, там посоветовали отключить аппаратный рендеринг курсора.
Создаю файл /etc/X11/xorg.conf.d/10-device.conf с таким содержимым

Section "Device"
        Identifier  "Card0"
	Driver      "nouveau"
	BusID       "PCI:1:0:0"
	Option      "HWCursor" "off"
EndSection

Section "Device"
        Identifier  "Card1"
	Driver      "intel"
	BusID       "PCI:0:2:0"
	Option      "HWCursor" "off"
EndSection
Но X не стартуют, хотя на арче стартовали. KDE грузится через kdm.
Вот логи с подключенным телевизором:
dmesg
X

еще хотелось бы узнать насчет звука. Что надо настроить в ведре? Этого хватит или нет?
CONFIG_HDMI=y
# CONFIG_SND_HDA_CODEC_HDMI is not set
или надо что-то еще собирать в ядре? Pinkbyte помоги пожалуйста!!!

Ответ на: комментарий от kostik87

Знаете, в принципе мне удалось подключить ноут к телевизору и без bumblebee, при помощи одного xrandr. И все бы ничего, если бы только не этот курсор, который очень сильно следит. Сейчас сижу смотрю фильм через телек, самое интересно, что когда плеер разворачиваешь во весь экран, то косяки с курсором пропадают, но стоит только флэш свернуть как проблема возвращается, так бы ничего, но все равно раздражает.
Кстати, вы не знаете как решить проблему со звуком? Не получается вывести звук на телек. Понятно что в рукокниге пишут

The sound won't work (if you know a way to get it to work, please let us know in the comments!) through HDMI so you'll only get sound through your laptop's speakers

но может это как то можно обойти. На linux mint например звук есть через hdmi.

akhmylin ()
Ответ на: комментарий от Meyer

DRI_PRIME это? слышал об этом. А расскажите пожалуйста об этом по подробней, конкретно как на практике? Нашел интересную статью http://dchambers.github.io/articles/driving-multiple-monitors-on-an-optimus-laptop/, но там с помощью DRI_PRIME можно запустить какое-нибудь приложение. А как HDMI????

akhmylin ()
Ответ на: комментарий от akhmylin

На счет этого, увы, не знаю. Кстати, вот и ответ на вопрос об артефактах. nouveau пока не особо удобен для использования.

Meyer ★★★★★ ()

Для начала надо некоторые ошибки понять. Вот эти строчки смущают:

[    24.304] (EE) AIGLX error: dlopen of /usr/lib64/dri/i965_dri.so failed (/usr/lib64/dri/i965_dri.so: cannot open shared object file: No such file or directory)
[    24.304] (EE) AIGLX: reverting to software rendering
[    25.001] (II) AIGLX: Loaded and initialized swrast
[    25.001] (II) GLX: Initialized DRISWRAST GL provider for screen 0

Тут мы видим, что не шмогла открыть драйвер /usr/lib64/dri/i965_dri.so. А какого хрена? Он вообще есть? В результате Intel переходит на программный рендеринг вместо аппаратного. Сначала надо поправить это. Mesa стоит?

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Zubok

Все правильно, еще раз посмотрел с какими флагами собрана меса, флаг i965 отключен, соответственно и драйвер не грузится.

akhmylin ()
Ответ на: комментарий от Zubok

пересобрал mesa с флагом i965, вот что пишет X

[    24.628] (II) intel(0): [DRI2]   DRI driver: i965
[    24.628] (II) intel(0): [DRI2]   VDPAU driver: i965
[    24.873] (II) AIGLX: Loaded and initialized i965
Все, теперь получается, что драйвер i965 загружен. И вот теперь вопрос на миллион долларов: будет ли intel переходить на аппаратный рендеринг или нет, и если нет то как заставить?

akhmylin ()
Ответ на: комментарий от Zubok

glxinfo | grep OpenGL вот выхлоп

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.3.7
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.3.7
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.3.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
OpenGL ES profile extensions:

akhmylin ()
Ответ на: комментарий от akhmylin

Ну все ок. Теперь рендеринг аппаратный включен. И что теперь с курсором? Если иксы не стартуют, то тогда лог при нестартующих иксах выложи, плз.

Попробуй без конфигурации вообще стартануть.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от Zubok

без конфигурации иксы стартуют, я сейчас в DE. Они не стартовали когда я в /etc/X11/xorg.conf.d/10-device.conf ложил

Section "Device"
        Identifier  "Card0"
	Driver      "nouveau"
	BusID       "PCI:1:0:0"
	Option      "HWCursor" "off"
EndSection

Section "Device"
        Identifier  "Card1"
	Driver      "intel"
	BusID       "PCI:0:2:0"
	Option      "HWCursor" "off"
EndSection
Так что сейчас сделать? Что показать?

akhmylin ()
Ответ на: комментарий от Zubok

да, основная задача - это отключить аппаратный рендеринг курсора, чтобы не было артефактов при подключении ноута к телеку через HDMI.

akhmylin ()
Ответ на: комментарий от kostik87

это получается опять же надо ставить проприетарные дрова. Кстати, а есть нормальные маны как поставить bumblebee на gentoo, работоспособные.

akhmylin ()
Ответ на: комментарий от armbox

хорошо, допустим я удалю этот файл. Вот вывод xrandr когда работает intel

Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768      59.99*+  40.06  
   1024x768      60.00  
   800x600       60.32    56.25  
   640x480       59.94  
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
Там HDMI не видно. А где гарантия что после полного удаления нуво появится? А появляется как раз только после xrandr --setprovideroutputsource nouveau Intel, то есть после переключения опять же на нуво. Вот такой вот замкнутый круг. А если еще добавить проблему со звуком...

akhmylin ()
Ответ на: комментарий от akhmylin

перемести и перезагрузись, если что, то вернёшь обратно

armbox ()
Ответ на: комментарий от akhmylin
emerge bumblebee nvidia-drivers

и всё. Ещё можно поставить primus из оверлей bumblebee, если хочется использовать primusrun вместо optirun. У меня самого ноутбук с Nvidia Optimus, Acer Aspire V3-771G.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от akhmylin

Так вот я и спрашиваю: артефакты сейчас пропали, когда ты драйвер нормально сделал?

Так что сейчас сделать? Что показать?

Лог иксов, когда они не стартуют. Посмотреть, на что он спотыкнулся.

Zubok ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.