LINUX.ORG.RU

Нужно ли обновлять ядро?

 ,


0

1

Стоит Ubuntu 14.04.1 с ядром 3.13.0-45

Недавно тут мелькала новость, что вышла версия 14.04.2 с новым ядром 3.16...

Обновлений ядра не прилетело, отсюда вопрос, нужно ли его принудительно обновить или действовать по принципу «работает - не трогай»?

p.s. пользуюсь только LTS

★★

Если у тебя есть причины его обновлять - обнови. В противном случае - не обновляй.

Valdor ★★ ()
Ответ на: комментарий от krang

если не прилетит, то останется

если вдруг не останется, то значит, что таки прилетело

Alyssa ()

Хочешь - ставь, ждать не нужно, можно и самому собрать.

neversleep ★★ ()

Нужно, иначе зачем Линус его запиливает, а мейнтейнеры дистрибутива опакечивают?

Lavos ★★★★★ ()

обновления ради обновлений

snaf ★★★★★ ()
aptitude search kernel

что говорит?

dvrts ★★★ ()
Ответ на: комментарий от krang

На опеннете говорили, что иксы и ядро автоматически не обновляются с переходом 14.04.1->2. Если тебе надо — обнови вручную, можешь глянуть на том же опеннете в новости.

Deleted ()

просто интересно оно само потом прилетит или так и останется 3.13 до 16.04?

Оно останется 3.13.x, если ты его не обновишься, как и xorg окружение.

anonymous_sama ★★★★★ ()

ядро имеет смысл обновить если

1. оно старое, т.е. в репозитории ТВОЕГО дистра есть новее (и нужно!)

2. если у тебя какая-то железка не работает (редко помогает, но иногда помогает)

3. если тебе нечем заняться, и хочется покрасноглазить

emulek ()
Ответ на: комментарий от Valkeru

Ты явно не про тот дистр пишешь.

может ему про ppa рассказать?

emulek ()

Для перевода уже существующих установок на новые версии ядра и графического стека следует выполнить команду (opennet.ru)

sudo apt-get install linux-generic-lts-utopic xserver-xorg-lts-utopic libegl1-mesa-drivers-lts-utopic xserver-xorg-video-all-lts-utopic xserver-xorg-input-all-lts-utopic
garik_keghen ★★★★★ ()

Можно, но это не так уж и срочно. Прилетит обновление - поставишь.

Bfgeshka ★★★★★ ()

или действовать по принципу «работает - не трогай»?

Мне кажется в жизни всегда нужно следовать этому принципу. Ну и в этом случае тоже.

mbivanyuk ★★★★★ ()

нужно ставить обновления. не страдай хернёй.

darkenshvein ★★★★★ ()

В ближайший месяц точно не стоит, пока баги не исправят.

fornlr ★★★★★ ()
Ответ на: комментарий от mbivanyuk

или действовать по принципу «работает - не трогай»?

Мне кажется в жизни всегда нужно следовать этому принципу. Ну и в этом случае тоже.

Лучшее враг хорошего, иногда просто хорошо — мало, нужно великолепно))

haku ★★★★★ ()

Обычно ручной сборкой простому пользователю страдать резона нет.

Deathstalker ★★★★★ ()
Ответ на: комментарий от fornlr

Не бывает линуксов без красноглазия

Да перестань, линукс сейчас проще и надежнее винды. Вставил диск или флэшку, несколько раз нажал «далее» и получаешь готовую систему. Где там вообще необходимость красноглазить то? И работает годами без всяких сбоев и необходимости что-то делать. Я уже и забыл как выглядит терминал и что такое apt-get и прочие ругательства.

mbivanyuk ★★★★★ ()

Обновления ставить нужно.

Если против этого выступает жаба душегубка или кошка посребушка, то нужно запросить changelog и почитать.

TEX ★★ ()
- Дженкинс!
- Да, сэр!
- Как вы относитесь к хлебу: какой вам больше нравится? Белый или чёрный?
- Видите ли сэр. Если у меня есть белый хлеб, то я его ем. Ну а если у меня есть чёрный, так уж и быть - съем булочку чёрного...
- Спасибо Дженкинс.
- Не за что сэр.

- Дженкинс!
- Да, сэр!
- Как вы относитесь к женщинам: бывают блондинки, брюнетки...
- Видите ли сэр...
- Спасибо Дженкинс.
- Не за что сэр.

- Дженкинс!
- Да, сэр!
- Как вы относитесь к обновлению ядра?
- Видите ли сэр...
- Спасибо Дженкинс.
- Не за что сэр.

ziemin ★★ ()

Для перевода уже существующих установок на новые версии ядра (3.16) и графического стека следует выполнить команду:

sudo apt-get install linux-generic-lts-utopic xserver-xorg-lts-utopic libegl1-mesa-drivers-lts-utopic xserver-xorg-video-all- lts-utopic xserver-xorg-input-all-lts-utopic

но я бы не советовал...

Odalist ★★★★★ ()
Последнее исправление: Odalist (всего исправлений: 1)
Ответ на: комментарий от Valkeru

Обычный пользователь, которому не повезёт, может скачать «стабильную» ubuntu LTS и получить кучу проблем Не установить Steam! Помогите новичку.

Ну прошаренный красноглазик, то поймёт что LTS выпуск со свеже испеченным HWE - это экстрим.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)

Работает без сбоев?! Я вообще использую сейчас 3.9.7 только патчу и никаких проблем.......

kraz5 ()
Ответ на: комментарий от fornlr

Да? Ну ХЗ, у меня на многих компьютерах линукс и везде одно и тоже - воткнул флэшку, несколько раз кнопка далее, получил рабочую систему, годами стоит и никаких проблем. Я бы может и покрасноглазил, но во-первых ни разу не было необходимости, а во-вторых я просто не умею. Говоришь это только моё воображение? Ну ОК, как скажешь ))

mbivanyuk ★★★★★ ()
Ответ на: комментарий от Valkeru

Ну если это красноглазие...

Зри в корень. В ссылке даты апдейтов, чреватые красноглазием для пользователя в случае обновления. А в случае необновления (для некоторых из обновлений) есть риск уязвимостей, ненадлежащей работы из-за прекращения поддержки версии стека.

andrew667 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.