LINUX.ORG.RU

emerge предлагает добавление keywords

 ,


0

0

Всем доброго времени!
Собственно сабж в последней строке выхлопа от ebuild'а:

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-office/openerp-7.0.20140125
# required by app-office/openerp (argument)
=dev-python/python-openid-2.2.5-r1 ~x86
...
...

Would you like to add these changes to your config files? [Yes/No]
Как отключить такую фичу?


Как отключить такую фичу?

Зачем????

P.S. Гм, а у меня не предлагает. make.conf в студию

iVS ★★★★★ ()
Последнее исправление: iVS (всего исправлений: 1)

=dev-python/python-openid-2.2.5-r1 ~x86 На нестабильной ветке сидишь?

Unicode4all ★★★★★ ()

Раз уж зашла тема, спрошу

Мне портаж не предлагает такого, а хочется. Как включить такую фичу?

devsdc ★★ ()

проверь свой make.conf на слова autounmask

snaf ★★★★★ ()
Ответ на: комментарий от snaf

Про опцию я знаю, хочется, чтобы он и без опции предлагал.

devsdc ★★ ()
Ответ на: комментарий от snaf

Так ведь будет вообще без запросов записывать или нет?

pS ()
Ответ на: комментарий от eternal_sorrow

Значит для моего случая:

EMERGE_DEFAULT_OPTS="--ask-enter-invalid=y ... --autounmask=n"
Так?

pS ()
Ответ на: комментарий от eternal_sorrow

man emerge | grep -A2 '\-\-autounmask'
--autounmask [ y | n ]
Automatically unmask packages and generate package.use settings as necessary to satisfy dependencies. This option is enabled by default.

package.use

И это, видимо, не то!

pS ()
Последнее исправление: pS (всего исправлений: 1)
Ответ на: комментарий от pS

разумеется у нештабильных пакетов будут нештабильные зависимости. не сиди на смеси, если хочешь штабильных версий

anonymous ()
Ответ на: комментарий от anonymous

Я понимаю про зависимости. Речь не об этом. Portage хочет _сам_ куда-то(?!) записать keywords.

pS ()
Ответ на: комментарий от pS

это же наглядно показывает что делать для не читающих маны 99%. тем более тебе дают выбор y/n. в чём проблемы?

anonymous ()
Ответ на: комментарий от anonymous

Может, я и не столь внимателен при чтении манов, но не на 99%. А выбор y/n легко спутать посто с запросом на установку пакетов.

pS ()
Ответ на: комментарий от pS

package.use

И это, видимо, не то!

всё то

unmask packages and generate package.use settings

так понятно?

eternal_sorrow ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.