LINUX.ORG.RU

kde-plasma/kwinбез wayland хочет media-libs/mesa с wayland

 


0

2

Всем привет.

Gentoo ~x86, прилетело с обновлением:

$ emerge -av1 kwin
...
Calculating dependencies... done!
[ebuild     U  ] media-libs/mesa-11.0.5::gentoo [11.0.4::gentoo] USE="classic dri3 egl gallium gbm nptl udev vaapi wayland* -bindist -d3d9 -debug -gles1 -gles2 -llvm -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -vdpau -xa -xvmc" VIDEO_CARDS="(-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 7 102 KiB
...
[ebuild     U  ] kde-plasma/kwin-5.4.95:5::kde [5.4.3:5::kde] USE="-debug -gles2 -handbook -multimedia {-test} (-wayland%)" 3 719 KiB
[...
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-plasma/kwin-5.4.95::kde
# required by kwin (argument)
>=media-libs/mesa-11.0.5 wayland

Would you like to add these changes to your config files? [Yes/No]


То есть kwin, который без wayland, требует mesa с wayland, я все правильно понял?
Это нормально?

★★★★★

Это нормально?

Смотря что считать нормой. И да наркоманы такие наркоманы...

init_6 ★★★★★ ()

Welcome to Gentoo!!!

Циннамон без НетворкМанагера просто и непринуждённо устанавливает его с его же прихвостнями.

Deleted ()
Последнее исправление: Lifun (всего исправлений: 1)
Ответ на: комментарий от daemonpnz

Ну ок защитано.

А то что стабильный gnome-3.16 из основного дерева тянет одновременно ДВЕ РАЗНЫХ версии webkit-gtk никого не смущает?

init_6 ★★★★★ ()
Ответ на: комментарий от init_6

Сам напейсши ебилд, или ты неосилятор?

anonymous ()
Ответ на: комментарий от anonymous

Сам напейсши ебилд, или ты неосилятор?

А ты потраченная лалка - это за миня уже сделал апстрим генты осталось только выяснить причины которые побудили их надмозг поступить именно так.

init_6 ★★★★★ ()
Ответ на: комментарий от init_6

Жалкие оправдания твоего неосиляторства и слабовольности.

anonymous ()
Ответ на: комментарий от anonymous

Жалкие оправдания твоего неосиляторства и слабовольности.

Нет это твоя жалкая попытка.

init_6 ★★★★★ ()
Ответ на: комментарий от init_6

нет ты

Просто признай, что ты не осилил поддерживать свой оверлей и бросил это дело, как тряпка.

anonymous ()
Ответ на: комментарий от anonymous

Это ^ не моя цитата. А своё мнение можешь оставить при себе, потому что мне на него, как собственно и на тебя, насрать.

init_6 ★★★★★ ()

Это значит, что в kwin флаг wayland убрали и теперь это хард-депендеси

anonymous8 ()

Ты это, поосторожнее. Часть функционала не портировали еще, dolphin без минимтюр (пока зависимости не зарелизили), dolphin-плагины тоже, kmail тянет зависимости и хочет baloo старой версии (не поставишь kmail пока все не преломаешь). Короче через годика два можно вместе с wayland'ом попробовать. Кстати, если я не ошибаюсь, то в ::gentoo все равно будет зависимость от wayland.

deterok ★★★★★ ()
Ответ на: комментарий от init_6

Его зовут Martin Gräßlin

https://mail.kde.org/pipermail/release-team/2015-July/008725.html

Reasoning: over the Plasma 5.4 cycle I have pretty much only worked on Wayland 
support and that has resulted in more than 100
#if HAVE_WAYLAND
...
#endif

As our CI system and most distributions only compile with Wayland support the 
risk of accidental breakage increases each day. Even more it means that 
running builds without this build dependency is pretty much untested. While 
it's unlikely to affect kwin_x11, it is possible, nevertheless.

Given that I want to turn the following list of dependencies from optional to 
required in the next development cycle:
* KF5Wayland
* Wayland::Cursor
* Wayland::Egl
* xkbcommon
* libdrm
* gbm

Kroz ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.