LINUX.ORG.RU

На правах телепатии:

В новых драйверах иногда выпиливают поддержку старых карт. У меня была GeForce 7300 GT, работала с такой строкой в package.mask:

$ cat /etc/portage/package.mask | grep nvidia
>=x11-drivers/nvidia-drivers-305.0.0 # will not support my video card

Посмотри какие версии nvidia-drivers находятся в официальном репозитории, должно навести на мысль.

$ ls -1 /usr/portage/x11-drivers/nvidia-drivers/*.ebuild
/usr/portage/x11-drivers/nvidia-drivers/nvidia-drivers-173.14.39.ebuild
/usr/portage/x11-drivers/nvidia-drivers/nvidia-drivers-304.121.ebuild
/usr/portage/x11-drivers/nvidia-drivers/nvidia-drivers-331.79.ebuild
/usr/portage/x11-drivers/nvidia-drivers/nvidia-drivers-334.21-r3.ebuild
/usr/portage/x11-drivers/nvidia-drivers/nvidia-drivers-337.12.ebuild
/usr/portage/x11-drivers/nvidia-drivers/nvidia-drivers-337.19.ebuild
/usr/portage/x11-drivers/nvidia-drivers/nvidia-drivers-96.43.23.ebuild

Ну, если телепатия не сработала, то выкладывай /etc/X11/xorg.conf, /var/log/Xorg.0.log , вывод

$ lspci
$ glxinfo | grep direct
$ eselect opengl list

Kroz ★★★★★ ()
Последнее исправление: Kroz (всего исправлений: 1)

GeForce 6100

есть вариант поставить старые иксы и legacy-драйвер, но у многих приложений может быть зависимость от новых иксов (кде? возможно нужно собрать кде3).

wakuwaku ★★★★ ()
Последнее исправление: wakuwaku (всего исправлений: 1)
Ответ на: комментарий от Stil

Разве нуво поддерживает настолько старые видеокарты? А нвидия периодически обновляет версию своего блоба для старых видеокарт.

bsdfun ★★★★★ ()

X11 требует единственную настройку:

 Section "Device"
   Identifier  "nvidia"
   Driver      "nvidia"
 EndSection
Последний блоб для твоей карты, согласно офф сайту зависти: 304.88
Ну а как настроить 100500 настроек KDE, это уже не ко мне. Я пока что на крысафейсе сижу)

Waldo-de-Kard ★★ ()
Ответ на: комментарий от bsdfun

Разве нуво поддерживает настолько старые видеокарты?

yeap

http://nouveau.freedesktop.org/wiki/CodeNames/#nv40family

http://nouveau.freedesktop.org/wiki/FeatureMatrix/

А нвидия периодически обновляет версию своего блоба для старых видеокарт.

ага, наверное поэтому тут блобоводы про маскировки пакетов, легаси иксы и кде3 рассуждают

Stil ★★★★★ ()

Так и есть: http://www.nvidia.com/object/unix.html
В 304.121 твоя видяха еще поддерживается, в 331.79 уже нет. Маскируй «>=x11-drivers/nvidia-drivers-305.0.0», переключай eselect на драйвер nvidia, перегружай иксы, команда `glxinfo | grep direct` должна выдать 'direct rendering: Yes'.

Kroz ★★★★★ ()
Последнее исправление: Kroz (всего исправлений: 1)
Ответ на: комментарий от Kroz

Так и есть: http://www.nvidia.com/object/unix.html
В 304.121 твоя видяха еще поддерживается, в 331.79 уже нет. >Маскируй «>=x11-drivers/nvidia-drivers-305.0.0», переключай >eselect на драйвер nvidia, перегружай иксы, команда `glxinfo | >grep direct` должна выдать 'direct rendering: Yes'.

А можно подробнее?

LanSilot ()
Ответ на: комментарий от LanSilot

Открываешь /etc/portage/package.mask (создаешь, если у тебя нет этого файла), добавляешь туда строку:

>=x11-drivers/nvidia-drivers-305.0.0

Далее переустанавливаешь драйвер:

$ emerge nvidia-drivers

Далее проверяешь активный OpenGL движок:

$ eselect opengl list

Если звездочка стоит не на nvidia, то с помощью `eselect opengl set <нужный номер>` , переключаешь на nvidia.

Далее перегружаешь иксы. Проверка что ускорение работает:

$ glxinfo | grep direct

В выводе этой команды должно присутствовать «direct rendering: Yes» . Если у тебя не команды glxinfo, установи mesa-progs.

Это вкратце. Там еще есть другие нюансы, я просто надеюсь, что с ними у тебя все нормально . Детальней здесь: http://wiki.gentoo.org/wiki/NVidia/nvidia-drivers ; если не сработало то, что я написал - проработай wiki по ссылке что я дал.

Отпишись по результату.

Kroz ★★★★★ ()
Ответ на: комментарий от Kroz

Всем спасибо за помощь. Особенно тебе Kroz! Всё получилось.

LanSilot ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.