LINUX.ORG.RU

nvidia-331 не работает

 


0

1

В общем, обновился на двух компах с 13.04 до 14.04 без особых проблем. На одном вообще всё гладко - были открытые дрова для nVidia (карта GT210, там открытый сойдет), на втором вручную поставил новое ядро и перешел на опенсорсный драйвер (HD 6320 - тоже норм открытый драйвер) - тоже всё пучком.

А вот компьютер с GTX-465 (хочется проприетарный драйвер для быстрой графики) не хочет запускать Unity с проприетарным драйвером, только с опенсорсным нет проблем. Это выражается в том что не появляются никакие панельки, просто тупо фон стартового экрана и более ничего, но есть всплывающие уведомления.

Пробовал переустанавливать через консоль (пакет из репозитория nvidia-311) - вижу что никаких ошибок при установке нет, а X11 говорит что can't load nvidia kernel module и всё... Ядро 3.13, всё исключительно из репозиториев стандартных.

У кого такая же проблема?

Пока вот сижу на Gallium 0.4 on NVC0... Игры вообще не тянутся, куча расширений не поддерживается... В общем, может оно и к лучшему, лучше работать буду. Но всё же.

Ответ на: комментарий от anonymous

Абсолютно всё есть, а хедеры в первую очередь. Если не получится разобраться, буду писать баг репорт, в принципе не срочно.

Linux MS-7623 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
ii  linux-cloud-tools-3.13.0-24                           3.13.0-24.46                                        amd64        Linux kernel version specific cloud tools for version 3.13.0-24
ii  linux-cloud-tools-3.13.0-24-generic                   3.13.0-24.46                                        amd64        Linux kernel version specific cloud tools for version 3.13.0-24
ii  linux-cloud-tools-common                              3.13.0-24.46                                        all          Linux kernel version specific cloud tools for version 3.13.0
ii  linux-headers-3.13.0-24                               3.13.0-24.46                                        all          Header files related to Linux kernel version 3.13.0
ii  linux-headers-3.13.0-24-generic                       3.13.0-24.46                                        amd64        Linux kernel headers for version 3.13.0 on 64 bit x86 SMP
ii  linux-headers-generic                                 3.13.0.24.28                                        amd64        Generic Linux kernel headers
ii  linux-image-3.13.0-24-generic                         3.13.0-24.46                                        amd64        Linux kernel image for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-extra-3.13.0-24-generic                   3.13.0-24.46                                        amd64        Linux kernel extra modules for version 3.13.0 on 64 bit x86 SMP
ii  linux-image-generic                                   3.13.0.24.28                                        amd64        Generic Linux kernel image
ii  linux-libc-dev:amd64                                  3.13.0-24.46                                        amd64        Linux Kernel Headers for development
ii  linux-tools-3.13.0-24                                 3.13.0-24.46                                        amd64        Linux kernel version specific tools for version 3.13.0-24
ii  linux-tools-3.13.0-24-generic                         3.13.0-24.46                                        amd64        Linux kernel version specific tools for version 3.13.0-24
ii  linux-tools-common                                    3.13.0-24.46                                        all          Linux kernel version specific tools for version 3.13.0
I-Love-Microsoft ★★★★★ ()
Последнее исправление: I-Love-Microsoft (всего исправлений: 2)

Во дела... попробовал поставить VirtualBox - пишут can't install drivers with DKMS, please install linux-headers-3.13.0-24-generic package... но ведь:

sudo apt-get install linux-headers-3.13.0-24-generic Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Уже установлена самая новая версия linux-headers-3.13.0-24-generic. Следующие пакеты устанавливались автоматически и больше не требуются: bbswitch-dkms lib32gcc1 libc6-i386 libcuda1-331 libvdpau1 linux-image-generic screen-resolution-extra Для их удаления используйте «apt-get autoremove». обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

I-Love-Microsoft ★★★★★ ()
Последнее исправление: I-Love-Microsoft (всего исправлений: 1)
Ответ на: комментарий от anonymous

И снеси хедеры старого ядра, например.

anonymous ()

В общем, обновился на двух компах с 13.04 до 14.04 без особых проблем.

ССЗБ

Ядро 3.13, всё исключительно из репозиториев стандартных.

Блоб не дружит 3.13. Если не ошибаюсь. На генточке 3.12.

Deleted ()
Ответ на: комментарий от Deleted

Дружит теоретически, пофиксили же давно. Иначе как оно попало в единственном варианте для аж LTS релиза...

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от Deleted

Добавлю что обновление прошло через промежуточное 13.10, так что всё по правилам и канонам :)

Лишь в 14.04 пофиксили индикатор и переключение клавиатуры. Сидеть с таким багом пол года это не приемлемо, а поставить 13.04 вместо 12.04 тоже был вынужден, увы.

I-Love-Microsoft ★★★★★ ()
Последнее исправление: I-Love-Microsoft (всего исправлений: 1)
Ответ на: комментарий от I-Love-Microsoft

Лишь в 14.04 пофиксили индикатор и переключение клавиатуры

Весь интернет трындит об этой проблеме, а я только сижу на кедах и недоумеваю...

Deleted ()
Ответ на: комментарий от Deleted

Да, это эпичнейший баг с невероятно странным игнором со стороны каноникала. Ладно там когда редкая хитрая софтина в одном из 1000 случаев как-то не так работает а всем пофиг, но когда тупо переключение языка и отображение индикатора не пашет... это просто провал, поэтому я и вернулся на 13.04 после 13.10.

Однако, одно важное устройство вынудило меня уйти с 12.04, а так бы сидел и проблем не знал.

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от anonymous

Переустанови с --reinstall, вдруг фс повредилась и файлы потерялись, чё как блондинка.

Вах вах, маладэс, хароший аноним! Спасибо! Это действительно помогло.

sudo apt-get install --reinstall linux-headers-3.13.0-24-generic

Видать какой-то файлик похерился и DKMS считал что нету заголовочников и дрова не ставил...

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от Deleted

Обычный 337.12 без каких либо патчей, мой мнительный друг. Для 3.13 и более старые версии работали.

anonymous ()
Ответ на: комментарий от I-Love-Microsoft

Чтд, обычные блондинки с более крутыми чем у меня компами на которых тот же софт что у меня тормозит и падает :3

anonymous ()
Ответ на: комментарий от anonymous

Чтд, обычные блондинки с более крутыми чем у меня компами на которых тот же софт что у меня тормозит и падает

Узнаваемый стиль... еще раз благодарю :) Для моего крошечного мозга было далеко не очевидно что решение вот такое простое...

I-Love-Microsoft ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.