LINUX.ORG.RU

Проблемы с сетью Debian

 


0

1

Установил debian последнего стабильного выпуска - 7.4.0 - amd64.
Не подключается к сети. Имеется:
TP-LINK 150Mbps Wireless Lite N Adapter
Killer e2200 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
Можно ли заставить хоть что-нибудь из этого работать?

apt-get install firmware-linux firmware-linux-free firmware-linux-nonfree

nano /etc/network/interfaces

auto wlan0
iface wlan0 inet dhcp

auto eth0
iface eth0 inet dhcp

ctrl+o ctrl+x

service networking restart
Dron ★★★★★ ()
Последнее исправление: Dron (всего исправлений: 3)

TP-LINK TL-WN7200ND 150Mbps Wireless Lite N Adapter, если точнее

Pingvinux ()
Ответ на: комментарий от Pingvinux

Ну я подумал может диски есть, сори.

Тогда настройки впиши и перезапусти сеть.

Лучше провод ethernet воткни вместо wifi свистка, сеть должна поднятся, и сделай apt-get вышеописанный.

Dron ★★★★★ ()
Последнее исправление: Dron (всего исправлений: 1)
Ответ на: комментарий от Pingvinux

dhcp на роутере соотвецтвенно включи/настрой. Если с этим проблемы пиши.

Dron ★★★★★ ()

TP-LINK 150Mbps Wireless Lite N Adapter

На каком чипе wifi адаптер?

По поводу e2200 вот, почитайте: https://wiki.debian.org/alx

Вам нужно подключить debian-backports (wheezy-backports) и установить оттуда ядро 3.12. А то в ядре 3.2, которое идёт вместе с Debian нет поддержки вашего адаптера.

Можете получить список пакетов, затем их скачать и установить хотя бы средствами

dpkg -i *.deb

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от Pingvinux

Значит ставьте в виртуальную машину и получайте там список пакетов или сразу скачивайте пакеты, а затем поставьте в реальной системе. Ну и почитайте моё предыдущее сообщение, по поводу wheezy-backports.

kostik87 ★★★★★ ()
Ответ на: комментарий от Pingvinux

В wheezy-backports присутствует ядро 3.13, в котором есть поддержка драйвера alx, который нужен для вашего ethernet адаптера:
https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/tree/dri...

В ядре 3.2, которое идёт вместе с Debian 7, нет поддержки этого драйвера:
https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/tree/dri...

Так же есть и в ядре 3.10 и, скорее всего, и некоторых ниже. Но, как я уже сказал, в wheezy-backports сейчас есть пакет с ядром версии 3.13:
https://packages.debian.org/ru/wheezy-backports/linux-image-amd64

Нет, если вам нужно ядро ниже 3.12 или 3.13, то ставьте его, если знаете откуда взять готовый пакет с ядром версии ниже. Ну или соберите его сами, если умеете.

Если же нет, то у вас только один вариант - подключить wheezy-backports и установить оттуда пакет с ядром версии 3.13.

Ну, а для wifi адаптера так же нужно будет установить соответствующий пакет с прошивками (firmware), т.к. в Debian по умолчанию этого пакета нет.

kostik87 ★★★★★ ()
Ответ на: комментарий от Dron

Скорее всего, ничего, т.к. в ядре 3.2 нет драйвера alx, который есть только в ядрах выше.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)

В TL-WN7200ND по идее чип Ralink RT3070, есть драйвер на оф. сайте или же compat-wireless.

invokercd ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.