LINUX.ORG.RU

Realtek RTL8101/2/6E

 


0

1

Всем доброго времени суток. В Linux совсем недавно.Опешу свою проблему,при потключении wi-fi нету выхода в интернет.А при подключенном кабели выход есть. Mint 18.1 Serena;Linux 4.4.0-53-generic х86_64;MATE 1.16.1 Intel Pentium(R) CPU N3700 При вводе каманды

lspci -k | grep -iA2 net 
выдает вот это

   Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
	Subsystem: ASUSTeK Computer Inc. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
	Kernel driver in use: r8169
	Kernel modules: r8169
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter
	Subsystem: AzureWave RTL8821AE 802.11ac PCIe Wireless Network Adapter
	Kernel driver in use: rtl8821ae
	Kernel modules: rtl8821ae

зарание спасибо!!!

1. LORCODE. Читайте описание, выставляйте теги, нажимайте предварительный просмотр.

2. Нет выхода в интеренет или вобще не пингуется точка доступа?

mky ★★★★★ ()
Ответ на: комментарий от symon2014

Пробуйте sudo modprobe -r rtl8821ae sudo modprobe rtl8821ae

я полныи ноль в линукс.serg@serg-X553SA ~ $ sudo modprobe -r rtl8821ae sudo modprobe rtl8821ae[sudo] password for serg: modprobe: FATAL: Module sudo not found. serg@serg-X553SA ~ $ sudo modprobe -r rtl8821ae serg@serg-X553SA ~ $ sudo modprobe rtl8821ae serg@serg-X553SA ~ $

undrago ()
Ответ на: комментарий от mky

Нет вход есть но только по проводу,оключаю провод подключаю wi-fi,подключается и показывает что подключена но в инет не выходит.

undrago ()

ох, братан, не завидую я тебе

у меня из той же линейки дура стояла в ноуте и под таким же модулем ядра крутилась - и тоже вифи не ловила под линем, хоть убей... всё кончилось тем, что я купил интеловский адаптер, а ту дрянь отправил на помойку

и было дело то год назад или полтора, и до сих пор походу не допилили

tsmx ()
Ответ на: комментарий от undrago

Тогда такой совет. Создай тему на форумк Убунту , там есть такой чел с ником Pilot6 , он по вафлям знает все , его драйвера входят в состав даже некоторых официальных дистров.

symon2014 ()
Ответ на: комментарий от tsmx

ох, братан, не завидую я тебе

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter

Ваще проблем нет. Ядро 4.19. Ловит и 2.4, и 5.

infine ()
Ответ на: Пробуйте sudo modprobe -r rtl8821ae sudo modprobe rtl8821ae от undrago

Ты отдельно команды пиши.

Сначала sudo modprobe -r rtl8821ae

Потом sudo modprobe rtl8821ae

Первая выгрузит драйвер твоей вафли, вторая обратно загрузит.

Что происходит, когда ты пытаешься подключиться к вайфаю?

Вот ты нажал на апплет сети, там вылез список беспроводных сетей, ты тыкаешь на нужную сеть, спрашивает пароль, вбиваешь, дальше оно должно подцепиться, значок, наверное, поменяется на какой-нибудь, чтобы понятно было, что вайфай подключился.

Что после этого пишут в ip addr? Что в dmesg? (ну пусть dmesg | tail -n 50, должно хватить)

infine ()

вангую отсутствие фирмвари. риалтекам нужна фирмварь. установи соответствующий пакет. обычно что-нить типа firmware-realtek.

Iron_Bug ★★★★★ ()
Последнее исправление: Iron_Bug (всего исправлений: 1)
Ответ на: комментарий от infine

это потому что у тебя 8821ae, а я говорю про всю линейку, которая под одним и тем же модулем работает

у меня, например, 8192 был и нифига не работал, у опа тоже какой-то 81хх интересно, они их тестят вообще или просто говорял «лол, первая цифра совпадает, и так сойдёт)))»?

tsmx ()
Ответ на: комментарий от infine

На данные команды не чего не происходи.

первая serg@serg-X553SA ~ $ sudo modprobe rtl8821ae [sudo] password for serg: serg@serg-X553SA ~ $

вторая serg@serg-X553SA ~ $ sudo modprobe -r rtl8821ae [sudo] password for serg: serg@serg-X553SA ~ $

Ещё раз повторяю что при подключении к своей вифи индикатор на панели сегнализирует что соеденения есть но при выходе в инет браузер выдаёт что его нету.

вот что могу показать и я здесь не чего не понемаю

serg@serg-X553SA ~ $ iwconfig wlp3s0 IEEE 802.11abgn ESSID:«Keenetic-6464» Mode:Managed Frequency:5.18 GHz Access Point: 50:FF:20:11:B2:E2 Bit Rate=6 Mb/s Tx-Power=17 dBm Retry short limit:7 RTS thr=2347 B Fragment thr:off Power Management:off Link Quality=70/70 Signal level=-14 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:4 Missed beacon:0

enp2s0 no wireless extensions.

lo no wireless extensions.

undrago ()
Ответ на: комментарий от infine

Ну не знаю у меня тлько на этой зборке такой гемарой,на Debian 9 не было такой фигни.

undrago ()
Ответ на: комментарий от Iron_Bug

Простите я не чего из написоного вами не понял. у меня есть скаченый пакед драйверов «r8101-1.024.00.tar.bz2 но что сними делать я пока не знаю.)))) Нет конечно разархевирвать архив я смогу но вт как дльше , тёмный лес.Пока изучаю информацию.

undrago ()
Ответ на: комментарий от undrago

Если ты правильно указал порядок ввода команд с modprobe то они перепутаны местами. Первой должна быть команда с параметром -r. Вафля на 5 гигагерцах , а роутер?

symon2014 ()
Ответ на: комментарий от symon2014

Keenetic xctra. После обновления до версии 18.3 всё заработало Всем спасибо.

undrago ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.