LINUX.ORG.RU

Сломал зависимости... опять libc6

 , , ,


0

1

Решил я внезапно сыграть - скачал wine unstable. При попытке установки ругается на то, что надо, мол, libc6 >= 2.17 Ну ладно, будет тебе libc6 2.17: захожу на packages.ubuntu.com, ищу нужный пакет. Качаю его вместе с «якобы» нужными к нему:

$ ls -1
libc6_2.17-0ubuntu5.1_amd64.deb
libc6_2.17-93ubuntu4_i386.deb
libc6-amd64_2.17-0ubuntu5.1_i386.deb
libc6-dev_2.17-0ubuntu5.1_amd64.deb
libc6-dev-amd64_2.17-0ubuntu5.1_i386.deb
libc6-dev-i386_2.17-0ubuntu5.1_amd64.deb
libc6-i386_2.17-0ubuntu5.1_amd64.deb
затем ставлю:
$ sudo dpkg -i *.deb
(Чтение базы данных ... на данный момент установлено 249384 файла и каталога.)
Подготовка к замене пакета libc6:amd64 2.17-0ubuntu5.1 (используется файл libc6_2.17-0ubuntu5.1_amd64.deb) ...
Распаковывается замена для пакета libc6:amd64 ...
Подготовка к замене пакета libc6:i386 2.15-0ubuntu20.2 (используется файл libc6_2.17-93ubuntu4_i386.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
Checking for services that may need to be restarted...
Checking init scripts...
Stopping some services possibly affected by the upgrade (will be restarted later):
  cron: stopping...done.

Распаковывается замена для пакета libc6:i386 ...
Подготовка к замене пакета libc6-amd64 2.17-0ubuntu5.1 (используется файл libc6-amd64_2.17-0ubuntu5.1_i386.deb) ...
Распаковывается замена для пакета libc6-amd64 ...
Заменено файлами из установленного пакета libc6:amd64 ...
Подготовка к замене пакета libc6-dev:amd64 2.17-0ubuntu5.1 (используется файл libc6-dev_2.17-0ubuntu5.1_amd64.deb) ...
Распаковывается замена для пакета libc6-dev:amd64 ...
Подготовка к замене пакета libc6-dev-amd64 2.17-0ubuntu5.1 (используется файл libc6-dev-amd64_2.17-0ubuntu5.1_i386.deb) ...
Распаковывается замена для пакета libc6-dev-amd64 ...
Распаковывается пакет libc6-dev-i386 (из файла libc6-dev-i386_2.17-0ubuntu5.1_amd64.deb)...
dpkg: error processing libc6-dev-i386_2.17-0ubuntu5.1_amd64.deb (--install):
 попытка перезаписать «/usr/include/gnu», который уже имеется в пакете libc6-dev-amd64 2.17-0ubuntu5.1
Подготовка к замене пакета libc6-i386 2.17-0ubuntu5.1 (используется файл libc6-i386_2.17-0ubuntu5.1_amd64.deb) ...
Распаковывается замена для пакета libc6-i386 ...
Заменено файлами из установленного пакета libc6:i386 ...
dpkg: error processing libc6:amd64 (--install):
 package libc6:amd64 2.17-0ubuntu5.1 cannot be configured because libc6:i386 is at a different version (2.17-93ubuntu4)
dpkg: error processing libc6:i386 (--install):
 package libc6:i386 2.17-93ubuntu4 cannot be configured because libc6:amd64 is at a different version (2.17-0ubuntu5.1)
dpkg: dependency problems prevent configuration of libc6-amd64:
 libc6-amd64 зависит от libc6 (= 2.17-0ubuntu5.1), однако:
  Версия libc6:i386 в системе 2.17-93ubuntu4.

dpkg: error processing libc6-amd64 (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: dependency problems prevent configuration of libc6-dev:amd64:
 libc6-dev:amd64 зависит от libc6 (= 2.17-0ubuntu5.1), однако:
  Пакет libc6:amd64 пока не настроен.
 libc6-dev:amd64 зависит от libc-dev-bin (= 2.17-0ubuntu5.1), однако:
  Версия libc-dev-bin в системе 2.15-0ubuntu20.2.

dpkg: error processing libc6-dev:amd64 (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: dependency problems prevent configuration of libc6-dev-amd64:
 libc6-dev-amd64 зависит от libc6-amd64 (= 2.17-0ubuntu5.1), однако:
  Пакет libc6-amd64 пока не настроен.
 libc6-dev-amd64 зависит от libc6-dev (= 2.17-0ubuntu5.1), однако:

dpkg: error processing libc6-dev-amd64 (--install):
 проблемы зависимостей -- оставляем не настроенным
dpkg: dependency problems prevent configuration of libc6-i386:
 libc6-i386 зависит от libc6 (= 2.17-0ubuntu5.1), однако:
  Пакет libc6:amd64 пока не настроен.

dpkg: error processing libc6-i386 (--install):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libc6-dev-i386_2.17-0ubuntu5.1_amd64.deb
 libc6:amd64
 libc6:i386
 libc6-amd64
 libc6-dev:amd64
 libc6-dev-amd64
 libc6-i386
В итоге сломал зависимости, любые действия с помощью менеджера пакетов невозможны. При попытке «исправить» зависимости предлагает снести почти всю систему, а взамен поставить kde-baseapps-data и еще какие-то kde-шные либы.

Сижу в растерянности, комп выключать/перезагружать не рискую. Linux mint 14 MATE, amd64

Что делать?

★★★★★

Ответ на: комментарий от zikasak

уже пытался:

$ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… не удалось.
Пакеты, имеющие неудовлетворённые зависимости:
 libc-dev-bin : Зависит: libc6 (< 2.16) но 2.17-0ubuntu5.1 уже установлен
 libc6 : Ломает: libc6:i386 (!= 2.17-0ubuntu5.1) но 2.17-93ubuntu4 уже установлен
 libc6:i386 : Ломает: libc6 (!= 2.17-93ubuntu4) но 2.17-0ubuntu5.1 уже установлен
 libc6-amd64:i386 : Зависит: libc6:i386 (= 2.17-0ubuntu5.1) но 2.17-93ubuntu4 уже установлен
 libc6-dev : Зависит: libc-dev-bin (= 2.17-0ubuntu5.1)
 libc6-dev-amd64:i386 : Зависит: libc6-dev:i386 (= 2.17-0ubuntu5.1) но он не установлен
                        Рекомендует: gcc-multilib:i386 но он не установлен
 libnih1 : ПредЗависит: libc6 (< 2.16) но 2.17-0ubuntu5.1 уже установлен
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
E: Невозможно скорректировать зависимости

reprimand ★★★★★ ()
Ответ на: комментарий от GodlikeBro

а есть альтернативы поставить libc6 нужной мне версии? в репах нет, а обновлять дистр пока что нет никакого желания

reprimand ★★★★★ ()
Ответ на: комментарий от darkenshvein

спасибо, помогло. Правда, с каким-то непонятным результатом...

Следующие пакеты имеют неудовлетворённые зависимости:
 libc6-dev-amd64:i386 : Зависит: libc6-dev:i386 (= 2.17-0ubuntu5.1) но его установка не запланирована.
 avahi-utils : Зависит: avahi-daemon но его установка не запланирована.
 libc6-amd64:i386 : Зависит: libc6:i386 (= 2.17-0ubuntu5.1) но установлен 2.17-93ubuntu4.
 libc6-dev : Зависит: libc-dev-bin (= 2.17-0ubuntu5.1) но установлен 2.15-0ubuntu20.2.
 libc-dev-bin : Зависит: libc6 (< 2.16) но установлен 2.17-0ubuntu5.1.
 linux-signed-image-generic : Зависит: linux-signed-image-3.7.0-7-generic который является виртуальным пакетом.
 libc6 : Ломает: libc6:i386 (!= 2.17-0ubuntu5.1) но установлен 2.17-93ubuntu4.
 libc6:i386 : Ломает: libc6 (!= 2.17-93ubuntu4) но установлен 2.17-0ubuntu5.1.
 libc6-dev-i386 : Зависит: libc6-i386 (= 2.15-0ubuntu20.2) но установлен 2.17-0ubuntu5.1.
                  Зависит: libc6-dev (= 2.15-0ubuntu20.2) но установлен 2.17-0ubuntu5.1.
 libnih1 : ПредЗависит: libc6 (< 2.16) но установлен 2.17-0ubuntu5.1.
открыто: 22; закрыто: 56; отброшено: 2; конфлик� oСледующие действия разрешат зависимости:

      Удалить следующие пакеты:                                                 
1)      libc6-amd64:i386                                                        
2)      libc6-dev-amd64:i386                                                    

      Установить следующие пакеты:                                              
3)      avahi-daemon [0.6.31-1ubuntu2 (now, quantal)]                           
4)      libnss-mdns [0.10-3.2build1 (now, quantal)]                             

      Оставить для следующих пакетов их текущие версии:                         
5)      linux-signed-generic [Не установлен]                                    
6)      linux-signed-image-generic [Не установлен]                              

      Установить более старую версию для следующих пакетов:                     
7)      libc6 [2.17-0ubuntu5.1 (now) -> 2.15-0ubuntu20.2 (quantal-security, quan
8)      libc6:i386 [2.17-93ubuntu4 (now) -> 2.15-0ubuntu20.2 (quantal-security, 
9)      libc6-dev [2.17-0ubuntu5.1 (now) -> 2.15-0ubuntu20.2 (quantal-security, 
10)     libc6-i386 [2.17-0ubuntu5.1 (now) -> 2.15-0ubuntu20.2 (quantal-security,



Принять данное решение? [Y/n/q/?] y
Следующие пакеты будут ЗАМЕНЕНЫ НА БОЛЕЕ СТАРЫЕ:
  libc6 libc6:i386 libc6-dev libc6-i386 
Следующие НОВЫЕ пакеты будут установлены:
  apt-clone archdetect-deb avahi-daemon{a} avahi-utils btrfs-tools casper 
  cifs-utils cryptsetup dmraid dpkg-repack ecryptfs-utils firefox-locale-es 
  firefox-locale-zh-hans gir1.2-json-1.0 gir1.2-timezonemap-1.0 
  gir1.2-xkl-1.0 jfsutils keyutils kpartx kpartx-boot libc6-dev-i386 
  libdebconfclient0 libdebian-installer4 libdmraid1.0.0.rc16 libecryptfs0 
  libnss-mdns{a} libreadline5 libwhoopsie0 
  linux-signed-image-3.5.0-17-generic localechooser-data lupin-casper lvm2 
  metacity notify-osd notify-osd-icons python-problem-report 
  python3-distupgrade python3-pyicu python3-update-manager rdate 
  reiserfsprogs ubiquity ubiquity-casper ubiquity-frontend-gtk 
  ubiquity-ubuntu-artwork ubuntu-release-upgrader-core watershed whoopsie 
  xfsprogs 
Следующие пакеты будут УДАЛЕНЫ:
  bridge-utils{u} cpu-checker{u} libaio1{u} libalgorithm-c3-perl{u} 
  libanyevent-perl{u} libasn1-8-heimdal:i386{u} libc6-amd64:i386{a} 
  libc6-dev-amd64:i386{a} libcapi20-3{u} libcapi20-3:i386{u} 
  libclass-c3-perl{u} libclass-c3-xs-perl{u} libdata-optlist-perl{u} 
  libdata-section-perl{u} libevent-perl{u} libexif12:i386{u} 
  libfile-copy-link-perl{u} libfile-find-rule-perl{u} 
  libfile-homedir-perl{u} libfile-slurp-perl{u} libfile-which-perl{u} 
  libgconfmm-2.6-1c2{u} libgd2-xpm:i386{u} libgif4:i386{u} 
  libglu1-mesa:i386{u} libgphoto2-2:i386{u} libgphoto2-port0:i386{u} 
  libgraph-perl{u} libgssapi3-heimdal:i386{u} libhcrypto4-heimdal:i386{u} 
  libheap-perl{u} libheimbase1-heimdal:i386{u} libheimntlm0-heimdal:i386{u} 
  libhx509-5-heimdal:i386{u} libieee1284-3:i386{u} libirrlicht1.7a{u} 
  libkrb5-26-heimdal:i386{u} libldap-2.4-2:i386{u} libltdl7:i386{u} 
  libmodern-perl-perl{u} libmpg123-0:i386{u} libmro-compat-perl{u} 
  libnumber-compare-perl{u} libopenal1:i386{u} libparams-util-perl{u} 
  libparse-recdescent-perl{u} librados2{u} librbd1{u} 
  libroken18-heimdal:i386{u} libsane:i386{u} libsasl2-2:i386{u} 
  libsasl2-modules:i386{u} libsub-exporter-perl{u} libsub-install-perl{u} 
  libtext-format-perl{u} libtext-glob-perl{u} libusb-0.1-4:i386{u} 
  libv4l-0:i386{u} libv4lconvert0:i386{u} libwind0-heimdal:i386{u} 
  libxcomposite1:i386{u} libxcursor1:i386{u} libxinerama1:i386{u} 
  libxpm4:i386{u} libxrandr2:i386{u} libxslt1.1:i386{u} msr-tools{u} 
  nvidia-persistenced{u} screen-resolution-extra{u} ttf-umefont{u} 
  ttf-unfonts-core{u} wine-gecko1.4:i386{u} winetricks{u} 
Следующие частично установленные пакеты будут настроены:
  virtualbox-4.2 
Следующие пакеты РЕКОМЕНДОВАНЫ, но установлены НЕ БУДУТ:
  gcc-multilib 
0 пакетов обновлено, 49 установлено новых, 4 пакетов заменены на старые версии, 73 пакетов отмечено для удаления, и 44 пакетов не обновлено.
Необходимо получить 34,4 MБ архивов. После распаковки освободится 23,4 MБ.
Хотите продолжить? [Y/n/?] y

reprimand ★★★★★ ()

Вот что значит говённый пакетный менеджер.

Удали пакеты через dpkg -r, потом собери libc6 + что ещё попросит, опакеть и установи.

kinik ★★☆ ()
Ответ на: комментарий от kinik

ты прав, синаптик в проблемных ситуациях ведет себя не лУчшим образом.
dpkg -r уже, видимо, не понадобится
друге дело - собрать libc6 какой версии-то? и возможно ли это вообще?

reprimand ★★★★★ ()
Ответ на: комментарий от reprimand

Вот сырцы: https://launchpad.net/ubuntu/ archive/primary/ files/eglibc_2.17.orig.tar.xz

Но собирать надо вдумчиво и внимательно, иначе можно похерить систему. Вот здесь: http://cross-lfs.org/view/svn/mips/cross-tools/eglibc.html можно просмотреть советы.

Я бы посоветовал оставить старые пакеты и поставить не wine unstable, а ту версию, что в репозитории или playonlinux, ибо ненужное красноглазие.

kinik ★★☆ ()

facepalm, ты ты удалил основную системную библиотеку и еще чему-то удивляешься? Лол. ЛОЛ.

tazhate ★★★★★ ()

Всегда ставил вайн в три команды:

sudo add-apt-repository ppa:ubuntu-wine/ppa

sudo apt-get update

sudo apt-get install wine1.7

Проблем не было ни когда. Или я что то пропустил?

sergio1204 ★★ ()
Ответ на: комментарий от sergio1204

я тоже так ставил, и всё было нормально.
Но теперь возникло такое вот «внезапно». Проверю всё ли в порядке, мб действительно где-то проглядел...

reprimand ★★★★★ ()
Ответ на: комментарий от reprimand

спасибо, помогло. Правда, с каким-то непонятным результатом...

да страсти христовы, тебе что, пост-оргазменные эндорфины всё внимание расхреначили? Я же говорю, повтори ещё раз команду аптитьюд -ф инсталл

darkenshvein ★★★★★ ()
Ответ на: комментарий от reprimand

у тебя всё нормально с глазами? где ты видел, чтобы я ее удалил?

У тебя все нормально с мозгом? Ты знаешь, зачем придумали пакетники? Как раз для того, чтобы такие как ты не стреляли себе в ногу.

tazhate ★★★★★ ()
Ответ на: комментарий от darkenshvein

с тобой всё нормально? в последнее время жутко несет неадекватством.

$ sudo aptitude -f install
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 42 пакетов не обновлено.
Необходимо получить 0 Б архивов. После распаковки 0 Б будет занято.

reprimand ★★★★★ ()
Последнее исправление: reprimand (всего исправлений: 2)
Ответ на: комментарий от tazhate

Я, конечно, понимаю что ты такой великий и могучий тазхейт с неплохим объемом ЧСВ (радует, что не таким большим как у некоторых), но попробуй иногда отбросить гордость и прочитать все-таки тему. Говорят так проще.

Или тебе приятен сам факт - разводить лишний срач? Если да, давай посрём в теме.

reprimand ★★★★★ ()
Ответ на: комментарий от reprimand

Да было б чо читать. Форсни через dpkg установку нужной тебе (бывшей в системе) libc и все чудом починится.

tazhate ★★★★★ ()

Пришло время переустанавливать линупс. Линупс сам не переустановится

GodlikeBro ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.