LINUX.ORG.RU

Русский язык в KDE, Arch

 ,


0

1

В Dolphin'е русские названия выглядят как ????? и в kонсоли русский текст аналогично отображается. В остальном отображается всё нормально. $ setfont cyr-sun16 в kонсоли выдаёт «Couldn't get a file descriptor referring to the console». Локаль русскую выбрал, пакет какой-то установил, шрифты настроил, как быть?

Локаль русскую выбрал

где и как ты ее «выбрал»?

unt1tled ★★★★ ()

пакет какой-то установил

Couldn't get a file descriptor referring to the console

иди-ка обратно в убунту.

false ★★★★★ ()

[offtop] В другом треде ты написал «Ставил по арчевики». Надеюсь, по английскому? [/offtop]

Deleted ()
Ответ на: комментарий от lampslave

Это было так давно, я искал решения где угодно, но не в своих же темах полугодовой давности. Простите, ребятки, за некую тормознутость, спасибо за ссылку на решение!

Romaboy ()
Ответ на: комментарий от lampslave

Вот такое вот безобразие:

locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: ?????????? ?????????? LC_ALL ? ?????? ?? ?????????.: ??? ?????? ????? ??? ???????? LANG=en_AU.UTF-8 LC_CTYPE=«en_AU.UTF-8» LC_NUMERIC=«en_AU.UTF-8» LC_TIME=en_DK.UTF-8 LC_COLLATE=C LC_MONETARY=«en_AU.UTF-8» LC_MESSAGES=ru_RU.UTF-8 LC_PAPER=«en_AU.UTF-8» LC_NAME=«en_AU.UTF-8» LC_ADDRESS=«en_AU.UTF-8» LC_TELEPHONE=«en_AU.UTF-8» LC_MEASUREMENT=«en_AU.UTF-8» LC_IDENTIFICATION=«en_AU.UTF-8» LC_ALL=

Romaboy ()
Ответ на: комментарий от Romaboy

Так лучше смотрится:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: ?????????? ?????????? LC_ALL ? ?????? ?? ?????????.: ??? ?????? ????? ??? ????????
LANG=en_AU.UTF-8
LC_CTYPE="en_AU.UTF-8"
LC_NUMERIC="en_AU.UTF-8"
LC_TIME=en_DK.UTF-8
LC_COLLATE=C
LC_MONETARY="en_AU.UTF-8"
LC_MESSAGES=ru_RU.UTF-8
LC_PAPER="en_AU.UTF-8"
LC_NAME="en_AU.UTF-8"
LC_ADDRESS="en_AU.UTF-8"
LC_TELEPHONE="en_AU.UTF-8"
LC_MEASUREMENT="en_AU.UTF-8"
LC_IDENTIFICATION="en_AU.UTF-8"
LC_ALL=
Romaboy ()
Ответ на: комментарий от Romaboy

wiki читать.

Uncomment the selected locale in /etc/locale.gen and generate it with locale-gen.

Set locale preferences in /etc/locale.conf.

lampslave ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.