LINUX.ORG.RU
ФорумGames

'Сталкер - Тень Чернобыля' & 'Wine'

 , , ,


0

1

Fedora 17 64bit Wine 1.5.8 noveau собственно Сталкер -тень Чернобыля (патч до 1.006 (или как то так))

Не запускается. Ключ -dsound не покатил.

$ wine XR_3DA.exe fixme:msvcrt:MSVCRT__set_abort_behavior _WRITE_CALL_REPORTFAULT unhandled err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded fixme:heap:RtlCompactHeap (0x110000, 0x0) stub err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer «Gallium 0.4 on NVC3», version «1.4 (2.1 Mesa 8.0.2)»). err:ntdll:RtlpWaitForCriticalSection section 0x7daff0c0 «x11drv_main.c: X11DRV_CritSection» wait timed out in thread 0024, blocked by 0009, retrying (60 sec) fixme:dbghelp:elf_search_auxv can't find symbol in module fixme:dbghelp:MiniDumpWriteDump NIY MiniDumpFilterMemory fixme:dbghelp:MiniDumpWriteDump NIY MiniDumpScanMemory err:ntdll:RtlpWaitForCriticalSection section 0x7daff0c0 «x11drv_main.c: X11DRV_CritSection» wait timed out in thread 0024, blocked by 0009, retrying (60 sec) fixme:dbghelp:MiniDumpWriteDump NIY MiniDumpWithDataSegs err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x7ef624aa AL lib: ReleaseALC: 1 device not closed

Ололо, ты его на швободном nouveau пытаешься запускать? Ищи в репах своей федоры блоб от nvidia, и ставь его.

anonymous ()
Ответ на: комментарий от mhogolikii

Блин ещё один федоровец и драйвера, ладно

su -c "yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm"

su -c "yum install akmod-nvidia"

Мб ещё какие то пакеты нужны для nvidia не знаю, после добавления rpmfusion ищите необходимое в вашем пакетном менеджере

Вот так это делалось для AMD: Драйвер (комментарий)

bhfq ★★★★★ ()
Последнее исправление: bhfq (всего исправлений: 1)

немного не в тему, но еще рекомендуется ставить патч 1.004, так как он постабильнее и под него затачиваются многие моды(чудесный AMK Mod)

kravich ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.