LINUX.ORG.RU
ФорумGames

Phobia3


0

0

При запуске выдает:

./phobia3: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory

Ядро 2.6.7
На машине у меня такого файла нету %-\

Ответ на: Re: Phobia3 от burzum

Re: Phobia3

libstdc++-libc6.2-2.so.3

Пакет называется libctdc++ (с версиями)везде. Мог бы из названия допереть.

Не дай бог тебе его стронуть, если у тебя версия не та. Эта хрень была в libstdc++-3.3.4 (или 3.3.2), если не ошибаюсь.

После 3.4.2 она поменялась и в той же федора есть пакет на этот случай - compat-libstdc++-8-3.3.4.2.

P.S. Учу - в следующий раз, как увидишь название, забей его в гугл - наверняка либо упоминание будет, либо на пакет че-нить наткнешься, а дальше уже догадаешься, что качать.

jackill ★★★★★ ()
Ответ на: Re: Phobia3 от jackill

Re: Phobia3

> Не дай бог тебе его стронуть, если у тебя версия не та. Эта хрень > была в libstdc++-3.3.4 (или 3.3.2), если не ошибаюсь.

Чего не делать? Не трогать? Или наоборот, поставить? В /usr/portage есть /usr/portage/sys-libs/libstdc++-v3/libstdc++-v3-3.3.3-r1.ebuild

На качать он его не хочет. emerge libstdc++-v3-3.3.3 посылает.

burzum ()
Ответ на: Re: Phobia3 от burzum

Re: Phobia3

Сам видишь что сказал? emerge libstdc++-v3, а не emerge libstdc++-v3-3.3.3

ergil ★★★ ()
Ответ на: Re: Phobia3 от burzum

Re: Phobia3

Если переходишь с 3.3 на 3.4, то без compat часть программ начнет вылетать. Например, все KDE. KDE я вылечил симлинком, но часть утилит (фак, как же оно называлось-то) не смогли работать - у них сразу символы неразрешенные полезли и т.п.

jackill ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.