LINUX.ORG.RU
ФорумGames

[Quake3][проблемы] нет звука


0

0

В игре нет звука. Вообще. Даже если я закрываю медиаплеер (Totem).

Пишет следующее:

------- sound initialization -------
Could not mmap dma buffer PROT_WRITE|PROT_READ
trying mmap PROT_WRITE (with associated better compatibility / less performance code)
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------

У меня Xubuntu 9.04, ставил с помощью sudo apt-get install quake3-data , потом скопировал с диска pak0.pak в папку с паками. Как освободить /dev/dsp или заставить игру пользоваться микшером?

★★★★★

Re: [Quake3][проблемы] нет звука

sudo apt-get install alsa-oss
quake3 +set s_driver oss

хотя лучше будет заглянуть на http://ioquake3.org/ там как раз новый билд недавно выложили
а вообще, полезно иногда почитать faq

ist76 ★★★★★ ()
Ответ на: Re: [Quake3][проблемы] нет звука от Gary

Re: [Quake3][проблемы] нет звука

Может помочь, может не помочь. Закономерности я не уловил. Лучше всего у меня родная квака от id работала, когда стоял настоящий OSS с opensound.com, но это очень своеобразный дзен и подходит не всем.

ist76 ★★★★★ ()

Re: [Quake3][проблемы] нет звука

openarena не пробовал?

Eddy_Em ☆☆☆☆☆ ()

Re: [Quake3][проблемы] нет звука

В своём *.cfg на звук попробуй выставь best. Или через SDL.

amorpher ★★★★★ ()
Ответ на: Re: [Quake3][проблемы] нет звука от ist76

Re: [Quake3][проблемы] нет звука

>хотя лучше будет заглянуть на http://ioquake3.org/ там как раз новый билд недавно выложили а вообще, полезно иногда почитать faq

Спасибо, ioquake3 помог!

AITap ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.