LINUX.ORG.RU

Steam, печаль.

 ,


1

1

OpenSuSe 13.1 x86_64

#uname -a
Linux home1 3.12.59-47-default #1 SMP Fri Jul 1 06:36:45 UTC 2016 (1920c1d) x86_64 x86_64 x86_64 GNU/Linux

# rpm -qi Mesa
Name        : Mesa
Version     : 12.0.1
Release     : 582.1
Architecture: x86_64
Install Date: Пн 25 июл 2016 23:57:29
Group       : System/Libraries
Size        : 18515229
License     : MIT
Signature   : DSA/SHA1, Пн 25 июл 2016 16:43:52, Key ID bb1af2330f2672c8
Source RPM  : Mesa-12.0.1-582.1.src.rpm
Build Date  : Пн 25 июл 2016 16:40:37
Build Host  : lamb02
Relocations : (not relocatable)
Vendor      : obs://build.opensuse.org/X11

После обновления стима где-то с месяц назад он перестал запускаться.

1. со steam STEAM_RUNTIME=0 лучше не становится,
2. tmp монтировать с exec пробовал, повляетя градусник с обновлением, что-то происходит, потом опять вываливается.
3. NM установлен, но не используется, управление «через ifup» - у меня тут br, qemu-kvm (нет, видяху не пробрасываю).

Идеи, рекомендации ?

> steam
removing troublesome steam-runtime libs...
Running Steam on opensuse 13.1 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)

(steam:27723): Gtk-WARNING **: Загружаемый модуль тем не найден в module_path: «oxygen-gtk»,

(steam:27723): Gtk-WARNING **: Загружаемый модуль тем не найден в module_path: «oxygen-gtk»,
Installing breakpad exception handler for appid(steam)/version(1471977975)
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
[0824/173646:ERROR:main_delegate.cc(779)] Could not load cef_extensions.pak
[0824/173646:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
Installing breakpad exception handler for appid(steamwebhelper)/version(20160823182455)
Installing breakpad exception handler for appid(steamwebhelper)/version(1471976695)
[0824/173646:ERROR:main_delegate.cc(779)] Could not load cef_extensions.pak
Installing breakpad exception handler for appid(steamwebhelper)/version(20160823182455)
Installing breakpad exception handler for appid(steamwebhelper)/version(1471977975)
Installing breakpad exception handler for appid(steamwebhelper)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Created shared memory when not owner SteamController_Shared_mem
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Generating new string page texture 7: 128x256, total string texture memory is 131,07 KB
Generating new string page texture 8: 48x256, total string texture memory is 180,22 KB
Generating new string page texture 9: 256x256, total string texture memory is 442,37 KB
Generating new string page texture 10: 64x256, total string texture memory is 507,90 KB
Installing breakpad exception handler for appid(steam)/version(1471977975)
Installing breakpad exception handler for appid(steam)/version(1471977975)
Setting VR Path Registry runtime path to /home/srg/.local/share/Steam/steamapps/common/SteamVR
vr/vrmanager.cpp (171) : Assertion Failed: BFileExists( /home/srg/.local/share/Steam/steamapps/common/SteamVR/bin/linux64/vrpathreg ) failed
Assert( Assertion Failed: BFileExists( /home/srg/.local/share/Steam/steamapps/common/SteamVR/bin/linux64/vrpathreg ) failed ):vr/vrmanager.cpp:171

Installing breakpad exception handler for appid(steam)/version(1471977975)
assert_20160824173707_17.dmp[27939]: Uploading dump (out-of-process)
/tmp/dumps/assert_20160824173707_17.dmp
Setting VR Path Registry config path to /home/srg/.local/share/Steam/config
vr/vrmanager.cpp (171) : Assertion Failed: BFileExists( /home/srg/.local/share/Steam/steamapps/common/SteamVR/bin/linux64/vrpathreg ) failed
Setting VR Path Registry log path to /home/srg/.local/share/Steam/logs
vr/vrmanager.cpp (171) : Assertion Failed: BFileExists( /home/srg/.local/share/Steam/steamapps/common/SteamVR/bin/linux64/vrpathreg ) failed
crash_20160824173545_1.dmp[27942]: Uploading dump (out-of-process)
/tmp/dumps/crash_20160824173545_1.dmp
/home/srg/.local/share/Steam/steam.sh: line 713: 27723 Ошибка сегментирования                   $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
assert_20160824173707_17.dmp[27939]: Finished uploading minidump (out-of-process): success = yes
assert_20160824173707_17.dmp[27939]: response: CrashID=bp-0675e19e-b24c-4939-b753-bb8c92160824
assert_20160824173707_17.dmp[27939]: file ''/tmp/dumps/assert_20160824173707_17.dmp'', upload yes: ''CrashID=bp-0675e19e-b24c-4939-b753-bb8c92160824''
crash_20160824173545_1.dmp[27942]: Finished uploading minidump (out-of-process): success = yes
crash_20160824173545_1.dmp[27942]: response: CrashID=bp-227d80b3-7120-4d44-a93e-fa3472160824
crash_20160824173545_1.dmp[27942]: file ''/tmp/dumps/crash_20160824173545_1.dmp'', upload yes: ''CrashID=bp-227d80b3-7120-4d44-a93e-fa3472160824''

https://bugzilla.opensuse.org/show_bug.cgi?id=988273

тебе нужна меса собранная с libnettle вместо libcrypto, увы я не держу репа для 13.1, так что или собирай сам с --with-sha1=libnettle или искать в репах васянов вдруг кто собрал для 13.1.

Ну или используй докер с моим имейджем, там будет меса, ллвм и прочее из гита, и точно можно быть уверенным что систему не поломаешь.

Novell-ch ★★★★★ ()
Ответ на: комментарий от Novell-ch

тебе нужна меса собранная с libnettle вместо libcrypto

Неужели Valve до сих пор не зашевелились?

Khnazile ★★★★★ ()
Ответ на: комментарий от Khnazile

На ubuntu и debian steam запускается без каких-либо проблем. Остальной зоопарк они не собираются поддерживать.

ykroop ()
Последнее исправление: ykroop (всего исправлений: 1)

Поставь Ubuntu 16.04 и не парься.

anonymous ()
Ответ на: комментарий от Novell-ch

Благодарю за лаконичный и, как всегда, профессиональный ответ. Если есть время, еще несколько вопросов:

1. В OBS, в описаниях других сборок не вижу указания на сборки с этой либой ни под какую версию суськи, или я слепой - там либо совсем дежурное описание, либо про api opengl. Там твоей сборки нет, пусть и под другие версии суськи ?

2. У меня ati rx480 приезжает, я толком так и не понял, что на данный момент с ее поддержкой. Гуглеж в основном выдает или срачи или фороникс. Не в курсе как оно ? И там теперь, насколько я понял, 1.5 драйвера - открытый и открытый+блоб (amd-pro или как его там). Меса, понятно что последняя нужна, с ядром уже не ясно, бэкпортят ли или строго свежак нужен. На 13.1 я сижу т.к. LTS, leap мне показался сырым и с lts там теперь непонятно. Не знаю, дернуться ли по этому поводу на более свежий дистр (но кто теперь в следующий evergreen не понятно), а это важно и нужна стабильность тогоже уровня. Можешь что посоветовать ? - дергаться ли куда или просто ядро свежее взять в 13.1 и т.д.

3. С докером дел не имел, как твой имидж искать ?

handbrake ★★★ ()
Ответ на: комментарий от anonymous

Я несколько версий подряд пробовал пихать LTS убунту на свои буки/планшеты - не понимаю, как можно сделать такой глюкодром из линукса.

handbrake ★★★ ()
Последнее исправление: handbrake (всего исправлений: 1)
Ответ на: комментарий от handbrake

http://download.opensuse.org/repositories/home:/pontostroy:/branches:/home:/o...

вот тут кто-то собирает для других версий, я пересобрал для 13.1 эта таже что и в Х11:хорг но с другой либой

Ядро нужно последнее для поляриса, 4.7 уже имеет поддержку но чем новее тем лучше. на сусе пока amdgpu pro не работает, разве что опенкл можно заюзать. для 13.1 конечно хватитт и нового ядра + меса из Х11:хорг. Так что как я вижу основная проблема в ядре, можно попытпться создать из kernel:head таргет на 13.1 и получить 4.8-rc3 уже хоть сейчас, но как оно будет на самом деле сказать тяжело.

а по докеру http://www.gearsongallium.com/?p=2744 http://www.gearsongallium.com/?p=2720

Novell-ch ★★★★★ ()
Ответ на: комментарий от handbrake

Как можно быть таким жирным троллем?

anonymous ()
Ответ на: комментарий от ykroop

У меня убунта

Убунта у меня а толку не могу стим поставить хелп народ кто может помочь напишите плиз в вк vk.com/mihasma123

mihasma ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.