LINUX.ORG.RU

Не запускается Steam

 ,


0

1

На Kubuntu 12.04 amd64 не запускается Steam. Вывод такой:

steam
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
unlinked 1 orphaned pipes
removing stale semaphore last operated on by process 16968 with name 0eBlobRegistryMutex_CD5219E7703C06857507D21D911AAF4D
removing stale semaphore last operated on by process 16968 with name 0eBlobRegistrySignal_CD5219E7703C06857507D21D911AAF4D
removing stale semaphore last operated on by process 16968 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 16968 with name 0eSteamEngineLock
surface_linux.cpp (1528) : Assertion Failed: X context is not using direct rendering. Unfasten your seatbelt...

Assert( Assertion Failed: X context is not using direct rendering. Unfasten your seatbelt...
 ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/vgui2/src/surface_linux.cpp:1528

Installing breakpad exception handler for appid(steam)/version(1359141904_client)
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
[0126/130205:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130126130205_1.dmp
success = yes
response:  CrashID=bp-7bbc0bcb-2864-40c0-9201-f23e72130126
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
Installing breakpad exception handler for appid(steam)/version(1359141904_client)
/home/tim/.local/share/Steam/steam.sh: line 343: 17072 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Пакет Steam последний, установился без ошибок (требуемые 32-битные зависимости установил). Видеокарта — Nvidia 6600GT, драйвер версии 295.40.

В чём может быть проблема?

P.S.: играть не собираюсь. Просто решил проверить, вдруг Steam для Linux — это мистификация?

☆☆☆☆☆

Просто решил проверить, вдруг Steam для Linux — это мистификация?

Вот ты и убедился :)

kerneliq ★★★★★ ()

Смущает:

surface_linux.cpp (1528) : Assertion Failed: X context is not using direct rendering.
Быть может, видеокарта/драйвер уже староваты?

ArtKun ★★★★★ ()

295.40

Ему необходима как минимум 310 ветка.

StalinEXE ★★★★★ ()
Ответ на: комментарий от StalinEXE

А она мою карту поддерживает?

Только вот не понимаю, зачем она ему для игр 5-15-летней давности?

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от Ttt

Понятия не имею, если честно, насчёт карточки...
Видать, чтобы работали как старые, так и новые игрушки.

StalinEXE ★★★★★ ()

запусти из консоли. Стим пошкребёт по сусекам и предложит докачать некоторые пакеты. Потом попросить пароль судо.

darkenshvein ★★★★★ ()

По идее должно запускаться, а ругаться на драйвер будет при попытке запуска какой-нибудь игры.

PaRuSoft ★★★ ()
Ответ на: комментарий от Ttt

из-под рута, что ли? :)
ещё соображение, старый баг с kdm. Некоторые упоротые приложения не могут вылезти из консоли в иксы, не находят дисплей. Перепроверить в гноме3 и с lightdm.

darkenshvein ★★★★★ ()
Ответ на: комментарий от darkenshvein

ещё соображение, старый баг с kdm. Некоторые упоротые приложения не могут вылезти из консоли в иксы, не находят дисплей.

Так при первом запуске появилось графическое окно с полосой прогресса, сигнализировавшее о том, что докачиваются необходимые компоненты.

Ttt ☆☆☆☆☆ ()

Виноват довольно кривой порт Steam под Linux.

Hitray ()
Ответ на: комментарий от Hitray

Ну а почему у других запускается, а у меня нет?

Ttt ☆☆☆☆☆ ()

(требуемые 32-битные зависимости установил)

а шо сборки под 64 нету?

eR ★★★★★ ()
Ответ на: комментарий от darkenshvein

ещё соображение, старый баг с kdm. Некоторые упоротые приложения не могут вылезти из консоли в иксы, не находят дисплей.

Это фича, а не баг. Приложения от других пользователей не допускаются к текущей сессии, если вежливо об этом не попросят. Поэтому от рута софт надо запускать через kdesu, а не через sudo или su.

Axon ★★★★★ ()

Попробуй обновить драйвера из xorg-edgers. Если комп у тебя после этого вообще включится, то стим тоже =)

Kor03d ★★ ()

Что-то мне подсказывает, что твоя карточка поддерживается актуальными драйверами. Обновляйся.

Kor03d ★★ ()
Ответ на: комментарий от Kor03d

Актуальные — это 304.64. У меня (после обновления до 12.10) — 304.43. Не думаю, что разница большая.

А 310 как раз вроде не поддерживают.

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от Ttt

304.64 актуально в убунту. А на их сайте (и в ppa) доступны и посвежее.

Kor03d ★★ ()
Ответ на: комментарий от Ttt

В 310 версии Nvidia дропнула поддержку 6ххх и 7ххх. Последний драйвер для этих карт будет 304.

Xe0N ()
Ответ на: комментарий от Xe0N

У меня при щелчке по ярлыку Steam перезагружаются «иксы», я возвращаюсь к меню входа в систему. Если запускать через Ctrl+Alt+F1, пишет (в конце абзаца): «Unable to open a connection to X. Check your DISPLAY environment and make sure...» и т.д. Решение с сайта Steam не помогает: https://support.steampowered.com/kb_article.php?ref=4050-WOJB-0608

Stepan12 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.