LINUX.ORG.RU

Не собирается Ruby ruby-build'ом.

 ,


0

1

Не получается собрать Ruby с помощью rbenv. Нагуглить ошибки не смог.

RVM при этом собирает нормально.

rbenv install 2.0.0-p247
Downloading ruby-2.0.0-p247.tar.gz...
-> http://dqw8nmjcqpjn7.cloudfront.net/c351450a0bed670e0f5ca07da3458a5b
Installing ruby-2.0.0-p247...

BUILD FAILED

Inspect or clean up the working tree at /tmp/ruby-build.20131113124643.18839
Results logged to /tmp/ruby-build.20131113124643.18839.log

Last 10 log lines:
compiling array.c
In file included from vm.c:82:0:
vm_eval.c: In function ‘rb_catch_obj.constprop.54’:
vm_eval.c:1813:20: warning: argument ‘tag’ might be clobbered by ‘longjmp’ or ‘vfork’ [-Wclobbered]
 rb_catch_obj(VALUE tag, VALUE (*func)(), VALUE data)
                    ^
linking miniruby
collect2: error: ld returned 1 exit status
Makefile:195: recipe for target 'miniruby' failed
make: *** [miniruby] Error 1

Полный лог сборки

cc -v
Using built-in specs.
COLLECT_GCC=cc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.2/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: /build/gcc/src/gcc-4.8.2/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++ --enable-shared --enable-threads=posix --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --enable-gnu-unique-object --enable-linker-build-id --enable-cloog-backend=isl --disable-cloog-version-check --enable-lto --enable-gold --enable-ld=default --enable-plugin --with-plugin-ld=ld.gold --with-linker-hash-style=gnu --disable-install-libiberty --disable-multilib --disable-libssp --disable-werror --enable-checking=release
Thread model: posix
gcc version 4.8.2 (GCC)

Ответ на: комментарий от renya

Типичный ответ помощи на проблемы возникающие в альтернативном софте.

IIIypuk ★★ ()
Ответ на: комментарий от IIIypuk

Ты бы еще написал, что за дистрибутив например, не?

renya ★★★★★ ()
Ответ на: комментарий от renya

Да какая разница? Дистрибутив Arch.

libyaml-0.1.4
linux-3.11.6
версия gcc в шапке.

IIIypuk ★★ ()

Если на арче что-то не получается, а иначе получается - делай как получается. Откуда кому знать, какую библиотеку/зависимость или настройку компилятора арчемейнтейнерам вздумалось обновить сегодня? Неизвестно. Работает RVM - пусть будет RVM, тем более, что он фичастее намного.

Alve ★★★★★ ()

В общем попробовал ещё раз собрать и снова получил ошибку.
Оказалось таки просто не хватало места в /tmp

IIIypuk ★★ ()
Последнее исправление: IIIypuk (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.