LINUX.ORG.RU

WxHaskell


0

1

Здравствуйте, такая проблема: не могу установить библиотеки wx и wxCore установил libgtk2.8-dev, набираю cabal install wxCore. выдает

[1 of 1] Compiling Main             ( /tmp/wxcore-0.13.2.125440/wxcore-0.13.2.1/Setup.hs, /tmp/wxcore-0.13.2.125440/wxcore-0.13.2.1/dist/setup/Main.o )
Linking /tmp/wxcore-0.13.2.125440/wxcore-0.13.2.1/dist/setup/setup ...
/bin/sh: wxdirect: not found
/bin/sh: wxdirect: not found
/bin/sh: wxdirect: not found
/bin/sh: wxdirect: not found
Configuring wxcore-0.13.2.1...
setup: Missing dependency on a foreign library:
* Missing C library: wx_gtk2u_media-2.8
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
cabal: Error: some packages failed to install:
wxcore-0.13.2.1 failed during the configure step. The exception was:
ExitFailure 1

что за «wx_gtk2u_media-2.8»?

★★★★★

Ответ на: комментарий от anatolat

Я же написал, что эта библиотека уже стоит.

Aswed ★★★★★ ()
Ответ на: комментарий от tensai_cirno

Enjoy your Haskell. Чтобы умудриться собрать Haskell Platform из сорцов, нужно иметь как минимум бубен из кожи тюлена-девственника, родившегося в полнолуние.

buddhist ★★★★★ ()
Ответ на: комментарий от malbolge

Я одно время пакетики собирал для зенволка и слакса.

buddhist ★★★★★ ()

а ты сишные либы поставил?

kyz ()
Ответ на: комментарий от Aswed

установил, не помогло не хватает ему wx_gtk2u_media-2.8

а можно полные steps to reproduce? Т.е. что откуда качал и как собирал. Попробую воспроизвести и забороть.

Sectoid ★★★★★ ()

Коротенький гуглёж по названию либы показал, что у пользователей перла и луа ровно те же проблемы.

Miguel ★★★★★ ()

Кстати, советуют сбилдить wxwidgets с параметром --enable-mediactrl.

Miguel ★★★★★ ()
Ответ на: комментарий от buddhist

а нафига вобще haskell platform под linux? это всяким недоосям с проблемами с установкой нужно.

А вобще можно поставить gentoo и не иметь никаких проблем.

qnikst ★★★★★ ()
Ответ на: комментарий от buddhist

Там вообще-то минимальные зависимости. Собирал, и не один раз.

tensai_cirno ★★★★★ ()
Ответ на: комментарий от Sectoid

уствновил wx2.8-headers libwxgtk2.8-0 libwxgtk2.8-dev из gutsy-wx. Ругаться на wx_gtk2u_media-2.8 перестал, но появились другие проблемы: Скачал сырцы wxhaskell-0.11.1.2 (т.к. кабал 12 ставить патается). После sudo make install

...
wxcore-0.11.1.2: missing id field
wxcore-0.11.1.2: dependency "base-4.2.0.0" doesn't exist (use --force to override)
wxcore-0.11.1.2: dependency "containers-0.3.0.0" doesn't exist (use --force to override)
wxcore-0.11.1.2: dependency "haskell98-1.0.1.1" doesn't exist (use --force to override)
wxcore-0.11.1.2: dependency "bytestring-0.9.1.5" doesn't exist (use --force to override)
wxcore-0.11.1.2: dependency "stm-2.3" doesn't exist (use --force to override)
make: *** [wxcore-register] Ошибка 1

если ставить через кабал (cabal install wxcore) то:

src/cpp/eljevent.cpp:1082:0:
     error: ‘wxEVT_COMMAND_AUITOOLBAR_TOOL_DROPDOWN’ was not declared in this scope
src/cpp/eljevent.cpp: In function ‘int expEVT_COMMAND_AUITOOLBAR_OVERFLOW_CLICK()’:

src/cpp/eljevent.cpp:1083:0:
     error: ‘wxEVT_COMMAND_AUITOOLBAR_OVERFLOW_CLICK’ was not declared in this scope
src/cpp/eljevent.cpp: In function ‘int expEVT_COMMAND_AUITOOLBAR_RIGHT_CLICK()’:

src/cpp/eljevent.cpp:1084:0:
     error: ‘wxEVT_COMMAND_AUITOOLBAR_RIGHT_CLICK’ was not declared in this scope
src/cpp/eljevent.cpp: In function ‘int expEVT_COMMAND_AUITOOLBAR_MIDDLE_CLICK()’:

src/cpp/eljevent.cpp:1085:0:
     error: ‘wxEVT_COMMAND_AUITOOLBAR_MIDDLE_CLICK’ was not declared in this scope
src/cpp/eljevent.cpp: In function ‘int expEVT_COMMAND_AUITOOLBAR_BEGIN_DRAG()’:

src/cpp/eljevent.cpp:1086:0:
     error: ‘wxEVT_COMMAND_AUITOOLBAR_BEGIN_DRAG’ was not declared in this scope
cabal: Error: some packages failed to install:
wxcore-0.13.2.1 failed during the building phase. The exception was:
ExitFailure 1

Aswed ★★★★★ ()
Ответ на: комментарий от Aswed

Легко: cabal install Chart-0.14 (fetch тоже понимает).

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.