LINUX.ORG.RU

ubuntu 16.04: sudo apt install edb-debugger: package not found?

 ,


0

1

Пытаюсь поставить на чистенькую ubuntu 16.04 (учебная машина) отладчик edb.

Делаю это так, как написано в тысяче мест в интернете:

sudo apt-get update
sudo apt-get install edb-debugger

Пишет, что пакет не найден.

Пробую на другом компе - вуаля! С первой попытки!

Пытаюсь найти разницу, вижу, что на ubuntu 18 и 20 версии все работает «из коробки». Но на учебной машине я не могу обновить то, что там понаставлено.

Видимо, у всех, у кого это работает, уже был подключен нужный репозиторий с пакетами, но какой?

Связываться со сборкой из исходников не хочу, потому что этот ад зависимостей между версиями буста и qt я не разгребу никогда.

Посоветуйте, пожалуйста, какой магической командой подключается нужный репозиторий?

Спасибо

Пытаюсь поставить на чистенькую ubuntu 16.04 (учебная машина) отладчик edb. Пишет, что пакет не найден.

Логично, под 16.04 его нет:

https://repology.org/project/edb-debugger/versions

Делаю это так, как написано в тысяче мест в интернете:

Может там пишут про актуальные версии системы?

Пробую на другом компе - вуаля! С первой попытки!

Может потому что там не 16.04?

Посоветуйте, пожалуйста, какой магической командой подключается нужный репозиторий?

Нет такого репозитория. Либо обновляйте систему, либо собирайте руками.

slovazap ★★★★★ ()