LINUX.ORG.RU

не находится libQtAssistantClient.so.4 в CentOS7

 ,


0

1

Всем добрый вечер!
Пытаюсь портировать прогу с Debian'а на ЦентОС, но запнулся на

error while loading shared libraries: libQtAssistantClient.so.4: cannot open shared object file: No such file or directory

и фиг знает где его в ЦентОСи искать, отдельно пакета нет, сам qt-assistant тоже ничем не помог...

нид хелп, плиз! :)

$ dnf provides *libQtAssistantClient* 
alpha ★★★★★ ()
Ответ на: комментарий от alpha

dnf 'a я не нашел, а

[root@localhost ~]#  yum provides *libQtAssistantClient* 
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.h1host.ru
 * extras: mirror.h1host.ru
 * updates: mirror.h1host.ru
base/7/x86_64/filelists_db                                                                                                                                                                                            | 6.6 MB  00:00:00     
extras/7/x86_64/filelists_db                                                                                                                                                                                          | 423 kB  00:00:00     
updates/7/x86_64/filelists_db                                                                                                                                                                                         | 1.5 MB  00:00:00     
No matches found

это как?.. :(

metawishmaster ★★★★ ()
Ответ на: комментарий от alpha

зато

[root@localhost ~]#  yum provides *AssistantClient* 
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.h1host.ru
 * extras: mirror.h1host.ru
 * updates: mirror.h1host.ru
qt3-devel-docs-3.3.8b-51.el7.x86_64 : Documentation for the Qt 3 GUI toolkit
Repo        : base
Matched from:
Filename    : /usr/share/man/man3/QAssistantClient.3qt.gz


т.е., хана, в цетоси с 4-ой Qt все грустно?

metawishmaster ★★★★ ()
Ответ на: комментарий от metawishmaster

подключи epel-репозиторий

это с федоры:

$ dnf provides *libQtAssistantClient*
Last metadata expiration check: 4 days, 19:44:08 ago on Sun Feb  5 22:26:05 2017.
qt-assistant-adp-4.6.3-12.fc24.i686 : Compatibility version of Qt Assistant
Repo        : fedora

qt-assistant-adp-4.6.3-12.fc24.x86_64 : Compatibility version of Qt Assistant
Repo        : fedora

но судя по pkgs.org в центоси в epel этот пакет тоже есть

https://pkgs.org/download/qt-assistant-adp

alpha ★★★★★ ()
Ответ на: комментарий от alpha

спасибо! буду разбираться, уже лет пятнадцать на rpm-based дистрах не сидел %)

metawishmaster ★★★★ ()
Ответ на: комментарий от metawishmaster

для подключения репозитория достаточно

yum install epel-release
alpha ★★★★★ ()
Ответ на: комментарий от alpha

угу, нашел, тока dnf завис на апдейтах %)
но ниче, с юмом получилось :)

спасибо! :)

metawishmaster ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.