LINUX.ORG.RU

Задействование CUDA и NVENC в OBS

 


0

1

Привет, друзья! Хочу пересобрать с --enable-cuda некоторые программы из дефолтного репозитория суси. Как задействовать официальную репу NVIDIA?

И ещё. Хочу пересобрать packman-овский ffmpeg с поддержкий NVENC, чтобы делать -vcodec nvenc -preset hq -tune film. На локалхосте всё уже сделано, но я-то хочу пакет. Как можно выдрать libnvidia-encode.so из драйвера и сделать отдельным пакетом?

Как задействовать официальную репу NVIDIA?

Только локально или в своём OBS.

На локалхосте всё уже сделано, но я-то хочу пакет.

Не проще использовать osc build?

dinn ★★★★★ ()
Ответ на: комментарий от dinn

Ну. Я делал так. При запуске ffmpeg он пишет параметры, с которым он собран. Я всего лишь дописал --enable-nonfree и --enable-nvenc. Также мне понадобилось установить header-файлы из какого-то архива с примерами кода NVENC.

ZenitharChampion ★★★★★ ()

Как задействовать официальную репу NVIDIA?

Я не уверен что она хочет чтобы её задействовали.

Как можно выдрать libnvidia-encode.so из драйвера и сделать отдельным пакетом?

Зачем "выдёргивать её из драйвера" (что бы это не значило)? Юзерспейсные компоненты там все друг на друга завязаны по версиям. Дистрибутор и так должен был сделать subpackage с nvenc. Для сборки и дистрибьюта программ с nvenc нужно ещё очевидно опакечивать CUDA SDK (а может быть есть отдельно NVENC SDK).

d_a ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Ну и норм. Хедеры упаковать, в ffmpeg их потребовать и драйверный subpackage nvenc.

d_a ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

а попробовать офф pdf почитать никак?

я тебе лично уже на эот вопрос отвечал,еще весной когда ты тред в games создавал

вот ссылка на пдф и страничку нвидии https://developer.nvidia.com/ffmpeg

пдф самый последний снизу на той странице http://developer.download.nvidia.com/compute/redist/ffmpeg/1511-patch/FFMPEG-...

при сборки ффмпега просто убрать --енабле-нвресизе
и все-куда не нужен

(также если не знал-«спец драйвера cuda-nvidia-версия-блаблабла» тоже вообще не нужны,достаточно любого драйвера начиная с 340,они все включают куда хеадеры по дефолту,для всех линуксов

anonymous ()
Ответ на: комментарий от anonymous

> (также если не знал-«спец драйвера cuda-nvidia-версия-блаблабла» тоже вообще не нужны,достаточно любого драйвера начиная с 340,они все включают куда хеадеры по дефолту,для всех линуксов

Спасибо за информацию. В моём случае сойдут и пакеты с CUDA из отдельного репозитория. Для ImageMagick, буду собирать в OBS (аналог PPA).

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

если что я сюсе юзер,сам собирал ффмпег для сюси-все работает не первый год

репы делать лень офк

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.