LINUX.ORG.RU

Не компилится модуль ядра Catalyst 13.1 legacy.


0

1

На такой вот оси

Linux LIKAN-PC 3.10-2-686-pae #1 SMP Debian 3.10.7-1 (2013-08-17) i686 GNU/Linux
Не собирается модуль ядра для проприетарных дров амд 13.1 legacy. Выплевывает вот такой вот лог http://pastebin.com/6Sx19G2v Поначалу жаловался, что мол не установлены заголовочные файлы ядра (хотя все сделал, как доктор прописал apt-get install linux-headers-$(uname -r)), видите ли, файлика ему вот такого не хватает : /lib/modules/3.10-2-686-pae/build/include/linux/version.h. Ну я и симлинкнул вот отсюда : /usr/include/linux/version.h. Это часом не было ошибкой?

★★★

это гуано больше не нужно, ставь открытый

smilessss ★★★★★ ()
Ответ на: комментарий от smilessss

Я б рад. Но железки у меня довольно старые, и производительность у открытого довольно сильно проседает.

LIKAN ★★★ ()
Ответ на: комментарий от smilessss

radeon hd 2600. Производительность оконного менеджера, любого. Меня раздражает, когда окна движутся рывками или когда виден тирниг. Я понимаю, что для ТруЪМегаМатерогоСуперЛинуксоида эти доводы покажутся детскими, и не буду его осуждать. Это и вправду иррационально, нелогично и тд, но это подсознательное, ничего не могу с этим поделать.

LIKAN ★★★ ()
Ответ на: комментарий от LIKAN

когда ты в последний раз ставил открытый драйвер ?
поставь его сейчас
поставь 3.11 ядро
git версии дров и mesa
думаю изменишь своём мнение
там запилили vdpau + энергосбережение

smilessss ★★★★★ ()
Ответ на: комментарий от LIKAN

Странно, debian jessie x64. Дрова из реп установились в один клик, без всякого геморроя.

sergio1204 ★★ ()

Debian 3.10.7-1 (2013-08-17) i686 GNU/Linux

Description:
Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4

Если с сайта качаете, смотрите хотя бы зависимости. Еще и Xserver скорее всего новее, чем надо, не только ядро. На убунте я ставил легаси из РРА, он был пересобран под новое ядро и xserver даунгрейдился. Так что либо ищите репозиторий соответствующий, либо ставьте свободный драйвер, он уже готов

MyFreedom ★★★ ()
Последнее исправление: MyFreedom (всего исправлений: 1)

SMP Debian 3.10.7-1
13.1 legacy

В дебиан 7 оно должно работать. Может стоит использовать его?

onon ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.