LINUX.ORG.RU

Переключение раскладки клавиатуры в KDE


0

0

Проблемма стара как КДЕ. Не могу настроить переключение раскладок с помощью клавы. Работает только Ctrl+Alt+K, да и то в одну сторону. Конфигурирование через апплет настройки в КДЕ не помогает. Вручную отредактировал /etc/X11/XF86Config-4: Section "InputDevice" Identifier "Keyboard0" Driver "keyboard" Option "CoreKeyboard" Option "XkbModel" "pc105" Option "XkbLayout" "us,ru" Option "XKbOptions" "grp:alt_shift_toggle" EndSection

Что еще нужно сделать? Заранее спасибо за ответ

Re: Переключение раскладки клавиатуры в KDE

Поставь kkbswitch, очень хорошая вещь.

SK ()

Re: Переключение раскладки клавиатуры в KDE

Где-то сделал ошибку в X.conf У меня всегда работало.

Например? у меня так:

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "microsoftpro"
Option "XkbLayout" "us,ru(winkeys),ua(winkeys)"
Option "XkbOptions" "grp:ctrl_shift_toggle"
EndSection

Иксы перезапустил? Файл тот который нужно правил? В логах икс-сервера видно как он эти опции обрабатывает? в програме xev видны события ISO_NextGroup/ISO_PrevGroup на нажатия комбинации переключения?

smartly ★★★ ()

Re: Переключение раскладки клавиатуры в KDE

1) Идем в "Центр управления" -> "Региональные и специальные возможности" 2) Выбираем "Раскладка клавиатуры"->"Раскладка" 3) Удаляем все из активных раскладок 4) Добавляем в активные раскладки "Русская" 5) Отмечаем галочкой "Включить латинскую раскладку" 6) "Вариант раскладки" выбираем "winkeys" 7) Идем в "Комбинации клавиш" и выбираем нужную комбинацию клавиш для переключения (да хоть и Ctrl+Shift)

Skull ★★★★★ ()

Re: Переключение раскладки клавиатуры в KDE

и нифига не работает :-) - хоть в кде, хоть в конфиге иксов правь. по крайней мере в 3 федоре. я уже и плюнул на это. мож, кто вылечил?

Vinill ★★ ()

Re: Переключение раскладки клавиатуры в KDE

>Идем в "Комбинации клавиш" и выбираем нужную комбинацию клавиш для переключения (да хоть и Ctrl+Shift)

С какой версии эта вещь заработала? Помнится в 3.3 мне ее не удалось заставить воспринять ctrl+shift.

jackill ★★★★★ ()

Re: Переключение раскладки клавиатуры в KDE

В KDE вообще как-то странно с переключением придумали.
Смешали в одну кучу настройку и xkb и своего переключателя.

Свой работает нормально, но не на всех клавишах.

Настройка xkb - вместо нормального переключения между несколькими языками можно выбрать только переключение между одним языком и английской раскладкой(выбрав один язык и галку). При попытке выбрать несколько языков имеет действие только последний setxkbmap.

В общем, этот аплет настройки вообще нужно выбросить и включить в KDE что-то вроде упомянутого kkbswitch.

Murr ★★ ()

Re: Переключение раскладки клавиатуры в KDE

>и нифига не работает :-) - хоть в кде, хоть в конфиге иксов правь. по
>крайней мере в 3 федоре. я уже и плюнул на это. мож, кто вылечил?

В FC3, да и везде это должно сработать, т.к. описана правильная настройка xkb из этого дурного аплета.

Murr ★★ ()

Re: Переключение раскладки клавиатуры в KDE

> 7) Идем в "Комбинации клавиш" и выбираем нужную комбинацию клавиш для
>переключения (да хоть и Ctrl+Shift)
Только не комбинации клавиш, а вкладку "параметры xkb" в том же аплете.
Там можно выбрать ctrl+shift из списка.

Murr ★★ ()

Re: Переключение раскладки клавиатуры в KDE

Делал и по FAQ и сам ковырялся - бесполезно. Хотя в FC2, RH9 и еще в нескольких дистрибутивах проблем нет. Сделал себе просто идиотскую настройку по трем клавишам из цетра управления кде, хоть так работает. уже привык :)

Vinill ★★ ()

Re: Переключение раскладки клавиатуры в KDE

Спасибо Вам Skull, все заработало. Хотя индикатору пофиг, все время русский показывает. Но вообще-то тупо зделан апплет. А на файл XF86Config-4 KDE клала с прибором ))) Но ведь, по-идее, должен быть где-то файл, который за все это отвечает. И еще вопросец. Руссифицировал консоль, но в КДЕ в консоли по-прежнему вместо русского знаки вопроса. Можно это как-нибудь подшаманить? Дистрибутив Simple Mepis 3.3.1 Заранее спасибо за ответы

Normann ()

Re: Переключение раскладки клавиатуры в KDE

Vinill:

Ну у меня то так работает в FC3.
Еще раз:
kcontrol->Regional&Accessibility->Keyboard Layout
1) выбрать в active layouts только Russian(ru), других раскладок в active layouts быть не должно, поставить галку "Include latin layout".

В поле command должна появиться команда "setxkbmap -model pc104 -layout us,ru -variant ,basic".

2) выбрать tab Xkb options, установить Enable Xkb options, Reset Old options, выбрать Alt+Shift changes group, Scroll lock LED shows alternate group

должна появиться команда "setxkbmap -option -option grp_led:scroll,grp:alt_shift_toggle".

После нажатия на Apply должно работать переключение по Alt-Shift(перекрывает настройки в X86Config).

Murr ★★ ()

Re: Переключение раскладки клавиатуры в KDE

kkbswitch

KRoN73 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.