LINUX.ORG.RU

mail-notification: пугающие зависимости при установке

 , ,


0

1

Хотел поставить напоминалку на новоустановленный Linux Mint 15.0 Cinnamon i386. Дал комманду

$ sudo aptitude install mail-notification

[sudo] password for askinfra: 
Следующие НОВЫЕ пакеты будут установлены:        
  curl{a} evolution{a} evolution-common{a} evolution-plugins{a} 
  fetchyahoo{a} getlive{a} libconvert-binhex-perl{a} 
  libcrypt-ssleay-perl{a} libedataserverui-3.0-4{a} 
  libencode-locale-perl{a} liberror-perl{a} libevolution{a} 
  libfile-listing-perl{a} libfont-afm-perl{a} libgnomevfs2-extra{a} 
  libgtkhtml-4.0-0{a} libgtkhtml-4.0-common{a} libgtkhtml-editor-4.0-0{a} 
  libhtml-form-perl{a} libhtml-format-perl{a} libhtml-parser-perl{a} 
  libhtml-tagset-perl{a} libhtml-tree-perl{a} libhttp-cookies-perl{a} 
  libhttp-daemon-perl{a} libhttp-date-perl{a} libhttp-message-perl{a} 
  libhttp-negotiate-perl{a} libio-multiplex-perl{a} 
  libio-socket-ssl-perl{a} liblwp-mediatypes-perl{a} 
  liblwp-protocol-https-perl{a} libmail-spf-perl{a} libmime-tools-perl{a} 
  libnet-cidr-perl{a} libnet-http-perl{a} libnet-server-perl{a} 
  libnet-ssleay-perl{a} libnetaddr-ip-perl{a} libpst4{a} 
  libsys-hostname-long-perl{a} libterm-readkey-perl{a} libwww-perl{a} 
  libwww-robotrules-perl{a} libytnef0{a} mail-notification 
  mail-notification-evolution{a} postfix{a} procmail{a} re2c{a} 
  spamassassin{a} spamc{a} 
0 пакетов обновлено, 52 установлено новых, 0 пакетов отмечено для удаления, и 12 пакетов не обновлено.
Необходимо получить 9 836 kБ архивов. После распаковки 48,6 MБ будет занято.
Хотите продолжить? [Y/n/?] 

Нельзя иначе? Почему так много пакетов и зачем для напоминалки ставить почтовый сервер и спамфильтр? Или это такая шутка?

★★★★★

Пробовал запустить c --no-install-recommends?

olibjerd ★★★★★ ()
Ответ на: комментарий от Excavator

«Чтобы вам напоминали о почте, рекомендуется самому стать почтальоном». :) Да, спасибо, сейчас намного меньше пакетов — думаю, самое то.

askinfra@vvv-leee ~ $ sudo aptitude install --without-recommends mail-notification
Следующие НОВЫЕ пакеты будут установлены:        
  libgnomevfs2-extra{a} mail-notification 
Следующие пакеты РЕКОМЕНДОВАНЫ, но установлены НЕ БУДУТ:
  fetchyahoo getlive mail-notification-evolution 
0 пакетов обновлено, 2 установлено новых, 0 пакетов отмечено для удаления, и 12 пакетов не обновлено.
Необходимо получить 500 kБ архивов. После распаковки 2 101 kБ будет занято.
Хотите продолжить? [Y/n/?] 
Почему-то, среди рекомендованных нету тех (наверно, зависимости и рекомендованные рекомендованных были).

Infra_HDC ★★★★★ ()
Ответ на: комментарий от Infra_HDC

Почему-то, среди рекомендованных нету тех (наверно, зависимости и рекомендованные рекомендованных были).

В точку! mail-notification-evolution по-любому зависит от evolution, а от него всё остальное

alix ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.