LINUX.ORG.RU

Ужасно работает переключалка раскладок в Gnome

 , ,


0

1
  • На alt-shift нормально не настроить
  • если настроить, то работает через раз (нужно нажать «до конца», ну т.е. вообще до конца)
  • в «Overview» и диалоге запуска (Alt+F2) вообще не переключается
  • если пытаться настроить через «нормальный» диалог, то вообще фигня получается (Ctrl+Space не работает, алсо комбинация зависит от языка (шо вообще ппц))
  • иногда вот набираешь, успеешь набрать уже два символа и тут раскладка меняется и символы тоже изменяются на символы из другой раскладки о_О

На всякий случай cast Ochkarik

★★★★★

Ответ на: комментарий от Black_Roland

И возможно еще в иксах настройки переключалки нужно прописать, что-то вроде:

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us,ru"
        Option "XkbModel" "pc105"
        Option "XkbOptions" "grp:shifts_toggle,grp_led:caps"
EndSection

Black_Roland ★★★★ ()

А я просто засунул в стартовый скрипт вот такое

setxkbmap  -option grp:alt_shift_toggle,grp_led:scroll "us,ru" &

the_green ()

Шел 2013 год, а в Gnome все те же нарколыги заправляют балом.

bhfq ★★★★★ ()

Можно повесить переключатель на Caps.. будет переключать без задержек.

visaidj ()
Ответ на: комментарий от Black_Roland
% cat /etc/X11/xorg.conf.d/10-keyboard.conf
Section "InputClass"
    Identifier             "Keyboard Defaults"
    MatchIsKeyboard	   "yes"
    Option	           "XkbLayout" "us,ru"
    Option                 "XkbOptions" "grp:alt_shift_toggle,grp_led:caps,ctrl:nocaps"
EndSection

Но Gnome, походу, игнорит это

derlafff ★★★★★ ()
Ответ на: комментарий от bass

Может таки как-нибудь можно сделать так, чтобы раскладка переключалась не по отпусканию клавиши, а по нажатии?

derlafff ★★★★★ ()
Ответ на: комментарий от derlafff

Естессно. Настройки через xorg.conf у меня никогда не работали (хотя у кого-то на федоре полгода назад они и заводились). А гном ставит настройки заново, ориентируясь на пользовательские настройки из Gconf или где они там сейчас. А если ты ещё поставишь приблуду типа gxneur, то она тоже будет ставить как ей вздумается.

Deleted ()
Ответ на: комментарий от derlafff

так индикатор в панельке превращается в тыкву

1. Используй grp:lctrl_rctrl_switch, и тебе не нужен будет индикатор. 2. можно не удалять файлы, а просто отключить keyboard плагин в settings-daemon

DonkeyHot ★★★★★ ()

Давно не заходил, прошу прощения.

Сам сейчас сижу на GNOME 3.8.3 (Mageia). Переключалка работает везде, и в Overview, и в Alt-F2, и в Looking Glass, и в диалогах ввода пароля. Но, разумеется, нет добра без худа, это же наш старый добрый GNOME ;) Например, если использовать Alt-Shift для переключения, то отваливается Alt-Shift-Tab (переключение окон в обратном порядке, я часто этим пользовался), а также вообще любые сочетания Alt-Shift-*. Думаю, надо писать баг-репорт.

Ochkarik ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.