LINUX.ORG.RU

debian sid - Xlib: extension «NV-GLX» missing on display


0

1

когда-то давно была у меня видяха от нвидии, потом я снова установил свой радеон 9600. И только недавно заметил, что иногда получаю сообщение - Xlib: extension «NV-GLX» missing on display

увы, родных дров от нвидии у меня уже нет, поэтому uninstall сделать им не могу. Установлены открытые дрова radeon - xserver-xorg-video-radeon

ldconfig -p | grep -i Xlib
libgdk_pixbuf_xlib-2.0.so.0 (libc6) => /usr/lib/i386-linux-gnu/libgdk_pixbuf_xlib-2.0.so.0

ldconfig -p | grep libGL
libGLU.so.1 (libc6) => /usr/lib/i386-linux-gnu/libGLU.so.1
libGLEW.so.1.7 (libc6) => /usr/lib/i386-linux-gnu/libGLEW.so.1.7
libGL.so.1 (libc6, ABI

выдержка из лога иксов

[    71.062] (II) LoadModule: "dri"
[    71.062] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    71.082] (II) Module dri: vendor="X.Org Foundation"
[    71.082]    compiled for 1.12.4, module version = 1.0.0
[    71.082]    ABI class: X.Org Server Extension, version 6.0
[    71.082] (II) Loading extension XFree86-DRI
[    71.082] (II) LoadModule: "glx"
[    71.101] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    71.133] (II) Module glx: vendor="X.Org Foundation"
[    71.133]    compiled for 1.12.4, module version = 1.0.0
[    71.133]    ABI class: X.Org Server Extension, version 6.0
[    71.133] (==) AIGLX enabled
[    71.133] (II) Loading extension GLX


подскажите, как вручную вычистить библиотеки от нвидии, которые выдают эту ошибку



увы, родных дров от нвидии у меня уже нет, поэтому uninstall сделать им не могу.

я тебе сочувствую.

# apt-get autoremove --purge nvidia*
вроде бы так

i_gnatenko_brain ★★★★ ()
Последнее исправление: i_gnatenko_brain (всего исправлений: 1)

nvidia-installer-cleanup не поможет? Это если ставил не с репозитария.

Deleted ()
Последнее исправление: Mystra_x64 (всего исправлений: 1)
Ответ на: комментарий от i_gnatenko_brain

apt-get autoremove --purge nvidia*
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет nvidia-installer.log
E: Не удалось найти пакет по регулярному выражению «nvidia-installer.log»


dpkg-reconfigure nvidia-installer-cleanup

тоже не помогло

Sky777 ()
Ответ на: комментарий от Sky777

dpkg-reconfigure nvidia-installer-cleanup
dpkg-reconfigure

Почему?

Deleted ()
Ответ на: комментарий от Deleted

aptitude reinstall nvidia-installer-cleanup
Следующие пакеты будут ПЕРЕУСТАНОВЛЕНЫ:
nvidia-installer-cleanup
0 пакетов обновлено, 0 установлено новых, 1 переустановлено, 0 пакетов отмечено для удаления, и 923 пакетов не обновлено.
Необходимо получить 0 B/16,2 kB архивов. После распаковки 0 B будет занято.
Preconfiguring packages ...
(Чтение базы данных ... на данный момент установлено 160146 файлов и каталогов.)
Подготовка к замене пакета nvidia-installer-cleanup 20120630+3 (используется файл .../nvidia-installer-cleanup_20120630+3_i386.deb) ...
Распаковывается замена для пакета nvidia-installer-cleanup ...
Настраивается пакет nvidia-installer-cleanup (20120630+3)


этого достаточно, чтобы удалить остатки дров от нвидии или еще надо что-то делать ?

Sky777 ()
Ответ на: комментарий от Sky777

Похоже оно ставит скрипт, который вызывается при установке libgl1-nvidia{,-legacy-*}-glx{,-ia32} и xserver-xorg-video-nvidia*. Печально. Можно, конечно, их установить, а потом удалить, но это… не знаю даже %)

Deleted ()
Ответ на: комментарий от i_gnatenko_brain
xserver-xorg-video-nvidia - NVIDIA binary Xorg driver
xserver-xorg-video-nvidia-any -
xserver-xorg-video-nvidia-legacy-173xx - NVIDIA binary Xorg driver (173xx legacy version)
xserver-xorg-video-nvidia-legacy-71xx - OBSOLETE NVIDIA binary Xorg driver (71xx legacy version)
xserver-xorg-video-nvidia-legacy-96xx - NVIDIA binary Xorg driver (96xx legacy version)
Пакет: xserver-xorg-video-nvidia
Зависимости: libgl1-nvidia-glx (= 304.64-3), nvidia-alternative (= 304.64-3), nvidia-support (>= 20120630), xorg-video-abi-13 | xorg-video-abi-12 | xorg-video-abi-11 | xorg-video-abi-10 | xorg-video-abi-8 | xorg-video-abi-6.0, xserver-xorg-core (< 2:1.13.99), libc6 (>= 2.2.5), debconf (>= 0.5) | debconf-2.0
Предварительные зависимости: nvidia-installer-cleanup
Рекомендуются: nvidia-vdpau-driver (>= 304.64), nvidia-kernel-dkms (= 304.64-3) | nvidia-kernel-304.64, nvidia-settings

Для удобства, видимо.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.