LINUX.ORG.RU

debian gallium no fast 3d radeon удручает


0

1

здравствуйте!
всё стоит(фирмваре, меса, хорг-радеон), лог загрузки чистый идеально
но нет нормальной скорости 3д

stan@serenity:~$ glxinfo | grep Open
OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RV530
OpenGL version string: 2.1 Mesa 7.10.3
OpenGL shading language version string: 1.20
OpenGL extensions:

stan@serenity:~$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on ATI RV530
GL_NV_blend_square, GL_NV_conditional_render, GL_NV_light_max_exponent,

(II) LoadModule: «dbe»
[ 19.863] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 19.882] (II) Module dbe: vendor=«X.Org Foundation»
[ 19.882] compiled for 1.10.2.902, module version = 1.0.0
[ 19.882] Module class: X.Org Server Extension
[ 19.882] ABI class: X.Org Server Extension, version 5.0
[ 19.882] (II) Loading extension DOUBLE-BUFFER
[ 19.882] (II) LoadModule: «glx»
[ 19.882] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 19.953] (II) Module glx: vendor=«X.Org Foundation»
[ 19.953] compiled for 1.10.2.902, module version = 1.0.0
[ 19.953] ABI class: X.Org Server Extension, version 5.0
[ 19.953] (==) AIGLX enabled
[ 19.953] (II) Loading extension GLX
[ 19.955] (II) LoadModule: «record»
[ 19.955] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 19.967] (II) Module record: vendor=«X.Org Foundation»
[ 19.967] compiled for 1.10.2.902, module version = 1.13.0
[ 19.967] Module class: X.Org Server Extension
[ 19.967] ABI class: X.Org Server Extension, version 5.0
[ 19.968] (II) Loading extension RECORD
[ 19.968] (II) LoadModule: «dri»
[ 19.968] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 19.983] (II) Module dri: vendor=«X.Org Foundation»
[ 19.983] compiled for 1.10.2.902, module version = 1.0.0
[ 19.983] ABI class: X.Org Server Extension, version 5.0
[ 19.983] (II) Loading extension XFree86-DRI
[ 19.983] (II) LoadModule: «dri2»
[ 19.983] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 20.000] (II) Module dri2: vendor=«X.Org Foundation»
[ 20.000] compiled for 1.10.2.902, module version = 1.2.0
[ 20.000] ABI class: X.Org Server Extension, version 5.0
[ 20.000] (II) Loading extension DRI2
[ 20.000] (==) Matched ati as autoconfigured driver 0
[ 20.000] (==) Matched vesa as autoconfigured driver 1
[ 20.000] (==) Matched fbdev as autoconfigured driver 2
[ 20.000] (==) Assigned the driver to the xf86ConfigLayout
[ 20.000] (II) LoadModule: «ati»
[ 20.000] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[ 20.005] (II) Module ati: vendor=«X.Org Foundation»
[ 20.005] compiled for 1.10.1, module version = 6.14.2
[ 20.005] Module class: X.Org Video Driver
[ 20.005] ABI class: X.Org Video Driver, version 10.0
[ 20.005] (II) LoadModule: «radeon»
[ 20.005] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[ 20.124] (II) Module radeon: vendor=«X.Org Foundation»
[ 20.124] compiled for 1.10.1, module version = 6.14.2
[ 20.124] Module class: X.Org Video Driver
[ 20.124] ABI class: X.Org Video Driver, version 10.0
[ 20.129] (II) LoadModule: «vesa»
[ 20.129] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 20.141] (II) Module vesa: vendor=«X.Org Foundation»
[ 20.141] compiled for 1.10.2, module version = 2.3.0
[ 20.141] Module class: X.Org Video Driver
[ 20.141] ABI class: X.Org Video Driver, version 10.0
[ 20.141] (II) LoadModule: «fbdev»
[ 20.141] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 20.252] (II) Module fbdev: vendor=«X.Org Foundation»
[ 20.252] compiled for 1.10.1, module version = 0.4.2
[ 20.252] ABI class: X.Org Video Driver, version 10.0
[ 20.252] (II) RADEON: Driver for ATI Radeon chipsets:

S
[ 20.256] (II) VESA: driver for VESA chipsets: vesa
[ 20.256] (II) FBDEV: driver for framebuffer: fbdev
[ 20.256] (++) using VT number 7

[ 20.263] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[ 20.264] (II) [KMS] Kernel modesetting enabled.
[ 20.264] (WW) Falling back to old probe method for vesa
[ 20.264] (WW) Falling back to old probe method for fbdev
[ 20.264] (II) Loading sub module «fbdevhw»
[ 20.264] (II) LoadModule: «fbdevhw»
[ 20.264] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 20.386] (II) Module fbdevhw: vendor=«X.Org Foundation»
[ 20.386] compiled for 1.10.2.902, module version = 0.0.2
[ 20.386] ABI class: X.Org Video Driver, version 10.0
[ 20.386] (II) RADEON(0): Creating default Display subsection in Screen section
«Default Screen Section» for depth/fbbpp 24/32
[ 20.386] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
[ 20.386] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[ 20.386] (==) RADEON(0): Default visual is TrueColor
[ 20.386] (==) RADEON(0): RGB weight 888
[ 20.386] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
[ 20.386] (--) RADEON(0): Chipset: «ATI Radeon X1600» (ChipID = 0x71c2)
[ 20.386] (II) RADEON(0): PCIE card detected
[ 20.386] drmOpenDevice: node name is /dev/dri/card0
[ 20.386] drmOpenDevice: open result is 9, (OK)
[ 20.386] drmOpenByBusid: Searching for BusID pci:0000:05:00.0
[ 20.386] drmOpenDevice: node name is /dev/dri/card0
[ 20.386] drmOpenDevice: open result is 9, (OK)
[ 20.386] drmOpenByBusid: drmOpenMinor returns 9
[ 20.386] drmOpenByBusid: drmGetBusid reports pci:0000:05:00.0
[ 20.387] (II) Loading sub module «exa»
[ 20.387] (II) LoadModule: «exa»
[ 20.387] (II) Loading /usr/lib/xorg/modules/libexa.so
[ 20.405] (II) Module exa: vendor=«X.Org Foundation»
[ 20.405] compiled for 1.10.2.902, module version = 2.5.0
[ 20.405] ABI class: X.Org Video Driver, version 10.0
[ 20.405] (II) RADEON(0): KMS Color Tiling: enabled
[ 20.405] (II) RADEON(0): KMS Pageflipping: enabled
[ 20.405] (II) RADEON(0): SwapBuffers wait for vsync: enabled
[ 20.452] (II) RADEON(0): Output VGA-0 has no monitor section
[ 20.500] (II) RADEON(0): Output S-video has no monitor section
[ 20.559] (II) RADEON(0): Output DVI-0 has no monitor section
[ 20.608] (II) RADEON(0): EDID for output VGA-0
[ 20.656] (II) RADEON(0): EDID for output S-video
[ 20.713] (II) RADEON(0): EDID for output DVI-0



stan@serenity:~$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
284 frames in 5.0 seconds = 56.616 FPS
301 frames in 5.0 seconds = 60.014 FPS
301 frames in 5.0 seconds = 60.009 FPS

помогите врубить 3Д РЕАЛЬНО!

Ответ на: комментарий от Novell-ch

ай шаман!

stan@serenity:~$ vblank_mode=0 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
11980 frames in 5.0 seconds = 2395.882 FPS
14063 frames in 5.0 seconds = 2811.734 FPS
14469 frames in 5.0 seconds = 2893.724 FPS
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
after 44887 requests (44887 known processed) with 0 events remaining.
stan@serenity:~$



полагаю - тема закрыта одним выстрелом? мальчик никуда и не исчезал?это замерялка неправильная была?

stas_on ()
cat .drirc 
<driconf>
    <device screen="0" driver="dri2">
        <application name="Default">
            <option name="vblank_mode" value="0" />
        </application>
    </device>
</driconf>
kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

однако костик87 трюкач

оно реально теперича без префиксов рисует не синхронизированные с жк монитором фпсы

stan@serenity:~$ glxgears
13509 frames in 5.0 seconds = 2701.697 FPS
14386 frames in 5.0 seconds = 2877.185 FPS
14313 frames in 5.0 seconds = 2862.455 FPS
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
after 46360 requests (46360 known processed) with 0 events remaining.
stan@serenity:~$

stas_on ()
Ответ на: комментарий от Behem0th

несмотря на очень приличные фпсы в glxgears общее ощущение тормознутости системы имеет место быть и дело не только в замедленной реакции Кменю (хотя это достаёт приизрядно и доступной изменялки времени реации меню я не нашел) но и в том, что при отркытии приложений - сначала рисуется буферная каша в рамках приложения, а затем уже само содержимое окна приложения при ресайзе размеров окон тоже присутствует каша из пикселей на чёрном фоне.....

stas_on ()
Ответ на: комментарий от snoopcat

Нет. Замерялка как раз правильная. Это пользователь неправильный, не читает, что ему замерялка пишет.

Deleted ()
Ответ на: комментарий от Deleted

сокости гуи совершенно недостаточно оно же раньше, до 2.6.26 просто летало всё а ща тоскливое гав*0 при этом и файловую систему сменил на ext4 и вот галиум опять же вроде пашет - а есть очущение недостаточной чёткости рабочего стола..

stas_on ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.