LINUX.ORG.RU

Проблема с zlib1g


0

1

Короче, ломаю прошивку на смартфон. Скинули архив с файлами с помощью которого это можно сделать. Но прежде в этой папке необходимо выполнить команду make Вот что выходит: output_file.c:25:18: фатальная ошибка: zlib.h: Нет такого файла или каталога, компиляция прервана

Выполняю команду: apt-get install zlib1g-dev Пишет, что пакет zlib1g-dev недоступен, но упомянут в списке зависимостей другого пакета. Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

Ладно, фиг с ним. Скачал файл отдельно, пытался установить - пишет, что новая версия стоит. Посмотрел, стоит: zlib1g-dev. zlib1g 1:1.2.3.4.dfsg-3ubuntu4 Хотел удалить эту новую версию и поставить ту, что надо zlib1g_1.2.3.3.dfsg-15ubuntu1 При удалении пишет: Следующие пакеты имеют неудовлетворенные зависимости: libc6: Depends: libc-bin(=2.15-0ubuntu10) но 2.15-0ubuntu10 должен быть установлен linux-headers-3.2.0-26:

Не знаю зачем, но удалил linux-headers-3.2.0-26, теперь при удалении zlib1g пишет: Следующие пакеты имеют неудовлетворенные зависимости: libc6: Depends: libc-bin(=2.15-0ubuntu10) но 2.15-0ubuntu10 должен быть установлен

Посоветуйте что-нибудь

krab@ubuntu64:~$ sudo apt-get install zlib1g-dev
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
НОВЫЕ пакеты, которые будут установлены:
  zlib1g-dev
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 14 пакетов не обновлено.
Необходимо скачать 165 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 397 kB.
Получено:1 http://ru.archive.ubuntu.com/ubuntu/ precise/main zlib1g-dev amd64 1:1.2.3.4.dfsg-3ubuntu4 [165 kB]
Получено 165 kБ за 2с (71,8 kБ/c)        
Выбор ранее не выбранного пакета zlib1g-dev.
(Чтение базы данных ... на данный момент установлено 150714 файлов и каталогов.)
Распаковывается пакет zlib1g-dev (из файла .../zlib1g-dev_1%3a1.2.3.4.dfsg-3ubuntu4_amd64.deb)...
Обрабатываются триггеры для man-db ...
Настраивается пакет zlib1g-dev (1:1.2.3.4.dfsg-3ubuntu4) ...
bhfq ★★★★★ ()

zlib1g-dev недоступен, но упомянут в списке зависимостей другого пакета. Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

sudo apt-get update?

bhfq ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.