LINUX.ORG.RU

Настройка шрифтов или xorg.conf


0

2

Добрый день. Установил убунту 12.04 и на нее openbox поставил. Проблема в том, что очень быстро начинают болеть глаза за компом. Не понимаю почему. Думал в частоте обновления экрана проблема. Видяха nvidia 9600gt. Lxrandr показывает 1280x1024 и 50 гц. В nvidia-xconfig выбрал 60 гц. Вот xorg.conf

Section "Monitor"

    #HorizSync       30.0 - 81.0
    #VertRefresh     56.0 - 75.0
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    ModeLine       "1280x1024_60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -hsync +vsync
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9600 GT"
EndSection

Section "Screen"

    #Option         "TwinView" "0"
    #Option         "metamodes" "1280x1024_60 +0+0; nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024_60"
    EndSubSection
EndSection
Закоменченые строчки были раньше. Заменил на те что нашел в мануалах в инете. Возможно еще проблема в шрифтах х3. Тоже ковырял по мануалам. Вот скрин: извините залить в галерею не могу т.к. маленький score Пример шрифтов

Да. шрифты у тебя немного того. По крайней мере на моем мониторе. Думаю, у тебя antialiasing (скглаживание) зашкаливает.
xorg здесь не причем AFAIK. Какая DE?
И, если у тебя не ЭЛТ монитор, то частота экрана не играет роли. Единственно что, если у тебя TFT - разрешение установи родное (максимальное), не меньше.

Kroz ★★★★★ ()
Ответ на: комментарий от Kroz

ЖК монитор у меня. DE ubuntu 12.04 WM Openbox. Разрешение максимальное установлено 1280x1024. Сглаживание отрубил лучше не стало.

EJIqpEP ()
Ответ на: комментарий от EJIqpEP

В кедах «стиль хитинга» на полную выкрутил - и мыло пропадало (по дефолту там среднее, и мыло было).

Как в коробках такое прокрутить увы, я не в курсе.

cat .fonts.conf 
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgb</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hinting">
   <bool>true</bool>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintfull</const>
  </edit>
 </match>
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>
roman77 ★★★★★ ()
Ответ на: комментарий от EJIqpEP

Ты уверен, что 1280x1024 — это максимальное разрешение?

(Я б ещё попробовал наугад освещение в помещении сменить. Или днём тоже всё плохо?)

frob ★★★★★ ()
Ответ на: комментарий от EJIqpEP

А взять у кого-нибудь другой монитор на часок?

frob ★★★★★ ()
Ответ на: комментарий от EJIqpEP

Есть идеи как это пофиксить?

мб стоит поробовать отключить AA и выбрать нормальный шрифт?
Мой /etc/fonts/conf.d/10-antialias.conf выглядит так:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <match target="font">
    <edit name="antialias" mode="assign"><bool>false</bool></edit>
  </match>
</fontconfig>
с тахомой выглядит замечательно (на любителя, как в ХР... к сожалению достойной свободной замены не нашел)

Old_Hamster ★★★ ()

Я видел и похуже... намного хуже.

ArtKun ★★★★★ ()
Ответ на: комментарий от EJIqpEP

Сглаживание отрубил лучше не стало.

Сглаживание у тебя там 100% есть. Поэтому если ты отрубил, а ничего не изменилось, значит ты его не отрубил.

Разрешение максимальное установлено 1280x1024

То есть у тебя моник 17" или 19"? Какая модель?

1.a. В любом случае пропиши в xorg.conf свой DPI:

Section "Monitor"
...
    Option                 "DPI" "96 x 96"
Section "Monitor"
Только свой DPI подставь.

1.b. Убери «ModeLine» - AFAIK на TFT он не нужен.

2. В ~/.openbox/rc попробуй вот это:

session.screen0.antialiasFonts: False
session.screen0.dropShadowFonts: False

3. Еще попробуй вот такой вот ~/.fonts.conf :

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
        <edit name="autohint" mode="assign"><bool>false</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintfull</const></edit>
        <edit name="hinting" mode="assign"><bool>false</bool></edit>
        <edit name="rgba" mode="assign"><const>rgb</const></edit>
        <!-- lcdnone, lcddefault, lcdlight, lcdlegacy -->
        <edit name="lcdfilter" mode="assign"><const>lcddefault</const></edit>
        <edit name="dpi" mode="assign"><double>96</double></edit>
    </match>
</fontconfig>
Только DPI свой подставь.

Попробуй сначала 1, потом еще 2, потом еще 3. Отпишись по результату.

Kroz ★★★★★ ()
Ответ на: комментарий от EJIqpEP

Яркость

Глаза могут болеть от яркости большой. А также от плохого освящения комнаты, особенно если в темноте сидите.

Nikita_b ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.