LINUX.ORG.RU

Аппаратное ускорение видео AMD-C60


0

1

собственно кто знает как включить и возможно ли?

Система Archlinux, нетбук Acer Aspire 522

>fglrxinfo 
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6290 Graphics
OpenGL version string: 4.2.11318 Compatibility Profile Context
пробывал по убунту вики http://help.ubuntu.ru/wiki/аппаратная_поддержка_hd_видео

в арчевике ничего нового не увидел, и как узнать возможно ли вообще, так как карточка буквально недавно нормально заработала.

Можно.

Нужен патченный mplayer отсюда или отсюда (более поздняя версия) или из аура и xvba-video.

В /etc/environment вписать

export LIBVA_DRIVER_NAME="fglrx"

Запускать

$ mplayer-vaapi -va vaapi -vo vaapi:gl file

Kadi ()
Ответ на: комментарий от Martin256

Есть, но я так и не разобрался как заставить его юзать аппаратное ускорение. В итоге поставил патченный mplayer и smplayer в качестве фронтэнда и забыл про vlc.

Kadi ()
Ответ на: комментарий от leave

не работает, как узнать что оно работает кроме как перестать наблюдать лагающее видео?

Martin256 ★★ ()
Ответ на: комментарий от Kadi

$ mplayer -va vaapi -vo vaapi:gl Pasta01.mkv MPlayer SVN-r34578-4.6.2 (C) 2000-2012 MPlayer Team 183 audio & 394 video codecs mplayer: could not connect to socket mplayer: No such file or directory Failed to open LIRC support. You will not be able to use your remote control.

Playing Pasta01.mkv. libavformat version 53.30.100 (internal) libavformat file format detected. [lavf] stream 0: video (h264), -vid 0 [lavf] stream 1: audio (ac3), -aid 0, -alang rus, Pasta01_rus [lavf] stream 2: audio (ac3), -aid 1, -alang kor, Pasta01_kor [lavf] stream 3: subtitle (dvdsub), -sid 0, -slang rus, Russian VIDEO: [H264] 1280x720 0bpp 29.970 fps 0.0 kbps ( 0.0 kbyte/s) Load subtitles in ./ [vo_vaapi] Using OpenGL rendering libva: VA-API version 0.32.0 libva: User requested driver 'fglrx' libva: Trying to open /usr/lib/dri/fglrx_drv_video.so libva: va_openDriver() returns -1 [vo_vaapi] vaInitialize(): unknown libva error Error opening/initializing the selected video_out (-vo) device. ========================================================================== Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders libavcodec version 53.57.100 (internal) AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000) Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3) ========================================================================== [AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample) Video: no video Starting playback... A: 24.9 (24.9) of 3910.2 ( 1:05:10.1) 6.5% 

что то видео не показывает тока звук

Martin256 ★★ ()
Ответ на: комментарий от Martin256

> Trying to open /usr/lib/dri/fglrx_drv_video.so
Оно там есть? Если нет, то

export LIBVA_DRIVERS_PATH=`locate fglrx_drv_video.so`
У меня оно, например, лежит в /usr/lib/va/drivers

Kadi ()
Ответ на: комментарий от leave

$ vainfo
libva: VA-API version 0.32.0
libva: User requested driver 'fglrx'
libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
libva: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit
Martin256 ★★ ()
Ответ на: комментарий от Kadi
$ mplayer -va vaapi -vo vaapi:gl Pasta01.mkv MPlayer SVN-r34578-4.6.2 (C) 2000-2012 MPlayer Team 183 audio & 394 video codecs mplayer: could not connect to socket mplayer: No such file or directory Failed to open LIRC support. You will not be able to use your remote control.

Playing Pasta01.mkv. libavformat version 53.30.100 (internal) libavformat file format detected. [lavf] stream 0: video (h264), -vid 0 [lavf] stream 1: audio (ac3), -aid 0, -alang rus, Pasta01_rus [lavf] stream 2: audio (ac3), -aid 1, -alang kor, Pasta01_kor [lavf] stream 3: subtitle (dvdsub), -sid 0, -slang rus, Russian VIDEO: [H264] 1280x720 0bpp 29.970 fps 0.0 kbps ( 0.0 kbyte/s) Load subtitles in ./ [vo_vaapi] Using OpenGL rendering libva: VA-API version 0.32.0 libva: User requested driver 'fglrx' libva: Trying to open /usr/lib/dri/fglrx_drv_video.so libva error: /usr/lib/dri/fglrx_drv_video.so has no function __vaDriverInit_0_32 libva: va_openDriver() returns -1 [vo_vaapi] vaInitialize(): unknown libva error Error opening/initializing the selected video_out (-vo) device. ========================================================================== Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders libavcodec version 53.57.100 (internal) AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000) Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3) ========================================================================== [AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample) Video: no video Starting playback... A: 14.4 (14.3) of 3910.2 ( 1:05:10.1) 1.1%

MPlayer interrupted by signal 2 in module: play_audio A: 14.4 (14.3) of 3910.2 ( 1:05:10.1) 1.1%

Exiting... (Quit) 
Martin256 ★★ ()
Ответ на: комментарий от Martin256

Как щас вижу, какое-нибудь собрание, и тут вы выдаете в микрофон ПОКЛАЛ, повторите это всем кто будет смеяться

nutz ★★ ()

Может не по теме...

На AMD C-60 мне так и не удалось поставить проприетарные драйвера. Постоянно выдают сообщение что не поддерживаемое устройство. Может скинете ссылку на инструкцию именно для С-60. С другими ati у меня проблем не было. В гугле искал, но к своему сожалению ничего не нашел:(

Terrible ()
Ответ на: комментарий от Terrible

дистрибутив какой? нормально завелось только на Арче, на убунте еще не пробывал, там не только драйвера, но и ядро поновее надо

Martin256 ★★ ()
Ответ на: комментарий от Terrible

Никаких инструкций не использовал, поставил драйвера из реп и все.

Martin256 ★★ ()
Ответ на: комментарий от Terrible

Kubuntu: там вроде свой установщик искаропки. В меню где есть пункт про него.

А вообще установка примерно такая:
1) сносим открытый драйвер и ставим проприетарный
2) aticonfig --initial
3) добавляем к параметрам ядра radeon.modeset=0 чтоб отрубить KMS. Параметр не нужен, если ядро собрано без него.

Kadi ()
Ответ на: комментарий от Rakot

Suse 12.1. Вчера попробовал январский драйвер с сайта. Заработал. Декабрьский не ставился. Теперь осталось победить микрофон и будет счастье:)

Terrible ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.