LINUX.ORG.RU

kwin 4.6.3 radeon rv740, как вернуть OpenGL?


0

1

Debian testing, обновился с kde 4.4 до kde 4.6, kwin перестал включать OpenGL эффекты. Никто не сталкивался, их можно как-то вернуть?

В лог пишет:

kwin(5744) KWin::CompositingPrefs::detect: glx version is  1 . 4
OpenGL vendor string:                   X.Org
OpenGL renderer string:                 Gallium 0.4 on AMD RV740
OpenGL version string:                  2.1 Mesa 7.10.2
OpenGL shading language version string: 1.20
Driver:                                 R600G
GPU class:                              R700
OpenGL version:                         2.1
GLSL version:                           1.20
Mesa version:                           7.10.2
X server version:                       1.10.2
Linux kernel version:                   2.6.38
Direct rendering:                       yes
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   yes
. . .
kwin(5744) KWin::Extensions::init: Extensions: shape: 0x "11"  composite: 0x "4"  render: 0x "b"  fixes: 0x "40"
kwin(5744) KWin::Workspace::setupCompositing: Initializing OpenGL compositing
kwin(5744) KWin::Workspace::setupCompositing: KWin has detected that your OpenGL library is unsafe to use, falling back to XRender. 
kwin(5744): Failed to initialize compositing, compositing disabled 
kwin(5744): Consult http://techbase.kde.org/Projects/KWin/4.0-release-notes#Setting_up 
по ссылке ходил, там пишут что эффекты включаются с помощью галочки 'Enable desktop effects'.

в ~/.kde/share/config/kwinrc слов blacklist нет.

Создал нового пользователя, у него OpenGL прекрасно включается даже по умолчанию! Буду разбираться...

ps: что-то они накосячили с обновлением конфигов с 4.4 на 4.6, панели отвалились, kwin вот OpenGL потерял...

Eshkin_kot ★★ ()

У меня было похожее в арче, снес xorg.conf, потом заново его сгенерил с помощью нвидяшной тулзы.

cipher ★★★★★ ()

в ~/.kde/share/config/kwinrc слов blacklist нет.
Зато там есть OpenGLIsUnsafe=true. На false поменяйте.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

> Зато там есть OpenGLIsUnsafe=true. На false поменяйте.

Спасибо, заработало! :)

Eshkin_kot ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.