LINUX.ORG.RU

Как и где отключить кеширование при записи на флешку?


0

1

Сабж. А то приходится наблюдать такую печальну картину - копирую файл (скажем, 50+ Мб). Он моментально копируется на флешку (якобы). Нажимаю отмонтировать, и тут начинается нормальная запись. Диалог отмонтирования, естественно, выдаёт ошибку через некоторое время. Выглядит убого.

Да. Монтирование руками - не выход. Через fstab - тоже.

Используется KDE 4.6.4.

Есть решение через udev-костыль со скриптом, но это ... костыль. Насколько мне сказал гугль, опции монтирования прибиты гвоздями в коде udisks (сам не смотрел).

Собственно, может, я плохо искал и это прописано в каком-нибудь конфигурационном файле?

Ещё интересно, почему опция flush есть только для vfat. Не готов?

anonymous ()

>Насколько мне сказал гугль, опции монтирования прибиты гвоздями в коде udisks
В гноме тоже через udisks монтирование, но такой проблемы нет

xorik ★★★★★ ()

Оно читает опции монтирования из fstab.

uzbl ()

>Насколько мне сказал гугль, опции монтирования прибиты гвоздями в коде udisks (сам не смотрел).

Ну вот посмотри и исправь, там изменения тривиальны. И напиши в багзиллу пожелание приделать конфигурационный файл с опциями по умолчанию

anonymous ()

> Диалог отмонтирования, естественно, выдаёт ошибку через некоторое время. Выглядит убого.

это проблема диалога отмонтирования - пиши в багзиллу kde
уже 4.6.4, а ляпы как у беты

x905 ★★★★★ ()

Не советую это делать. Скорость копирования резко упадет, да и для флешки это не очень...

Eddy_Em ☆☆☆☆☆ ()

Просто дать команду sync религия что ли не позволяет? Раз уж у КДЕ такие ошибки в размонтировании.

anonymous ()

Может, проведём тестирование? У меня на работе 8 Гб Ram, дома 4.
Делаем файл на 180 Мб
dd if=/dev/zero of=~/file count=1 bs=100M
Дельфином я копирую его на флешку (4Гб, какой-то kingston).
Кеды говорят, что файл скопирован моментально. Флешка ничего не моргает. Наимаю отмонтировать. Начинает бешено моргать. Через некоторое время апплет говорит, что не удалось отмонтировать. Через mc то же самое.

Unnamed_Hero ★★★ ()
Ответ на: комментарий от Unnamed_Hero

У меня автомонтирование делается таким правилом. С ним mc копирует адекватно. (ключевой является опция flush)

KERNEL!="sd[d-z][0-9]", GOTO="media_by_label_auto_mount_end"

# Import FS infos
IMPORT{program}="/sbin/blkid -o udev -p %N"

# Get a label if present, otherwise specify one
ENV{ID_FS_LABEL}!="", ENV{dir_name}="%E{ID_FS_LABEL}"
ENV{ID_FS_LABEL}=="", ENV{dir_name}="usbhd-%k"

# Global mount options
ACTION=="add", ENV{mount_options}="relatime,flush"
# Filesystem-specific mount options
ACTION=="add", ENV{ID_FS_TYPE}=="vfat|ntfs", ENV{mount_options}="$env{mount_options},utf8,gid=100,umask=002"

# Mount the device
ACTION=="add", RUN+="/bin/mkdir -p /media/%E{dir_name}", RUN+="/bin/mount -o $env{mount_options} /dev/%k /media/%E{dir_name}"

# Clean up after removal
ACTION=="remove", ENV{dir_name}!="", RUN+="/bin/umount -l /media/%E{dir_name}", RUN+="/bin/rmdir /media/%E{dir_name}"

# Exit
LABEL="media_by_label_auto_mount_end"

ATIpro ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.