LINUX.ORG.RU

Debian Squeeze, некоторые проблемы.


0

0

Во время установки зеркало ftp.ru.debian.org недоступно. Есть ли возможность выбрать другое, доступное? Кстати, почему оно недоступно, «накрылось»? В самом Дебиане после установки в синаптике не работает кнопка Репозитории, я могу править sources.list но привык работать все же с гуи в синаптике. Есть возможность это починить?

Мож пригодится тебе мой лист репов, я на него не жалуюсь =)

cat /etc/apt/sources.list
deb http://ftp.nl.debian.org/debian/ squeeze main 
deb-src http://ftp.nl.debian.org/debian/ squeeze main 

deb http://security.debian.org/ squeeze/updates main 
deb-src http://security.debian.org/ squeeze/updates main 

deb http://ftp.nl.debian.org/debian/ squeeze non-free 
deb-src http://ftp.nl.debian.org/debian/ squeeze non-free 

##WINE
deb http://www.lamaresh.net/apt/ squeeze main 

#QutIM
deb http://qutim.org/debian/testing/ testing main 
deb-src http://qutim.org/debian/testing/ testing main 

# deb http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/ jaunty main 

##Cromium-browser
deb http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/ karmic main   
deb-src http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/ karmic main   


##Experimental
#deb http://ftp.nl.debian.org/debian/ experimental main 
#deb-src http://ftp.nl.debian.org/debian/ experimental main 

#deb http://ftp.de.debian.org/debian sid main

#Virtualbox
deb http://download.virtualbox.org/virtualbox/debian karmic non-free

dgeliko ★★ ()



Synaptic в Ubuntu изрядно перекалечен дополнительными плугинами.
Удаление (или не установка) пакетов
update-manager и update-notifier освобождает память и приводит к (имхо) нормальному и классическому виду редактирование меню репозиториев в Synaptic:
Меню -> Настроки -> Репозитории.

elipse ★★★ ()

хм. прозреваю другое. подключение к сети интернет во время установки настроено? А вообще ищите местные зеркала от вашего провадера, так быстрее (:
#OR netselect

darkshvein ☆☆ ()
Ответ на: комментарий от SideObserver

>Спасибо за ваши sources.list, правда kernel-headers апт-гет инсталл не нашел..

# aptitude install module-assistant # module-assistant prepare

module-assistant потянет за собой и «kernel-headers»

anonymous ()
Ответ на: комментарий от SideObserver

# aptitude install module-assistant

# module-assistant prepare

anonymous ()
Ответ на: комментарий от elipse

разумеется, если, такое ядро еще есть в репозиториях.
Бывает, что и ядро надо обновлять ))

elipse ★★★ ()
Ответ на: комментарий от SideObserver

aptitude update сделал?
а то я сам иногда забываю :)

oh ()
Ответ на: комментарий от elipse

Лучше через «module-assistant» устанавливать.

anonymous ()
Ответ на: комментарий от SideObserver

>Он мне предлагает множество версий linux-headers.

По одной на каждую версию ядра. Но если ты так ввел, как тебе сказали, должна выбраться нужная:

apt-get install linux-headers-$(uname -r)

proud_anon ★★★★★ ()
Ответ на: комментарий от SideObserver

> Кстати, а куда по дефолту устанавливается gcc?

/usr/bin

anonymous ()
Ответ на: комментарий от SideObserver

>Кстати, а куда по дефолту устанавливается gcc?

Ну... в /usr, если из реп дебиана. Более подробную информацию в синаптике можно посмотреть в списке файлов в пакете.

proud_anon ★★★★★ ()

Всем спасибо за помощь, с репозиториями разобрался. Правда сейчас я тестирую пока что Дебиан на виртуальной машине, и не могу установить дополнения гостевой ос. Требует gcc, которого у меня в /usr/bin нет. Установил и gcc, и gcc 4.1 base и другие попробовал. Тщетно. Ну, будь что будет. Ставлю вместо Убунты Дебиан, там уже «на полный экран» буду разбираться.

SideObserver ()
Ответ на: комментарий от SideObserver

Я ж тебе писал выше

# aptitude install module-assistant

# module-assistant prepare

Таким образом у тебя автоматом потянется и gcc. Это лучший вариант.

anonymous ()
Ответ на: комментарий от anonymous

ну чушь же какая ))
если, товарищ поставил систему с диска и содержащую версию ядра УЖЕ отсутствующую в основных репозиториях, то module-assistant до лампады
тут.
Поможет:
Только обновление до актуальной версии ведра.
или подключение архивных репозиториев.


elipse ★★★ ()
Ответ на: комментарий от elipse

Ну тогда после перезагрузки в новое ядро следует сделать

# module-assistant prepare

Это стандартная процедура.

anonymous ()
Ответ на: комментарий от elipse

Ну так извернуться не любой хер с горы может, а ТС просто поставил систему. Так что c m-a не должно быть проблем.

oh ()
Ответ на: комментарий от anonymous

> Это стандартная процедура.

при фобиях на названия файлов от ведра ?))

Не всегда стоит цель собирать модули.
А было даже что и глючил сам m-a.

elipse ★★★ ()
Ответ на: комментарий от oh

>Ну так извернуться не любой хер с горы может,

))
И откуда вы такие «стандартные» беретесь ?



elipse ★★★ ()
Ответ на: комментарий от elipse

Если вы не извращаетесь с кучами ядер, то лучше ставить что-то более общее, что б при апдейте ядра таки и они обновлялись.

Deleted ()
Ответ на: комментарий от Deleted

Как вы все достали уже ))

При апдейте ядра убирают старые варианты из реп (вместе с linux-headers ,и в ubuntu тоже).
А тс на старом ведре через m-a этого не видит, вот и все проблемы.
«Вот нема linux-headers и все»
И некоторые доп. знания тут явно не помешают.


то лучше ставить что-то более общее,


возможно, только без фанатизма.

elipse ★★★ ()

лучше скажите - КАК ОНО? меня Lenny измучал. Я его тестировал и пытался использовать ещё до релиза - там были вообще фееричные вещи. после релиза основные проблемы пропали, но так перейти на него с Etch-а не смог. машину с установленной Lenny выключил и более пытаться притронутся к этому дистру желания нет. достало. пишу с Этча, но менять его надо...

tommy ★★★★★ ()
Ответ на: комментарий от tommy

> Я его тестировал и пытался использовать ещё до релиза - там были вообще фееричные вещи.

Что-то я не заметил такого.
А тебе советовать еще раз ставить testing у меня желания.
Будешь снова ерунду потом писать на каждом углу.

elipse ★★★ ()
Ответ на: комментарий от elipse

Я про linux-headers-2.6-amd64, например, или как там оно в i386 называется :}

Deleted ()

Идиотизм какой-то. Установил module-assistant, сделал prepare. Он действительно потянул за собой gcc, но... Установка дополнений гостевой ос никак gcc не видит.

The path «/usr/bin/gcc» is not valid path to the gcc binary. Would you like to change it? [yes]

SideObserver ()
Ответ на: комментарий от SideObserver

Давно пробовал ставить дополнения гостевой ОС, поэтому по памяти кажется както так: при установке гостевой ОС создается образ диска, который нужно примонтировать к виртуалке, зайти в гостевой системе в /сдром, выбрать файл, соответствующий твоей системе и установить его.

PS. А вообще, зачем тебе дополнение гостевой ОС. Какая от него польза.

anonymous ()
Ответ на: комментарий от anonymous

Тут другие дополнения. Тут один файл, .pl Он требует gcc, и не находит его в usr/bin/gcc Хз, где он может быть... Дополнения гостевой ОС нужны для полноэкранной работы ОС, в основном. Ну и для свистоперделок, компиза и т.д.

SideObserver ()
Ответ на: комментарий от SideObserver

Так может он требует другую версию gcc, а не просто «не находит». Тогда нужно принудительно заставлять инсталятор использовать именно ту версию, которая установлена.

anonymous ()
Ответ на: комментарий от anonymous

Говорит что директория «неправильная», где находится gcc. Ладно, попробую поднять Дебиан на Virtual Box-е.

SideObserver ()

Удивительно, на Виртуал Боксе все пошло просто преотлично. Все работает, и зеркало, и дополнения.

SideObserver ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.