LINUX.ORG.RU

[xorg][nvidia][debian] Чёрный экран при загрузке иксов


0

0

Никак не могу заставить работать закрытые драйвера nvidia.

Железо: GeForce FX 5200 (AGP), MB Epox EP-8HEAI с AGX разъёмом (псевдо-AGP на базе PCI).

Из софта - свежеустановленный debian lenny.

Что делал:

1. Ставил как написано тут: http://debian-russian.org/debian-faq/hardware/kak-pravilno-postavit-drova-dly...

$ sudo aptitude install module-assistant
$ sudo m-a prepare
$ sudo m-a a-i nvidia-kernel
$ sudo aptitude install nvidia-glx nvidia-settings

$ sudo nvidia-xconfig

2. Устанавливал из официального инсталлера (не поверх предыдущего).

Результат всегда один - при загрузке чёрный экран и неработающая клавиатура. Если переключаюсь на nv, запускается нормально.

При этом никаких ошибок в /var/log/Xorg.0.log нет, он просто обрывается.

Можете чего-нибудь подсказать?

★★

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

> Железо: GeForce FX 5200 (AGP), MB Epox EP-8HEAI с AGX разъёмом (псевдо-AGP на базе PCI).

извращение какое то. Оно вообще под линуксом работает?

JB ★★★★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

>извращение какое то.

Ну да, оно. Но внимание обратил только когда проблема возникла, до того и не знал.

>Оно вообще под линуксом работает?

Не знаю, гугль про это ничего не говорит. Но nv по крайней мере функционирует.

fffgh ★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

>1. Ставил как написано тут: http://debian-russian.org/debian-faq/hardware/kak-pravilno-postavit-drova-dly...

Попробуй поставить по второму варианту с nvidia-kernel-legacy

>Если переключаюсь на nv, запускается нормально.

То есть в xorg.conf меняешь nvidia на nv? если нет, то там должно быть nvidia

Serj0 ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

>Попробуй поставить по второму варианту с nvidia-kernel-legacy

Там как-то сильно халтурно всё описано, во второй части. Во-первых, пакета nvidia-kernel-legacy не существует - есть nvidia-kernel-legacy-96xx. Во-вторых последняя команда вообще не работает, да и не нужна похоже - синаптик докладывает, что всё уже поставлено.

А результат тот же - чёрный экран.

>То есть в xorg.conf меняешь nvidia на nv?

Да, так.

fffgh ★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

копипаст из обзора на материнку
===============
Существует, правда, проблема совместимости, не все видеокарты способны работать в псевдо-AGP разъёмах, однако ни на сайте, ни в руководстве пользователя упоминаний об этом не обнаружено.
===============

из предположений:
не исключено что закрытый драйвер (в отличии от относительно ограниченного nv) пытается завести в карте как раз те возможности, которые и вызываю несовместимость.

griz ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

Поставил также legacy дрова через synatic - ровно тот же результат.

fffgh ★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

а версию дров какую ставишь? 173 серия для 5200 - предел.

mic ★★★★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

>Существует, правда, проблема совместимости, не все видеокарты способны работать в псевдо-AGP разъёмах, однако ни на сайте, ни в руководстве пользователя упоминаний об этом не обнаружено.

Да, есть такое, производитель молчит как партизан. А в википедии, например, пишут, что с картами ati работает плохо. Но про nvidia ничего нет.

>не исключено что закрытый драйвер (в отличии от относительно ограниченного nv) пытается завести в карте как раз те возможности, которые и вызываю несовместимость.

Возможно.

Проблема в том, что никакой информации об этом лично я не нашёл. Ни со стороны производителя, ни в описании линуксовых дров. Не исключено, что там всех делов - строчку в конфиг добавить. Или наоборот, всё это не может работать в принципе.

fffgh ★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

>Проблема в том, что никакой информации об этом лично я не нашёл.

скорее всего и не найдешь. может быть на каких либо буржуйских форумах кто то так уже делал. можно поискать. Но вот только мне кажеться что AGX это такой костыль, который будет иметь специфику работы для каждого сочетания video+MB+driver.

а вообще то ну не в игрушки де на таком чудовище играть??? Чем не устраивает nv?

griz ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

>а вообще то ну не в игрушки де на таком чудовище играть???

Да ладно, чудовище. В третьекваку бы побегал.

>Чем не устраивает nv?

Чёрт его знает, не пробовал особо. Модет и нормально будет.

fffgh ★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

>а вообще то ну не в игрушки де на таком чудовище играть??? Чем не устраивает nv?

как бывший владелец подобного чудовища - openarena, xv, wine+игры хотят именно nvidia.

mic ★★★★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

Попробуй поиграться с видеорежимами (Ctrl+Alt+Numpad_+) и моделайнами - у меня иксы с нвидиевскими драйверами отказываются показывать что-либо в 1280x1024.
А на sysrq система реагирует?

Deleted ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

Подобная проблема:
Debian squeeze/sid, 2.6.26-1-686, GeForce 4 MX440, NVIDIA-Linux-x86-96.43.11-pkg1.run.
Устанавливаю драйвера посредством nvidia-installer, выполнив export CC=gcc-4.1 - компилится-устанавливается нормально, меняю в xorg.conf на Driver "nvidia" перстартую иксы - все работает отлично. До перезагрузки, потом просто черный экран и вирутальные консоли.
modprobe nvidia драйвер подгружает, но эффекта никакого. В логах ничего. Модули rivafb|nvidiafb|vesa не загружаются.
В чем проблема?

D_Ima ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

чёрт, вот это да, сейчас та же самая проблема. Железяка:

VGA compatible controller: nVidia Corporation C51 [Quadro NVS 210S/GeForce 6150LE] (rev a2)

поставил вчера етч прямо из инета, накатил до ленни. Вообще ооочень старнные танцы: иксы запускаются, сверху маленькая белая полоса - в остальном экран черный, но кде вроде работает так как слышен звук при загрузке кед. если модуль выставить не nvidia а vesa - всё пройдет нормально, далее если без перезагрузки выставить в конфиге модуль nvidia и перезапустить X - то и с ним нормально запустится - вот это вообще супер танцы - ни как не понятно из-за чего. Больше похоже что траблы какие-то не совсем из-за драйвера. Во всех логах даже варнингов нет.

При удалении nvidia-glx была ругань на отсутствие /usr/lib/libGL.so, правда сейчас поставил дровину для карточки с сайта нвидии NVIDIA-Linux-x86-180.29-pkg1.run - ссылка вроде есть, но её я похоже сам делал libGL.so -> libGL.so.1 -> libGL.so.180.29. В любом случае что с симлинком что без не работает одинакого )

The_Ketchup ★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

вообще полагаю что какая-то лажа именно в этих файлах, думаю что надо как-то под корень всё это вынести и поставить что-то одно, имхо лучше бы это был драйвер с сайт, хоть он и ругается на то компилятор которым скомпилено ядро отличается от того что сейчас в наличии :).

The_Ketchup ★★ ()

Re: [xorg][nvidia][debian] Чёрный экран при загрузке иксов

удалил всё вообше что хоть как-то относится к нвидии,переустановил драйвер с сайта - то же самое... ((

P.S. сорри за мою орфографию - сплю уже ).

The_Ketchup ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.