LINUX.ORG.RU

nvidia, черный экран

 


0

1

gentoo, обновил ядро до 4.9.76-r1, xorg-server до 1.19.5-r1. Что бы я ни делал, иксы выдают черный экран с nvidia-драйвером. Пробовал различные версии драйвера от 375 до 390 — результат везде один.

Судя по логу, что-то идет не так. Пробовал убирать metamodes — ничего не меняется.

[    16.445] (II) Module glx: vendor="NVIDIA Corporation"
[    16.445] (II) NVIDIA GLX Module  390.42  Sat Mar  3 03:25:37 PST 2018
[    16.457] (II) Module nvidia: vendor="NVIDIA Corporation"
[    16.459] (II) NVIDIA dlloader X Driver  390.42  Sat Mar  3 03:00:31 PST 2018
[    16.459] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    16.472] (II) NVIDIA(0): Creating default Display subsection in Screen section
[    16.472] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    16.472] (==) NVIDIA(0): RGB weight 888
[    16.472] (==) NVIDIA(0): Default visual is TrueColor
[    16.472] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    16.473] (**) NVIDIA(0): Option "HWcursor"
[    16.473] (**) NVIDIA(0): Option "RenderAccel" "true"
[    16.473] (**) NVIDIA(0): Option "AllowGLXWithComposite" "true"
[    16.473] (**) NVIDIA(0): Option "TripleBuffer" "true"
[    16.473] (**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
[    16.473] (**) NVIDIA(0): Option "ConnectToAcpid" "false"
[    16.473] (**) NVIDIA(0): Enabling RENDER acceleration
[    16.473] (**) NVIDIA(0): Option "MetaModes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
[    16.473] (**) NVIDIA(0): Enabling 2D acceleration
[    16.719] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 770 (GK104) at PCI:1:0:0 (GPU-0)
[    16.719] (--) NVIDIA(0): Memory: 4194304 kBytes
[    16.719] (--) NVIDIA(0): VideoBIOS: 80.04.bc.00.0f
[    16.719] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    16.719] (II) NVIDIA(0): Validated MetaModes:
[    16.719] (II) NVIDIA(0):     "NULL"
[    16.719] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[    16.719] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[    16.719] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[    16.719] (**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
[    16.720] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[    16.720] (II) NVIDIA:     access.
[    16.735] (II) NVIDIA(0): Setting mode "NULL"
[    16.741] (==) NVIDIA(0): Disabling shared memory pixmaps
[    16.741] (==) NVIDIA(0): Backing store enabled
[    16.741] (==) NVIDIA(0): Silken mouse enabled
[    16.742] (**) NVIDIA(0): DPMS enabled
[    16.742] (II) NVIDIA(0): [DRI2] Setup complete
[    16.742] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    30.717] (II) NVIDIA(0): Setting mode "NULL"

[ 16.719] (WW) NVIDIA(0): Unable to get display device for DPI computation. Собственно.

dygger1 ()

Такое может быть если модуль nvidia-modeset.ko не подгружается, а только nvidia.ko.

anonymous ()
Ответ на: комментарий от Deleted

У тебя шифт западает. Из-за гпу локапа не видишь что ли?

anonymous ()
Ответ на: комментарий от anonymous

Этот анонимус оказался прав. Хм, собирал с USE=-kms, модуля nvidia_modeset не было, как и картинки. После USE=kms и появления nvidia-modeset все стало ок.

kawaii_neko ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.