LINUX.ORG.RU

Вопрос по настройке РРРоЕ


0

0

Здравствуйте, ЛОР.

Нужно установить adsl-подключение. Исходные данные: Slackware 12.1, модем D-Link DSL-2500U (настроен в режиме bridge, указаны port/VPI/VCI, LAN IP Address, Primary DNS Server, Netmask), данные провайдера-Укртелеком(имя пользователя, пароль, IP, Netmask, DNS, шлюз).

Суть проблемы: не удается выйти в интернет.

Мои действия: я настраивал PPPoE соединение через pppoe-start, настраивал сеть через netconfig(статический адрес, затем DHCP). Потом запускаю pppoe-start и вижу строчку ..Connected! Затем выполняю ifconfig и вижу, что есть 3 устройства: eth0, lo, ppp0. Захожу Файрфоксом на любой сайт - не заходит, Konqueror тоже не заходит.

выполнял уже такие команды

#ifconfig eth0 192.168.1.2 ppp0 192.168.1.1 netmask 255.255.255.0

#route add -net 0.0.0.0 gw 192.168.1.1 ppp0

не заходит

потом такие:

#ifconfig eth0 inet 192.168.1.2 netmask 255.255.255.0

#route add -net 0.0.0.0 gw 192.168.1.1 ppp0

не заходит

Сейчас из-под Windows сижу на том же компьютере, раньше в Убунту сидел, там тоже работало. Не хочется Слаку бросать из-за такой мелочи))

Уже 4 дня бьюсь с этой проблемой....Облазил весь Гугль)) перепробовал много..

Помогите решить, господа Специалисты. Буду рад услышать любые предложения.

anonymous

Re: Вопрос по настройке РРРоЕ

В слаке должен быть скрипт pppoe-setup, который пропишет корректные настройки в конфиги. После чего сеть должна работать сразу после

$ pppoe-start ......Connected!

без дополнительных настроек.

kim-roader ★★ ()
Ответ на: Re: Вопрос по настройке РРРоЕ от kim-roader

Re: Вопрос по настройке РРРоЕ

Да, я выполнял, действительно - пишет Connected. Но из браузера никуда не заходит. Firewall я поставил в значение "0"..

anonymous ()
Ответ на: Re: Вопрос по настройке РРРоЕ от anonymous

Re: Вопрос по настройке РРРоЕ

1. Проходят ли пинги во внешний мир?
2. Что говорят ipconfig и route сразу после подключения
3. DNS выдается сервером при подключении? Если да, то при настройке через pppoe-setup в одном пункте надо написать большими буквами SERVER (некоторые это на моей памяти не замечали)

kim-roader ★★ ()
Ответ на: Re: Вопрос по настройке РРРоЕ от kim-roader

Re: Вопрос по настройке РРРоЕ

1) Во внешний мир пинги не проходят (ping www.google.com говорит unreachable adress)
2) Ifconfig говорит
root@i:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0E:A6:AC:32:B3
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::20e:a6ff:feac:32b3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:59 errors:0 dropped:0 overruns:0 frame:0
TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4092 (3.9 KiB) TX bytes:4028 (3.9 KiB)
Interrupt:19 Base address:0x9800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

ppp0 Link encap:Point-to-Point Protocol
inet addr:92.112.138.76 P-t-P:195.5.5.200 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:34 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:1751 (1.7 KiB) TX bytes:37 (37.0 b)

3) Route говорит:
root@i:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
195.5.5.200 * 255.255.255.255 UH 0 0 0 ppp0
localnet * 255.255.255.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default Alpha.Home 0.0.0.0 UG 1 0 0 eth0

4) ДНС выдал провайдер. 192.168.1.1

Я уже не знаю, может что-то в netconfig или в pppoe-setup не то написал? Но если pppoe подключается - значит правильно... не знаю

anonymous ()

Re: Вопрос по настройке РРРоЕ

почему бы не использовать модем в режиме роутера а не бриджа?...

eXenit ()
Ответ на: Re: Вопрос по настройке РРРоЕ от eXenit

Re: Вопрос по настройке РРРоЕ

Охотно буду использовать в режиме роутера, только как? И потом - на этих настройках соединение работает в Винде, работало и в Убунте...

anonymous ()
Ответ на: Re: Вопрос по настройке РРРоЕ от anonymous

Re: Вопрос по настройке РРРоЕ

Всё таки лучше писать "route -n" — тогда вывод понятнее.

Пинговать внешний мир я имел ввиду по IP (например "ping 74.125.67.100" для гугла)

Судя по выводу у тебя не прописывается default gateway. По идее должна помочь команда "route del default && route add default dev ppp0"

Скорее всего нужно просто поправить /etc/ppp/pppoe-conf:

DEFAULTROUTE=yes #чтобы на ppp-интерфейс заворачивало маршрут по умолчанию.

kim-roader ★★ ()
Ответ на: Re: Вопрос по настройке РРРоЕ от Root-msk

Re: Вопрос по настройке РРРоЕ

Спасибо большое, друзья! Все советы перепробовал. все оказались нужны. Соединение заработало! Знаете, в чем проблема была? Только не смейтесь)

Удалил все настройки, затем в netconfig настроил сеть на статический адрес и указал ДНС. А после этого в pppoe-setup в разделе ДНС написал server. И после этого pppoe-start -> Connected! И сразу зашло в брауере на Google.com. Сейчас пишу из-под Slackware)

Извините, если зря отнял у Вас время....))) И если можно, последний вопрос: как сделать так, чтобы при запуске системы сеть подключалась автоматически?

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.