LINUX.ORG.RU

XFree 4.3 не работают winkeys


0

0

redhat 7.3 Установил себе из src.rpm XFree86 4.3 (пропала проблемма падения иксов при переключении в текстовый режим на i810) Настроил XF86Config-4

Identifier "Keyboard0" Driver "keyboard" Option "XkbRules" "xfree86" Option "XkbModel" "pc104" Option "XkbLayout" "us,ru" Option "XkbOptions" "grp:ctrl_shift_toggle" Option "XkbVariant" "winkeys"

При "XkbLayout" "us,ru" опция "XkbVariant" "winkeys" используется(в логе написано), но не работает; а при "XkbLayout" "ru" опция "XkbVariant" "winkeys" используется и работает, но язык только русский.

Что не так указываю, дайте ссылку на man


Re: XFree 4.3 не работают winkeys

Option "XkbLayout" "us,ru" Option "XkbVariant" ",winkeys" или наоборот ;)) Option "XkbLayout" "ru,us" Option "XkbVariant" "winkeys,"

anonymous ()

Re: XFree 4.3 не работают winkeys

Но вот вреде конфиг файл не XF86Config-4, а XF86Config

anonymous ()

Re: XFree 4.3 не работают winkeys

1. Загляни в <XKBRoot>/rules/xfree и раскомменти строчку ! $nonlatin -- сможешь оставить layout ru. Может, поможет... Мне в Слаквари 9, впрочем, только setxkbmap и помог -- вроде из файла и читает, но как-то ничего не меняет...

2. As я пол, сначала смотрит таки XF86Config-4, а потом уж просто (эсли не нашла) (с четвёртой версии)

С уважением -- Смоляное Чучелко

anonymous ()

Re: XFree 4.3 не работают winkeys

Log file: "/var/log/XFree86.0.log" (==) Using config file: "/etc/X11/XF86Config-4"

Используется именно XF86Config-4 (потому что fresh, а не install) Покопался и оказалось:

так не работает Option "XkbLayout" "us,ru" Option "XkbVariant" "winkeys" а так работает Option "XkbLayout" "us,ru(winkeys)"

Спасибо всем за помощь.

vtl ()

Re: XFree 4.3 не работают winkeys

XkbLayout "us, ru(winkeys)"

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.