LINUX.ORG.RU

Проблемы после обновления ffmpeg

 


0

1

Система Artix (Arch Linux без systemd) после обновления ffmpeg до версии 5.0 (пакет ffmpeg 2:5.0-3) перестал работать Telegram-desktop, пишет:

telegram-desktop: error while loading shared libraries: libavcodec.so.58: cannot open shared object file: No such file or directory

Пробовал делать симлинки на библиотеки с требуемыми именами, эффект примерно тот же - не запускается.

Так же Firefox перестал воспроизводить некоторое видео.


это мажорное обновление ffmpeg, которое меняет API несовместимым образом, и поэтому версия *.so тоже поменялась.

можно установить обратно ffmpeg той версии, которая необходима приложениям.

можно даже установить несколько разных версий ffmpeg одновременно.

чтобы приложения заработали с этой версией ffmpeg - их нужно как минимум пересобрать, но есть вероятность что их еще нужно иcправить на предмет совместимости.

waker ★★★★★ ()

Artic это дистрибутив с кучей запаздывающих пакетов а репах, от того и их несовместимость. Тут на форуме товарищь даже утилиту выкладывал для поиска несоответствий. Находите что запоздало и ставите из арчевских реп. Ну и подумайте стоит ли хейт системд кучи лишних проблем.

anonymous ()
Ответ на: комментарий от anonymous

Зашел к ним на сайт, пишут:

Currently packages that depend on ffmpeg is borked due to mix up of ffmpeg/libplacebo rebuild. If you haven't upgraded yet and use stuff with ffmpeg deps, refrain from upgrading for now

На форуме предлагают даунгрейдиться…

rmnd ()
Ответ на: комментарий от rmnd

ffmpeg откатывать или обновить Фокс и телеграмм. Потому что на арче не поддерживаются частичные обновления, в арчевских репозиториях зависимые пакеты одновременно обновляют, а в артих из за маргинальности просто не успевают все обновить и потому часть пакетов запаздывает с обновлениями. И это будет постоянная головная боль со временем ситуация только ухудшится. Все эти ответвления с основными своими репами дохнут через несколько лет. Исключение лишь те что получили широкую поддержку, вроде манджары. Да и то лучше чистый арч.

anonymous ()
Ответ на: комментарий от anonymous

Да уж. Вернул ffmpeg-2:4.4.1-1-x86_64.pkg.tar.zst из кэша. Браузер и Телеграм работают.

P.S. Не для холивара ради, но тенденция такая, что systemd становится стандартом дефакто (крупные дистрибутивы его используют). Но по душе как-то дистрибутивы попроще - Void, Alpine.

rmnd ()
Ответ на: комментарий от rmnd

Поставил telegram-desktop-bin (из AUR) - запустился

с большой долей вероятности, он притащил с собой нужную ему версию ffmpeg :)

waker ★★★★★ ()
Ответ на: комментарий от waker

Он так-то дохлый был до недавнего времени. Votes: 0 А теперь вон оно че..

Jeronimo ()
Ответ на: комментарий от rmnd

становится

Вылезай из криокамеры. Давно стал. Его не используют только дистры, делающие это своей основной особенностью (devuan, artix) и сосредоточенные на минимальности (Tiny core, alpine). Сорс-базед дают выбор.

DMITRY ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.