LINUX.ORG.RU

Snap, Gentoo, боль

 , , , ,


0

1

Понадобилось тут поставить на Генту мне пару программ, которые только в snap распространяются. В теории все прекрасно, snap даже systemd не требует. WAIT, OH SHI.. нет, требует. Хотя в сети вроде есть упоминания, что можно и без него, но они у меня не заработали.

Окей, думаю, сейчас ебилд напишу, только тарбол скачаю, … погодите-ка, а на snapcraft’e его не скачать, там отправляют делать snapd install .

Собственно, 2 вопроса:

  1. Как заставить (и можно ли) работать snapd без systemd,
  2. Как руками достать тарбол, если snap не стоит.
  3. Как с этим жить?
★★

Ответ на: комментарий от Pinkbyte

app-emulation/snapd-2.53.1.ebuild содержит systemd как опциональную зависимость.

REQUIRED_USE=«!forced-devmode? ( apparmor cgroup-hybrid ) systemd»

как бы да, но нет. Даже баг есть.

Но собирается, конечно, и без него.

показывай что именно и как у тебя не работает

Ну, например.

snap install authy
error: cannot communicate with server: Post "http://localhost/v2/snaps/authy": dial unix /run/snapd.socket: connect: no such file or directory
tis ★★ ()
Ответ на: комментарий от grem

2 проблемы: не ставится (частично поправил, и пока в процессе)

вот хочу я 1.9.0 (последнюю версию) и не понимаю, как получить ссылку на скачивание.

Для справки, в ебилде, для 1.8.3: SRC_URI="https://api.snapcraft.io/api/v1/snaps/download/H8ZpNgIoPyvmkgxOWw5MSzsXK1wRZiHn_5.snap"

tis ★★ ()
Последнее исправление: tis (всего исправлений: 1)
Ответ на: комментарий от tis

в баге по твоей же ссылке пришли к выводу, что только для systemd

grem ★★★★★ ()
Ответ на: комментарий от grem

Ну,потому, что я не дошел до нерешенной проблемы с ним, а в процессе ковыряния.

Ну, раз хочешь больше деталей, последняя ошибка вот:

Traceback (most recent call last):
  File "/usr/lib/portage/python3.9/doins.py", line 607, in <module>
    sys.exit(main(sys.argv[1:]))
  File "/usr/lib/portage/python3.9/doins.py", line 596, in main
    if _doins(
  File "/usr/lib/portage/python3.9/doins.py", line 439, in _doins
    return install_runner.install_file(source, os.path.dirname(dest))
  File "/usr/lib/portage/python3.9/doins.py", line 373, in install_file
    return self._ins_runner.run(source, dest_dir)
  File "/usr/lib/portage/python3.9/doins.py", line 181, in run
    sstat = os.stat(source)
FileNotFoundError: [Errno 2] No such file or directory: b'/var/tmp/portage/app-misc/authy-1.8.3/files/authy.desktop'
 * ERROR: app-misc/authy-1.8.3::local-eblds failed (install phase):
 *   doins failed
tis ★★ ()
Ответ на: комментарий от tis

ты скачал то, что лежит в каталоге files?

Структуру файлов и каталогов воспроизведи как здесь в своём локально оверлее:

https://data.gpo.zugaina.org/EmilienMottet/app-misc/authy/

Ну и свяжись с автором ebuld’а, попроси обновить и поделиться знанием, как узнать id ссылки на скачивание.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 2)
Ответ на: комментарий от grem

ты скачал то, что лежит в каталоге files?

походу, нет. тож заметил.

Ну и свяжись с автором ebuld’а, попроси обновить и поделиться знанием, как узнать id ссылки на скачивание.

хорошая идея, спасибо!

Но блин, какзалось бы snap такая замечательная идея и все дела, а реализация через неизвестно что.

tis ★★ ()
Последнее исправление: tis (всего исправлений: 1)
Ответ на: комментарий от tis

id ссылки на скачивание

возможно, он поставил в виртуалку убунту и там скачал этот пакет, а потом посмотрел вывод snap info authy

grem ★★★★★ ()
Ответ на: комментарий от grem

да, как вариант. быстрее вайн поставить, конечно :)...

tis ★★ ()
Ответ на: комментарий от grem

можно еще на github в поиск забить, хотя и там и там ебилды один хуже другого

path:app-misc/authy language:"Gentoo Ebuild"

или на других ресурсах

nanosecond ()
Последнее исправление: nanosecond (всего исправлений: 2)
Ответ на: комментарий от thesis

нормальной работы, и более прозрачной «ручной» настройки/работы

tis ★★ ()

Вот и последствия ложной рекламы Snap как универсального менеджера пакетов для GNU/Linux. Ладно пользователи, но разработчики софта почему на это ведутся?

Извини, просто сталкивался с той же проблемой и тоже без решения. Хорошо хоть во flatpak всё нашлось.

Gentooshnik ★★★★ ()
Ответ на: комментарий от tis

А, ну ой... Что тут еще скажешь. Прибили его гвоздями к systemd. Учитывая что в 99% дистрибутивах сейчас именно systemd - их можно понять.

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Gentooshnik

Проблема в том что много стульев systemd, runit, openrc, s6, svi

Systemd самый большой стул, и прилипает, поэтому для таких систем которые не хотят использовать systemd должны страдать или пилить свой персональный снап, но проще намутить ebuild

SPRATAY ()
Ответ на: комментарий от Gentooshnik

Ну хотя бы потому что Flatpak для десктопов.

Поэтому когда мне понадобилось, то даже в его сторону не смотрел. Я уж молчу про все его остальные приколы — даже CLI плохое впечатление производит.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)

Напиши разработчикам этих программ, что они нехорошие люди и что пусть хотябы tarball предоставят.

sudopacman ★★★★★ ()
Ответ на: комментарий от fornlr

Ну хотя бы потому что Flatpak для десктопов.

А для серверов - docker. Серьёзно, какой сценарий использования Snap на сервере?

Gentooshnik ★★★★ ()
Ответ на: комментарий от SPRATAY

Да, но где гарантии что там софт отвязан от systemd? Нигде. Лично мне, видимо, везло, но гарантий действительно нет.

Gentooshnik ★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.