LINUX.ORG.RU

Ищу замену для WordPad

 ,


1

5

В феврале с.г. закинул на Opennet одноименную тему:

Для своих статей, заметок и т.д. давно использую простейшие редакторы - MCedit и Medit.
Потому что они крохотные, шустрые и с ними не идут ни в какое сравнение всякие монcтры Libre/Open Write.

Но все же возможностей этих «блокнотов» не хватает, хотелось бы минимального форматирования теста (жирный, подчеркивание, ...цвета) и ссылки.

Попытался какое-то время попользоваться AbiWord - нет, не то, вещь в себе.

И тут меня осенило: мелкософтовский WordPad - гениальная вещь, оказывается!
Он придуман как раз для таких случаев - легкий, шустрый, обладает минимальным форматированием и не содержит ничего лишнего.

Что же есть такого долгоиграющего в Linux?

Чтобы можно было спокойно им пользоваться и не задумываться, что его поддержку забросят.


И советов сразу было море!
Но когда сегодня с утреца уточнил, что картинки должны обязательно интегрироваться в документ, советов больше пока не последовало.
А уточнил я таким образом:

Ну что же, прошло больше полгода, как я упорно и настырно пытаюсь найти аналог WordPad в Linux.
Такой, чтобы позволял простейшее форматирование текста (B, U, I), его цветовую раскраску и - интегрирование изображений в документ
(а не держать их отдельно, это очень важно!).

И поневоле прихожу к выводу, что кроме AbiWord, до сих пор так ничего и не изобрели (или я не нашел), и он является единственной надеждой заменить WordPad.

С AbiWord я знаком еще где-то в эпоху перехода с DOS на Windows, и тогда он было вроде неплох, многие его использовали из-за слабых компьютерах с памятью 2 МБ (640K хватит всем! :-))
Но об его использовании в Linux у меня остались нехорошие воспоминания, подробностей не помню, какие-то косяки, что ли.

И вот сейчас, в 2021 году, не найдя замены WordPad, решил снова попробовать его использовать.

Система: Debian 10.10/64
AbiWord: 3.0.2 из репозитария Debian

И вот что получилось: AbiWord запускается, позволяет набрать пару слов, а далее, при попытке их сохранить часто мгновенно крошится.
Особенно, если пытаться сохранять не в родном формате .abw, а например, в .odg.
Еще смешно было, когда сохранив текст в простейшем формате .rtf, снова его открыть, то вместо него возникает какая-то абракадабра.
Ну тут понятно, чужие форматы AbiWord освоил плохо, поэтому возвращаемся к .abw.
Ведь свой родной формат он обязан понимать!

Понимать-то он может и понимает, но на плаву долго не держится.
Чтобы понять, что происходит, запустил его в консоли.
И вот что она выдала:

Когда Abiword только запустился, вскоре выскакивает вот такая парочка строк:

user@desktop:~$abiword
(abiword:23304): Gtk-CRITICAL **: 01:46:14.964: gtk_render_background: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed
(abiword:23304): Gtk-CRITICAL **: 01:46:14.964: gtk_render_frame: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed

Но при дальнейшей попытке работать в нем он быстро крошится, молниеносно выдав в консоли 3180 (!!!) строк вида -

** (abiword:23304): CRITICAL **: 01:46:42.112: follow_symlinks: assertion 'filename != NULL' failed
** (abiword:23304): CRITICAL **: 01:46:42.114: follow_symlinks: assertion 'filename != NULL' failed
** (abiword:23304): CRITICAL **: 01:46:42.114: follow_symlinks: assertion 'filename != NULL' failed
** (abiword:23304): CRITICAL **: 01:46:42.115: follow_symlinks: assertion 'filename != NULL' failed
** (abiword:23304): CRITICAL **: 01:46:42.118: follow_symlinks: assertion 'filename != NULL' failed

которые заканчиваются следующим -

** (abiword:23304): CRITICAL **: 01:46:46.486: follow_symlinks: assertion 'filename != NULL' failed
** (abiword:23304): CRITICAL **: 01:46:46.487: follow_symlinks: assertion 'filename != NULL' failed
** (abiword:23304): CRITICAL **: 01:46:46.489: follow_symlinks: assertion 'filename != NULL' failed
** (abiword:23304): CRITICAL **: 01:46:46.490: follow_symlinks: assertion 'filename != NULL' failed
** (abiword:23304): CRITICAL **: 01:46:46.491: follow_symlinks: assertion 'filename != NULL' failed
(abiword:23304): Gtk-WARNING **: 01:46:46.493: Attempting to read the recently used resources file at '/home/user/.local/share/recently-used.xbel', but the parser failed: Не удалось открыть файл «/home/user/.local/share/recently-used.xbel»: Слишком много открытых файлов.
/usr/lib/x86_64-linux-gnu/gio/modules/libgioremote-volume-monitor.so: невозможно открыть разделяемый объектный файл: Слишком много открытых файлов
Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/libgioremote-volume-monitor.so
(abiword:23304): GLib-GIO-WARNING **: 01:46:46.494: Error creating IO channel for /proc/self/mountinfo: Слишком много открытых файлов (g-file-error-quark, 14)
/usr/lib/x86_64-linux-gnu/gio/modules/libgioremote-volume-monitor.so: невозможно открыть разделяемый объектный файл: Слишком много открытых файлов
Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/libgioremote-volume-monitor.so
(abiword:23304): GLib-ERROR **: 01:46:46.494: Creating pipes for GWakeup: Слишком много открытых файлов
Ловушка трассировки/останова
user@desktop:~$

Да, уж, файлов открыто прямо немеряно - аж 1 штука...
Кажется, нечто подобное видел и пару лет назад.

Что делать, куда кидаться, не знаю, грущу, глядя на эту последнюю «надежду»...
Буду признателен любым полезным и креативным советам.


Может господа лоровцы подскажут такой «вордпадовский» редактор?
Или как заставить работать глючный AbiWord надежно.


PS. Пока же после долгих размышлений пришел к такому очевидному выводу:

Господа разработчики мало думают о нуждах пользователей.
И если бы думали, то не воротили таких монстров, как LibreOffice.
Вот скажите, кто использует все его возможности?
Рискну предположить, что никто. Лично я вряд ли более 1%.
Офисные работники побольше, но все равно далеко не всё.

А значит, кроме этого монстра надо было выпустить еще упрощенную лайт-версию - «LibreOffice Lite».
Чтобы бы она было без наворотов, а следовательно, компактной, шустрой и ею удовольствием пользовались бы многие пользователи, которым не нужны все эти монстроидальные навороты.

История о чем говорит? Что чрезмерное раздувание софта часто ведет к его забвению.
Напомню об истории «Аськи». Сначала она была крохотной и шустрой, и ею с удовольствием пользовались.
Но вместо того, чтобы сохранить эти достоинства, ею начали «раздувать», и она стала громоздкой и шустрой.

Этим и воспользовались разработчики Миранды и других клонов аськи, выпустив крохотные и шустрые «аськи», снабдив их плагинами, и народ с удовольствием переключился на них.

Разработчики классической «Аськи», наконец, спохватились, поняли свою ошибку, и выпустили «ICQ Lite» - но уже было слишком поздно, поезд ушел, она уже никого не интересовала.

Так что, чтобы софт не увядал, особенно powerfull, нужно вовремя снабжать его Lite-версиями.
Но по всей видимости, и сожалению, у разработчиков слабые «эффективные менеджеры», и им некому подсказать такую простую идею :-(

★★★★

«LibreOffice Lite» Чтобы бы она было без наворотов, а следовательно, компактной, шустрой

Идеалист. Не так это просто. Там даже все приложения (writer, calc, impress, draw, base) «в монолите».

А если на самом деле работать, а не считать секунды на запуск, то бери LibreOffice и не выпендривайся. Если бы MS Office был бесплатным, то WordPad-а бы не существовало.

greenman ★★★★★ ()
Последнее исправление: greenman (всего исправлений: 1)

Мыши плакали, кололись, но продолжали грызть WYSIWYG-кактус.

sudopacman ★★★★★ ()

Если ты программист то нефиг жаловаться что то спрашивать просто сделай сам. Там rtf форматирование, элементарщина. sudopacman +1

XoFfiCEr ★☆☆☆ ()
Ответ на: комментарий от greenman

Идеалист. Не так это просто. Там даже все приложения (writer, calc, impress, draw, base) «в монолите».

Как делают гениальные скульптуры? Берут гигантский камень и отсекают все лишнее.

А если на самом деле работать, а не считать секунды на запуск, то бери LibreOffice и не выпендривайся.

Вот чтобы их не считать, и нужна шустрая версия.

Если ты программист то нефиг жаловаться что то спрашивать просто сделай сам.

Аж ни разу не программист. А по твоему получается, что каждый, кто пользуется Линуксом, обязательно должен быть программистом.
Вот это и есть его главная проблема, почему так мало юзеров переходят в него из венды.

По сути вопроса будет что нибудь? Или все реплики будут типа «сам дурак».

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

Берут гигантский камень и отсекают все лишнее.

Попробуй так из Камаза сделать … даже не форд, а жигули

greenman ★★★★★ ()
Ответ на: комментарий от greenman

А вообще посмотри в сторону wiki движков. Может быть mytetra

Ага, вот и первый совет по сути!

Увы, так в mytetra документ тоже не монолитный, а в виде отдельных файлов.

chukcha ★★★★ ()
Ответ на: комментарий от frunobulax

Tex уже предлагали?

В смысле латекс-подобные редакторы? Емнип, пересмотрел все, но они или не визивиг, или не интегрируют картинки, или создают не монолитный документ.
Как и wiki-редакторы.

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

Из поста не понял что тебе именно визуальное.

Я для заметок-статей сейчас использую zim. Картинки еще не пробовал втыкать. Обычно с картинками у меня тексты для кого-нибудь, такие тексты хостю на медиавики (лютый оверкилл, но во всех альтернативах по-мелочам что-то не так как мне хочется).

frunobulax ()
Ответ на: комментарий от XoFfiCEr

Если ты программист то нефиг жаловаться что то спрашивать просто сделай сам.

Чукча - не писатель!

@chukcha без обид, не мог такое пропустить. :)

frunobulax ()

AbiWord 3.0.5 в Арче - никаких проблем. Может просто поискать версию поновее?

Motif ()
Ответ на: комментарий от LongLiveUbuntu

LongLiveUbuntu, вот вы брякнули походя -

Latex, Markdown, docbook, html, тысячи их

- и что, эти «тысячи» удовлетворяют этим условиям?

- вививиг
- форматирование текста
- вставка изображения с интеграцией в файл
- выходной моно-файл

К «Апостороф», zim, Tex и ко всему, что вы предложили, те же вопросы.

chukcha ★★★★ ()
Последнее исправление: chukcha (всего исправлений: 1)

Под линукс/qt/gtk нету нормального виджета, который умел бы все то, что умеет WordPad. Поэтому и советуют какой-то там markdown/latex которые ни разу не в категории WordPad. По идее все это можно реализовать кхе кхе на электроне. Но оно будет не быстрое и не нативное.

Возможно на каком-то QtWidgets или QML таки можно реализовать аналог WordPad, а в качестве формата файла заюзать не rtf, а HTML сжатый в zip https://en.wikipedia.org/wiki/Mozilla_Archive_Format

bhfq ★★★★★ ()
Последнее исправление: bhfq (всего исправлений: 1)
Ответ на: комментарий от bhfq

Под линукс/qt/gtk нету нормального виджета, который умел бы все то, что умеет WordPad.

За полгода поисков я пришел к такому же выводу.

Остается кривой и падучий Abiword. Может, в Арче он работает стабильно, но в Debian, понятно, другие сборщики, отсюда и такой плачевный результат.
Причем наблюдаю его не первый год в разных версиях.

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

вививиг

В калабаню за такие словечки!

Ищу замену для WordPad

Emacs.

Шутка.

Остается кривой и падучий Abiword. Может, в Арче он работает стабильно, но в Debian, понятно, другие сборщики, отсюда и такой плачевный результат.

В чём дело собрать новую версию или использовать Flatpak/Snap/Apppimage? Или ПК – драный тазик конца "нулевых"?

К тому же, я что-то не увидел, чтобы ты сюда заглядывал:

https://alternativeto.net/software/abiword

Если уж совсем ничего под хотелки, то выхода три: либо свежий Abiword, либо онлайн-редакторы (но тогда "китайские кулхацкеры" все твои рецепты пирогов уведут; как вариант – ищи что-то на Electron-е), либо напиши свой… Но мы же с тобой знаем, что ничего писать ты не собирался.

Korchevatel ★★★★★ ()
Ответ на: комментарий от bhfq

Заюзать флатпак

А чем лучше флатпак, чем банальные пакеты?

или собрать из сорцов

Ну, если дебиановские сборщики не справились с безглючной сборкой, то куда уж мне...

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

А чем лучше флатпак, чем банальные пакеты?

Неправильный вопрос. Правильный – когда он лучше.

Вот как раз с Debian-ом тот самый случай, ибо поставляется свежая версия ПО для не самой новой базовой системы.

Korchevatel ★★★★★ ()
Ответ на: комментарий от Korchevatel

К сожалению, не все там есть. вот к примеру вайна нету. Я на днях ставил rhel, чтобы глянуть что там по софту для десктопа и флатпак действительно выручил со всем, кроме вайна. а в репах там вайн толи 4ой толи 5ой версии. хоть бери и сам собирай :(

Keltir ()
Ответ на: комментарий от chukcha

тогда есть последняя альтернатива nixpkgs

https://search.nixos.org/packages?channel=21.05&show=abiword&from=0&size=50&sort=relevance&type=packages&query=abiword

ставится как второй пакетный менеджер, не засоряет систему, правда зависимостей ему придется выкачать почти столько же сколько и жырпак рантаймы.

bhfq ★★★★★ ()
Ответ на: комментарий от Korchevatel

вот сейчас загрузился на rhel, установил снап, нашел целую пачку «вайнов» https://snapcraft.io/search?q=wine попробовал парочку, ни один не дал мне возможности запустить сам вайн(нету исполняемого файла wine, но есть либы вайна). Предполагаю, что все эти «вайны» для использования только другими снапами. Но как быть, если я хочу игру запустить, которую с торентов скачал?

Keltir ()
Ответ на: комментарий от Korchevatel

К тому же, я что-то не увидел, чтобы ты сюда заглядывал:

https://alternativeto.net/software/abiword


Заглянул. Когда вижу словосочетание «powerful word processor», рука сама тянется к кобуре.

Зае.. достали уже своими «паверфулами»! Нафиг кому они нужны!
Лайты нужны народу, лайты!

Заюзать флатпак

В самом деле его заюзать, что ли? На офсайте и его версия посвежее - 3.0.5.
Только мне лучше подошел бы AppImage, он и так уже у меня используется, так что неохота разводить в системе этот снаповский зоопарк.

Нашел AppImage неизвестно кем сделанный, какой-то bratao. Хм - брателла :-)
https://github.com/bratao/Abiword.appimage
И версия немного старее - 3.0.4. Рискнуть, что ли?


Ааа, блин. вот почему мой 3.0.2 падает!!! -

04.07.2021

Спустя полтора года с момента прошлого обновления опубликован выпуск свободного многоплатформенного текстового процессора AbiWord 3.0.5, поддерживающего обработку документов в распространённых офисных форматах (ODF, OOXML, RTF и т.п.) и предоставляющего такие возможности, как организация совместного редактирования документов и многостраничный режим, позволяющий на одном экране просматривать и редактировать разные страницы документа. Код проекта распространяется под лицензией GPLv2.

В новой версии исправлено несколько ошибок, приводящих к краху, в том числе устранён крах при работе с буфером обмена.
Исправлены две уязвимости в обработчике форматов MS Word, приводившие к переполнению буфера при обработке специально оформленных сносок и документов в формате «doc»


До какой же степени надо быть таким криворуким, чтобы за 23 года существования AbiWord допускать такие косяки!

Ха-ха! А еще 5 лет назад -

Обновление AbiWord 3.0.2
20.11.2016 23:18

Многоплатформенный «лёгкий» текстовый процессор AbiWord обновлён до версии 3.0.2. Данный выпуск направлен на исправление ошибок. Особо отмечаются исправления для совместимости с новейшими версиями GTK3 (впрочем, использование GTK 3.22 пока не рекомендуется). Также исправлены ошибки, приводящие к краху приложения, различные проблемы со сборкой. Устранён ряд утечек памяти, улучшена поддержка формата OpenDocument и работа с Wayland. Внесён ряд менее значимых исправлений, специфичных для Linux и GTK.


6 лет назад:

17.01.2015 13:30
Известный текстовый процессор AbiWord обновился до версии 3.0.1. Кроме большого количества исправленных ошибок...

Они что - только тем и занимаются, что исправляют собственные ошибки, «приводящие к краху»?
А еще через год-другой выйдет новое «обновление, в котором исправлено большое количество ошибок»
И кто-то им еще пользуется??

Ржу не могу :-) То-то он запомнился мне как глючный, и теперь понятно, почему.

На офсайте, кстати, указано, что для венды он уже не поддерживается - туда им и дорога.

chukcha ★★★★ ()
Последнее исправление: chukcha (всего исправлений: 12)
Ответ на: комментарий от chukcha

В-общем, выбирать не из чего, придется ставить новейший AbiWord 3.0.5.
Поскольку на офсайте он существует только во флатпаке, установил flatpak.

Далее начал устанавливать флатпаковский AbiWord, однако получил ошибку нехватки места -

# flatpak install flathub com.abisource.AbiWord
Looking for matches…
Required runtime for com.abisource.AbiWord/x86_64/stable (runtime/org.gnome.Platform/x86_64/41) found in remote flathub
Do you want to install it? [Y/n]: y

com.abisource.AbiWord permissions:
        ID                                       Архитектура     Ветка      Удалённый репозиторий     Download
 1. [✗] org.gnome.Platform                       x86_64          41         flathub                      98,8 МБ / 288,1 МБ
 2. [ ] org.gnome.Platform.Locale                x86_64          41         flathub                   < 335,6 МБ (partial)
 3. [ ] org.freedesktop.Platform.GL.default      x86_64          21.08      flathub                   < 128,6 МБ
 4. [ ] org.freedesktop.Platform.VAAPI.Intel     x86_64          21.08      flathub                    < 11,6 МБ
 5. [ ] org.freedesktop.Platform.openh264        x86_64          2.0        flathub                     < 1,5 МБ
 6. [ ] com.abisource.AbiWord                    x86_64          stable     flathub                    < 18,9 МБ
 7. [ ] com.abisource.AbiWord.Locale             x86_64          stable     flathub                     < 1,9 МБ (partial)

Error: Not enough disk space to complete this operation
ошибка: Failed to установить org.gnome.Platform: Во время получения runtime/org.gnome.Platform/x86_64/41 из удалённого репозитория flathub: Writing content object: min-free-space-size 500MB would be exceeded, at least 9,1 МБ requested

У меня свободного места вроде полно -
# df -h
Файловая система Размер Использовано  Дост Использовано% Cмонтировано в
udev               3,9G            0  3,9G            0% /dev
tmpfs              786M         9,2M  776M            2% /run
/dev/sda2          101G          12G   85G           12% /
tmpfs              3,9G          28M  3,9G            1% /dev/shm
tmpfs              5,0M         4,0K  5,0M            1% /run/lock
tmpfs              3,9G            0  3,9G            0% /sys/fs/cgroup
/dev/sda1          453M          56M  370M           14% /boot
tmpfs              3,9G          40K  3,9G            1% /tmp
/dev/sdb3          3,9G         3,2G  539M           86% /var
/dev/sdb1          3,6T         2,5T  939G           73% /home
tmpfs              786M          12K  786M            1% /run/user/1000
# 

Какого же ему места не хватает?

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

Пользоваться это одно, скажи ты на ЛОРе только пользователь линукса? 3 звезды и не можешь элементарную программу написать? Сколько нытья из за этого. Уже было про программу для сравнения файлов побайтно, закончилось все нытьем.

XoFfiCEr ★☆☆☆ ()
Последнее исправление: XoFfiCEr (всего исправлений: 1)
Ответ на: комментарий от XoFfiCEr

Уже 100 раз говорил: только пользователь.

XoFfiCEr: ты, я вижу знаток Линукса?

Ну и подскажи: какого же ему места не хватает?

chukcha ★★★★ ()
Ответ на: комментарий от XoFfiCEr

Ошибся, значит, не знаток. Зачем тогда мешаешь дискуссии, непонятно...

chukcha ★★★★ ()

простейшее форматирование текста (B, U, I), его цветовую раскраску и - интегрирование изображений в документ

Ted — текстовый процессор RTF.

Летает на любом железе, способном хоть как-то запустить Linux, а также не глючит и не крашится (в отличие от AbiWord).

Причем сделанные в нем документы без проблем открываются в виндовом WordPad (вордпадовские в Ted — уже нет).

------

Скачать Ted для Debian (8 и выше)

Скачать зависимость libjpeg62-turbo для Debian (8 и выше)

minda ()
Последнее исправление: minda (всего исправлений: 3)
Ответ на: комментарий от minda

простейшее форматирование текста (B, U, I), его цветовую раскраску и - интегрирование изображений в документ

Уже подсказывали его, еще не проверил. И что, он действительно все это реализовывает? И выходной документ держит в моно-файле?

Заманчиво, спасибо! Сейчас гляну.

PS. Мне и не нужно, чтобы он вордпадовские открывал, главное. чтобы он свои понимал хорошо, и это будет вполне достаточно.

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

И что, он действительно все это реализовывает? И выходной документ держит в моно-файле?

Да. И умеет он даже больше, чем виндовый вордпад. Так, например, WordPad не умеет в нумерацию страниц (по крайней мере не умел в Windows 7).

minda ()
Последнее исправление: minda (всего исправлений: 1)
Ответ на: комментарий от chukcha

А тебе ted и в феврале советовали.

https://www.opennet.ru/openforum/vsluhforumID15/4579.html#16

Я то-думал, что ты на самом деле всё доступное уже перепробовал.

Ещё tea вроде бы подобное декларирует.

https://www.linux.org.ru/tag/tea

greenman ★★★★★ ()
Последнее исправление: greenman (всего исправлений: 1)
Ответ на: комментарий от minda

В самом деле, по функционалу Ted - самое то, что нужно!!!

Изображения - вставляет!
Причем интегрирует их в выходной документ!
Выходной документ с ними - моно-файл! (а не свалка разных файлов)
Понимает не только RTF, а и еще несколько форматов!
Проверка русской орфограции - есть!
Работает молниеносно!

И эти ребята даже настоящий встроенный хелп к нему пристроили! (а не заглушку, как это часто бывает).

И т.д. и т.п.

Браво, тедовцы! Кто ж они такие, умницы такие?

Разбираюсь дальше, но похоже, что этот Ted - самое то, что спасет лоровского пользователя! :-)

У меня за многие годы скопилась тонны технической документации, которую за многие годы набирал в plain тексте, т.е. текст - отдельно, картинки - отдельно, и работать с этим хаосом стало просто невозможно.
А StarOffice/OpenOffice/LibreOffice - ну просто воротит от этих монстров с их самого первого появления.

minda и Shadow, вы - настоящие креативные лоровцы, помогли делом, огромное вам спасибо!!!
Вот на таких линуксоидах и держится наш ЛОР!


PS. А вот тебя, XoFfiCEr, надо бы гнать с ЛОРа поганой метлой - ничем реально не помог, только нахамил и загадил дружескую дискуссию.

chukcha ★★★★ ()
Последнее исправление: chukcha (всего исправлений: 1)
Ответ на: комментарий от chukcha

Браво, тедовцы! Кто ж они такие, умницы такие?

Ну и ну! :-o

Эти умницы - один человек: Mark de Does :-)

Молча снимаю шляпу перед этим талантом...

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

по функционалу Ted - самое то, что нужно!!!

Есть даже разметка полей, отступы и т. д. Можно даже нетехнические документы по ГОСТу делать (гуманитарные курсовые и дипломные, в которых не нужно много формул).

Кто ж они такие, умницы такие?

Mark de Does и NLLGG.

StarOffice/OpenOffice/LibreOffice - ну просто воротит от этих монстров с их самого первого появления.

Да, это все треш. Ted хватит для всех простых задач. Все равно для сложной технической документации и библиографии нужно брать LaTeX или Markdown + LaTeX, а не эти монстры-комбайны, которые не годятся для таких сложных работ.

вы - настоящие креативные лоровцы

Спасибо. Просто разбираемся с качественном софте.

minda ()
Последнее исправление: minda (всего исправлений: 1)
Ответ на: комментарий от minda

Можно еще поставить скрипт-плагин для экспорта RTF в PDF (есть на официальном сайте Ted). Тогда вообще можно хорошо печатать документы откуда угодно (абсолютно в том виде, в котором они были сверстаны на авторском компьютере).

Но и без этого в винде есть WordPad, поэтому документ откроется. Т. е. у получателя документа будет доступ к исходнику документа для редактирования.

minda ()
Последнее исправление: minda (всего исправлений: 1)
Ответ на: комментарий от minda

Можно еще поставить скрипт-плагин для экспорта RTF в PDF

А, ну да, попробовал сохранить в PDF, Ted сделал вид, что сохранил, но файла не обнаружилось :-)

Оказывается. о Ted'е много статей было написано, но поди знай, что он все это умеет, пока вы не натолкнули на него.

Не знаю, кто первый это написал -

Я устанавливал и русифицированную версию 2.6 редактора Ted, однако после некоторого периода испытаний вернулся к англоязычной версии 2.7, которая датирована 31 декабря 1999 г., и в которой устранены некоторые недостатки предыдущей версии.

Например, у Костромина это есть - http://rus-linux.net/kos.php?name=/book1/gl-12/gl_12_07.html

Стало интересно - откуда они взяли версию 2.7 или 2.6 ?
Если я скачал с офсайта, наверное, самую свежую, и она всего лишь 2.23 от 4 Февраля 2013 года.

chukcha ★★★★ ()
Ответ на: комментарий от chukcha

Я устанавливал и русифицированную версию 2.6 редактора Ted

А у меня весь софт и так на английском. Может возьмусь за перевод Ted на русский язык, если свободное время будет.

откуда они взяли версию 2.7 или 2.6 ?

Завалялись эти версии где-то, скорее всего.

самую свежую, и она всего лишь 2.23

23 больше, чем 6 и 7.

minda ()
Ответ на: комментарий от minda

23 больше, чем 6 и 7.

Точно! Глаз замылился :-)

Кто-то его уже русифицировал -

Русифицированный вариант редактора можно найти на сервере ftp://ftp.logic.ru/ (конечно, русификация по версиям чуть отстает).

но этот фтпишник уже ничего не показывает, заходил на него по всякому.

Отсутствие русификации, конечно, не критично, но привычнее видеть наш интерфейс.
И да, ее можно сделать самостоятельно, благо работы там немного -

В заключение замечу, что Ted позволяет осуществить русификацию интерфейса. Достаточно перевести на русский язык файл ресурсов, который находится в каталоге /usr/X11R6/lib/X11/app-defaults/ru и называется Ted. Если такого каталога нет, его нужно создать и складывать туда все русифицированные ресурсы. После этого, будучи запущенным с русской локалью, Ted будет выводить все меню и большую часть сообщений в диалоговых окнах по-русски.

Так что могу сказать тоже самое :-) ---

Может возьмусь за перевод Ted на русский язык, если свободное время будет.

Где только его взять, это свободное время. Давно спать пора, а я всю ночь работаю.

chukcha ★★★★ ()
Ответ на: комментарий от greenman

https://www.opennet.ru/openforum/vsluhforumID15/4579.html#16

Я то-думал, что ты на самом деле всё доступное уже перепробовал.

Я тоже так думал, но видимо, на каком-то этапе перепробования выдохся и до Теда не дошел, или почему-то пропустил.

Ещё tea вроде бы подобное декларирует.

www.linux.org.ru/tag/tea

Поставил только что и его. Встал легко и запустился на русском.
Да, Петруха Семилетов славно потрудился!
Много хорошего и полезного, даже синтаксис программистских языков есть.
И цветовая раскраска шрифта есть.
Только и он уже на пути сотворения монстра, имхо.

А вот вставки изображений не нашел. Плохо искал?
Без них ну никак.

chukcha ★★★★ ()
Последнее исправление: chukcha (всего исправлений: 2)
Ответ на: комментарий от XoFfiCEr

Ага. Элементарщина. Именно по этой причине каких-то 5 лет назад RTF документы да так, чтобы там что-то куда-то не уехало, нельзя было открыть ни одним редактором в линуксах разумеется.

peregrine ★★★★★ ()
Последнее исправление: peregrine (всего исправлений: 1)
Ответ на: комментарий от minda

Скачать зависимость libjpeg62-turbo для Debian (8 и выше)

Да - а что это за зависимость такая и для чего она нужна Ted'у?
И поскольку нужна, то почему ее нет на его офсайте?

chukcha ★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.