LINUX.ORG.RU

Не запускается alacarte

 , ,


0

1

Доброго дня всем. При запуске alacarte через терминал выбивает ошибку.

(alacarte:690): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion 'gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

(alacarte:690): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion 'gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
Traceback (most recent call last):
  File "/usr/lib/python-exec/python2.7/alacarte", line 24, in <module>
    main()
  File "/usr/lib64/python2.7/site-packages/Alacarte/MainWindow.py", line 454, in main
    app.setMenuBasename(basename)
  File "/usr/lib64/python2.7/site-packages/Alacarte/MainWindow.py", line 65, in setMenuBasename
    self.editor = MenuEditor(menu_basename)
  File "/usr/lib64/python2.7/site-packages/Alacarte/MenuEditor.py", line 36, in __init__
    self.load()
  File "/usr/lib64/python2.7/site-packages/Alacarte/MenuEditor.py", line 49, in load
    if not self.tree.load_sync():
gi._glib.GError: Failed to look up menu_file for "applications.menu"
Я искал в гугле,там были похожие ошибки и предлагалось выполнить python-updater, но это ничего не дало.Также пробовал создавать файл ~/.config/menus/application.menu?,alacarte запускалось,но изменения не сохранялись.

но изменения не сохранялись.

https://git.gnome.org/browse/alacarte/commit/Alacarte/MenuEditor.py?id=e65fd3...

def get_default_menu():
  prefix = os.environ.get('XDG_MENU_PREFIX', '')
  return prefix + 'applications.menu'

Посмотри куда указывает переменная окружения XDG_MENU_PREFIX. (содержимое должно заканчиваться на /). В этой директории и должен лежать applications.menu. Если такой переменной нету - надо создать. Если ты используешь Gnome, эта переменная по идее должна быть установлена им.

stevejobs ★★★★☆ ()

Используй MenuLibre.

Deleted ()
Ответ на: комментарий от Armoken

пропиши ее в /etc/profile

олсо, я слегка в опупении, что для того чтобы запустить Алакарте, нужно читать его исходники. Вот это выкрутасы! В Гноме всё так?

stevejobs ★★★★☆ ()
Последнее исправление: stevejobs (всего исправлений: 2)
Ответ на: комментарий от stevejobs

Вообще я использую openbox с панельками xfce4.Cпасибо,попробую.

Armoken ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.