LINUX.ORG.RU

[gpodder] перестал запускаться


0

0

С вот таким вот питоновским выхлопом:

/usr/lib64/python2.6/site-packages/dbus/connection.py:242: DeprecationWarning: object.__init__() takes no parameters
  super(Connection, self).__init__(*args, **kwargs)
Creating new from file gPodder
Traceback (most recent call last):
  File "/usr/bin/gpodder", line 192, in <module>
    gui.main()
  File "/usr/lib64/python2.6/site-packages/gpodder/gui.py", line 5041, in main
    gp = gPodder(bus_name)
  File "/usr/lib64/python2.6/site-packages/gpodder/gui.py", line 367, in __init__
    BuilderWidget.__init__(self)
  File "/usr/lib64/python2.6/site-packages/gpodder/gui.py", line 149, in __init__
    uibase.GtkBuilderWidget.__init__(self, gpodder.ui_folder, gpodder.textdomain, **kwargs)
  File "/usr/lib64/python2.6/site-packages/gpodder/uibase.py", line 62, in __init__
    self.set_attributes()
  File "/usr/lib64/python2.6/site-packages/gpodder/uibase.py", line 172, in set_attributes
    raise AttributeError("instance %s already has an attribute %s" % (self,widget_api_name))
AttributeError: instance <gpodder.gui.gPodder at /gui at 0xfd1e10> already has an attribute GtkHBox
revdep-rebuild ничего не выявил. Точно не уверен, но это вероятно началось после обновления gtk+ до 2.20.0. Как решить проблему?

ps Откатывать gtk не вариант, ибо мне за n лет страшно надоел мягко говоря не шустрый диалог открытия файлов и обновившись просто гора с плеч...


> payableondeath@localhost ~ $ eix gpodder

* media-sound/gpodder

Available versions: 0.12.1!t ~0.15.1!t ~0.15.2!t ~0.16.1!t ~0.17.0!t {ipod libnotify mad}


> Homepage: http://gpodder.berlios.de/

Description: gPodder is a Podcast receiver/catcher written in Python, using GTK.


Ох уж эти unstable'оеды.

PayableOnDeath ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.