LINUX.ORG.RU

Pypanel


0

0

Поставил последнюю pypanel. Все требования точно удовлетворены.

$pypanel
/usr/lib/python2.3/site-packages/Xlib/display.py:30: DeprecationWarning: Non-ASCII character '\xf6' in file /usr/lib/python2.3/site-packages/Xlib/protocol/display.py on line 749, but no encoding declared; see http://www.python.org/peps/pep-0263.html for details
import protocol.display
Traceback (most recent call last):
File "/usr/bin/pypanel", line 923, in ?
PyPanel(display.Display())
File "/usr/lib/python2.3/site-packages/Xlib/display.py", line 80, in __init__
self.display = _BaseDisplay(display)
File "/usr/lib/python2.3/site-packages/Xlib/display.py", line 67, in __init__
apply(protocol.display.Display.__init__, (self, ) + args, keys)
File "/usr/lib/python2.3/site-packages/Xlib/protocol/display.py", line 122, in __init__
self.default_screen = min(self.default_screen, len(self.info.roots) - 1)
File "/usr/lib/python2.3/site-packages/Xlib/protocol/rq.py", line 1371, in __getattr__
raise AttributeError(attr)
AttributeError: roots

Как лечится? Дистрибутив - gentoo.

anonymous

Re: Pypanel

я вылечил перестановкой python2.3 на python2.4 и почемуто он нехотел запускаться в опенбоксе (когда был python2.3)

tomas ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.