LINUX.ORG.RU

GNOME3, gnome-shell, g-s-d...


0

2

Черт меня дёрнул попробовать собрать GNOME 3. Собрав зависимости и gnome-shell, я попытался его запустить. В ответ мне проговорило чудо заморское:

fat0troll@murcielago:~/Desktop/gnome3$ gnome-shell --replace
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "atk-bridge"
Предупреждение менеджера окон: Не удалось загрузить тему «(null)»: Не удалось найти допустимый файл для темы (null)

Предупреждение менеджера окон: Log level 16: Accessibility: org.a11y.atspi schema not found. Are you sure that at-spi or at-spi2 is installed on your system?
Предупреждение менеджера окон: Log level 16: Accessibility: invalid module path (NULL)
Предупреждение менеджера окон: Log level 16: Accessibility: error loading the atk-bridge. Although the accessibility on the system is enabled and clutter accessibility is also enabled, accessibility support on GNOME Shell will not work
      JS LOG: Cannot create "Network" item, .desktop file not found or corrupt.
      JS LOG: GNOME Shell started at Sun Feb 20 2011 18:42:30 GMT+0300 (MSK)
Предупреждение менеджера окон: Log level 16: The program 'mutter' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 678 error_code 8 request_code 7 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

/usr/bin/gnome-shell:596: Warning: g_variant_new_bytestring: assertion `string != NULL' failed
  appinfo.launch()
/usr/bin/gnome-shell:596: Warning: g_variant_new_variant: assertion `value != NULL' failed
  appinfo.launch()
/usr/bin/gnome-shell:596: Warning: g_variant_get_type: assertion `value != NULL' failed
  appinfo.launch()
/usr/bin/gnome-shell:596: Warning: g_variant_type_is_subtype_of: assertion `g_variant_type_check (type)' failed
  appinfo.launch()
/usr/bin/gnome-shell:596: Warning: g_variant_builder_add_value: assertion `!GVSB(builder)->expected_type || g_variant_is_of_type (value, GVSB(builder)->expected_type)' failed
  appinfo.launch()
/usr/bin/gnome-shell:596: Warning: g_variant_builder_end: assertion `GVSB(builder)->offset >= GVSB(builder)->min_items' failed
  appinfo.launch()
fat0troll@murcielago:~/Desktop/gnome3$ Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "atk-bridge"

(gnome-panel:20771): Gtk-CRITICAL **: gtk_orientable_get_orientation: assertion `GTK_IS_ORIENTABLE (orientable)' failed
Не удалось открыть файл «epiphany.desktop» для кнопки запуска панели

fat0troll@murcielago:~/Desktop/gnome3$ 

и сверкнул мне панелькой обычной. Запуск mutter --replace даёт нечто невообразимое без заголовков окна. А запуск gnome-setting-daemon выдаёт это:

fat0troll@murcielago:~/Desktop/gnome3$ gnome-settings-daemon 
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "atk-bridge"

GLib-GIO-ERROR **: schema does not contain a key named 'automatic-mnemonics'
aborting...
Аварийный останов

Что я забыл скомпилять?

fat0troll@murcielago:~/Desktop/gnome3$ ls packages/
gdk-pixbuf-2.23.0-x86_64-1.txz
gjs-0.7.10-x86_64-1.txz
glib2-2.28.0-x86_64-1.txz
gnome-control-center-2.91.6-x86_64-1.txz
gnome-desktop-2.91.6.1-x86_64-1.txz
gnome-panel-2.91.6-x86_64-1.txz
gnome-settings-daemon-2.91.9-x86_64-1.txz
gnome-shell-2.91.6-x86_64-1.txz
gnome-terminal-2.33.5-x86_64-1.txz
gnome-themes-2.91.5-noarch-1.txz
gnome2-desktop-2.32.1-x86_64-1.txz
gobject-introspection-0.10.2-x86_64-1.txz
gsettings-desktop-schemas-0.1.4-noarch-1.txz
gtk+3-3.0.0-x86_64-1.txz
gtk3-engines-2.91.1-x86_64-1.txz
libasyncns-0.8-x86_64-1.txz
libcanberra-gtk3-0.26-x86_64-1.txz
libcroco-0.6.2-x86_64-1.txz
libgnomekbd-2.91.5-x86_64-1.txz
libgweather-2.91.6-x86_64-1.txz
libnotify-0.7.1-x86_64-1.txz
libpulse-0.9.22-x86_64-1.txz
libwnck-2.91.6-x86_64-1.txz
mutter-2.91.6-x86_64-1.txz
nautilus-2.91.9-x86_64-1.txz

Что я забыл скомпилять?

Для начала:

Accessibility: org.a11y.atspi schema not found. Are you sure that at-spi or at-spi2 is installed on your system?

reader ()
Ответ на: комментарий от reader
fat0troll@murcielago:~/Desktop/gnome3$ mpkg-search at-spi
Запрос базы данных...
 [2053] [ AIC_ ]	at-spi-1.32.0-x86_64-1	(Assistive Technology Service Provider Interface)

установлен он

ы?

DoctorSinus ★★★★★ ()
Ответ на: комментарий от reader

меня больше волнует

редупреждение менеджера окон: Не удалось загрузить тему «(null)»: Не удалось найти допустимый файл для темы (null)

DoctorSinus ★★★★★ ()

Попробуй usr/lib/gtk-2.0/libcanberra-gtk-module.so удалить или usr/lib/libcanberra-gtk.so (не помню кого именно из них). Только не системные, естественно, а тот, что jhbuild собрал для gnome-shell

kss ★★★★★ ()
Ответ на: комментарий от kss

пфф, я собирал не jhbuild'ом, а системно :)

и да, с либканберрой удалял уже что-то там :)

DoctorSinus ★★★★★ ()
Ответ на: комментарий от DoctorSinus

> пфф, я собирал не jhbuild'ом, а системно :)

Ты накосячил, а теперь просишь разбираться в полученной куче бесполезного хлама другим? Не многовато ли хочешь?

unanimous ★★★★★ ()
Ответ на: комментарий от reader

gnome-themes-standard? Это просто gnome-themes или таки другой пакет?

DoctorSinus ★★★★★ ()
Ответ на: комментарий от DoctorSinus

Зря, лучше jhbuild'ом. И проще, и работоспособней, и вычищать потом легче)

kss ★★★★★ ()
Ответ на: комментарий от kss

вычищать мне нормально, mpkg-rollback зачистит всё, что надо

а я просто собираю в первый раз GNOME 3, в случае успеха хочу это дело причесать и в реп отдельный положить :)

DoctorSinus ★★★★★ ()

есть мнение, что сломан именно gnome-settings-daemon, но где? :)

DoctorSinus ★★★★★ ()

РЕШЕНИЕ

обновить gsettings-desktop-schemas до 0.1.4 :)

DoctorSinus ★★★★★ ()
Ответ на: РЕШЕНИЕ от DoctorSinus

фиг там, это только для работы gnome-settings-daemon. Ищем дальше

DoctorSinus ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.