LINUX.ORG.RU

На одноплатнике на чипе Amlogic S912 если модулем или вкомпилить в ядро panfrost драйвер, то не запускается Х-сессия.

 , ,


0

1

Mesa последняя. Логи:

$ cat /var/log/Xorg.0.log
[    41.032] 
X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
[    41.049] Build Operating System: Linux 5.10.27-gentoo-bur aarch64 Gentoo
[    41.060] Current Operating System: Linux tx9s 5.10.27-gentoo-bur #5 SMP PREEMPT Sun Aug 15 13:20:44 MSK 2021 aarch64
[    41.061] Kernel command line: root=PARTUUID=27a1adcc-01 rootwait rootfstype=ext4 console=ttyAML0,115200 console=tty0,38400
[    41.079] Build Date: 14 August 2021  12:15:30AM
[    41.084]  
[    41.090] Current version of pixman: 0.40.0
[    41.101]  Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
[    41.101] Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    41.125] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan  1 03:00:41 1970
[    41.151] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    41.157] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    41.159] (==) No Layout section.  Using the first Screen section.
[    41.159] (==) No screen section available. Using defaults.
[    41.159] (**) |-->Screen "Default Screen Section" (0)
[    41.159] (**) |   |-->Monitor "<default monitor>"
[    41.160] (==) No monitor specified for screen "Default Screen Section".
 Using a default monitor configuration.
[    41.160] (**) Option "BlankTime" "0"
[    41.160] (**) Option "StandbyTime" "0"
[    41.160] (**) Option "OffTime" "0"
[    41.160] (==) Automatically adding devices
[    41.160] (==) Automatically enabling devices
[    41.160] (==) Automatically adding GPU devices
[    41.160] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    41.173] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    41.173]  Entry deleted from font path.
[    41.174] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    41.174]  Entry deleted from font path.
[    41.174] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    41.174]  Entry deleted from font path.
[    41.174] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    41.175]  Entry deleted from font path.
[    41.175]  (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    41.175] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    41.175]  Entry deleted from font path.
[    41.175]  (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    41.175] (==) FontPath set to:
 /usr/share/fonts/misc/
[    41.176] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    41.176] (II) The server relies on udev to provide the list of input devices.
 If no devices become available, reconfigure udev or disable AutoAddDevices.
[    41.176] (II) Loader magic: 0xaaaad9c49c28
[    41.176] (II) Module ABI versions:
[    41.176]  X.Org ANSI C Emulation: 0.4
[    41.176]  X.Org Video Driver: 24.1
[    41.176]  X.Org XInput driver : 24.1
[    41.176]  X.Org Server Extension : 10.0
[    41.178] (II) xfree86: Adding drm device (/dev/dri/card0)
[    41.195] (II) no primary bus or device found
[    41.196]  falling back to /sys/devices/platform/soc/d0100000.vpu/drm/card0
[    41.197] (II) LoadModule: "glx"
[    41.207] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    41.232] (II) Module glx: vendor="X.Org Foundation"
[    41.233]  compiled for 1.20.11, module version = 1.0.0
[    41.233]  ABI class: X.Org Server Extension, version 10.0
[    41.233] (==) Matched modesetting as autoconfigured driver 0
[    41.233] (==) Matched fbdev as autoconfigured driver 1
[    41.233] (==) Assigned the driver to the xf86ConfigLayout
[    41.233] (II) LoadModule: "modesetting"
[    41.233] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[    41.236] (II) Module modesetting: vendor="X.Org Foundation"
[    41.236]  compiled for 1.20.11, module version = 1.20.11
[    41.236]  Module class: X.Org Video Driver
[    41.236]  ABI class: X.Org Video Driver, version 24.1
[    41.236] (II) LoadModule: "fbdev"
[    41.237] (WW) Warning, couldn't open module fbdev
[    41.237] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    41.237] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    41.237] (--) using VT number 12
Какие варианты? Там ещё какие то амлоджиковские драйвера есть, их случайно не надо выкинуть, не конфликтят с панфрост?

★★★★

Ответ на: комментарий от burato

Как видишь, иксы по какой-то причине его хотят и фейлятся от недоступности. Может стоит попробовать нарисовать конфиг иксов с жругим драйвером, или таки включить поддержку фреймбуфера.

manntes-live ★★★ ()
Ответ на: комментарий от burato

А fb драйвер вообще нужен?

Panfrost сотоварищи - это чисто про 3D и вроде как там нет 2D ускорения.
Выводом на экран заведует fbdev.

В ARM чипах вообще всё очень весело с зоопарком различных IP блоков, отвечающих каждый за своё.

devl547 ★★★★★ ()
Последнее исправление: devl547 (всего исправлений: 1)
Ответ на: комментарий от burato

А fb драйвер вообще нужен?

Для panfrost-а fb не нужен. Но panfrost тут даже и не дергался вообще. Либо его нет, либо в конфиге явно указано, что нужен fb. А вот fb по сути не может не стартовать. Значит ему чего-то не хватает. Текстовая консоль хотя бы запускается?

zloy_starper ★★★ ()

Установил драйвер x11-drivers/xf86-video-fbdev, проблема теперь в другом месте:

[    33.207] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    33.207] (II) FBDEV: driver for framebuffer: fbdev
[    33.207] (--) using VT number 12

[    33.234] (WW) Falling back to old probe method for modesetting
[    33.234] (WW) Falling back to old probe method for fbdev
[    33.234] (II) Loading sub module "fbdevhw"
[    33.234] (II) LoadModule: "fbdevhw"
[    33.234] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[    33.237] (II) Module fbdevhw: vendor="X.Org Foundation"
[    33.237]    compiled for 1.20.11, module version = 0.0.2
[    33.237]    ABI class: X.Org Video Driver, version 24.1
[    33.237] (II) FBDEV(0): using default device
[    33.247] (II) modeset(G0): using drv /dev/dri/card1
[    33.247] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    33.247] (EE) 
Fatal server error:
[    33.247] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices

burato ★★★★ ()