LINUX.ORG.RU

Не запускается startx в Recalbox 6.1.1 (PC x64)

 , , ,


0

1

Приветствую!

Скачал Recalbox 6.1.1-DragonBlaze с оф. сайта. Встала нормально, но после перезагрузки не запускается startx.

Если запускать startx в ручную, работает.

Компьютер ASUS MiniPC PN. Современный селерон со встроеной видюхой. Подключаю ЭЛТ монитор через VGA

Уже втрой день не могу найти решение, гугл не помог)

# /var/log/Xorg.0.log

[ 7.027]X.Org X Server 1.19.6
Release Date: 2017-12-20
[ 7.027] X Protocol Version 11, Revision 0
[ 7.027] Build Operating System: Linux 5.0.0-32-generic x86_64
[ 7.027] Current Operating System: Linux RECALBOX 4.15.16 #1 SMP Wed Nov 13 13:01:00 CET 2019 i686
[ 7.027] Kernel command line: BOOT_IMAGE=/boot/bzImage label=RECALBOX console=tty3 quiet loglevel=0
[ 7.027] Build Date: 13 November 2019 12:53:07PM
[ 7.027]
[ 7.027] Current version of pixman: 0.34.0
[ 7.027] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 7.027] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 7.027] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 7 01:57:21 2019
[ 7.046] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 7.046] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 7.068] (==) No Layout section. Using the first Screen section.
[ 7.068] (==) No screen section available. Using defaults.
[ 7.068] (**) |-->Screen "Default Screen Section" (0)
[ 7.068] (**) | |-->Monitor "<default monitor>"
[ 7.068] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 7.068] (==) Automatically adding devices
[ 7.068] (==) Automatically enabling devices
[ 7.068] (==) Automatically adding GPU devices
[ 7.073] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 7.081] (WW) The directory "/usr/share/fonts/X11//TTF/" does not exist.
[ 7.081] Entry deleted from font path.
[ 7.081] (WW) The directory "/usr/share/fonts/X11//OTF/" does not exist.
[ 7.081] Entry deleted from font path.
[ 7.081] (WW) The directory "/usr/share/fonts/X11//Type1/" does not exist.
[ 7.081] Entry deleted from font path.
[ 7.085] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11//100dpi/".
[ 7.085] Entry deleted from font path.
[ 7.085] (Run 'mkfontdir' on "/usr/share/fonts/X11//100dpi/").
[ 7.088] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11//75dpi/".
[ 7.088] Entry deleted from font path.
[ 7.088] (Run 'mkfontdir' on "/usr/share/fonts/X11//75dpi/").
[ 7.088] (==) FontPath set to:
/usr/share/fonts/X11//misc/
[ 7.088] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 7.088] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 7.088] (II) Loader magic: 0x8293640
[ 7.088] (II) Module ABI versions:
[ 7.088] X.Org ANSI C Emulation: 0.4
[ 7.088] X.Org Video Driver: 23.0
[ 7.088] X.Org XInput driver : 24.1
[ 7.088] X.Org Server Extension : 10.0
[ 7.090] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 7.090] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[ 7.092] (--) PCI:*(0:0:2:0) 8086:3185:1043:875e rev 3, Mem @ 0xa0000000/16777216, 0x90000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[ 7.092] (II) Open ACPI successful (/var/run/acpid.socket)
[ 7.092] (II) LoadModule: "glx"
[ 7.098] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 7.107] (II) Module glx: vendor="X.Org Foundation"
[ 7.107] compiled for 1.19.6, module version = 1.0.0
[ 7.107] ABI class: X.Org Server Extension, version 10.0
[ 7.107] (==) Matched intel as autoconfigured driver 0
[ 7.107] (==) Matched modesetting as autoconfigured driver 1
[ 7.107] (==) Matched fbdev as autoconfigured driver 2
[ 7.107] (==) Matched vesa as autoconfigured driver 3
[ 7.107] (==) Assigned the driver to the xf86ConfigLayout
[ 7.107] (II) LoadModule: "intel"
[ 7.111] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 7.122] (II) Module intel: vendor="X.Org Foundation"
[ 7.122] compiled for 1.19.6, module version = 2.99.917
[ 7.122] Module class: X.Org Video Driver
[ 7.122] ABI class: X.Org Video Driver, version 23.0
[ 7.122] (II) LoadModule: "modesetting"
[ 7.122] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 7.131] (II) Module modesetting: vendor="X.Org Foundation"
[ 7.131] compiled for 1.19.6, module version = 1.19.6
[ 7.131] Module class: X.Org Video Driver
[ 7.131] ABI class: X.Org Video Driver, version 23.0
[ 7.131] (II) LoadModule: "fbdev"
[ 7.131] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 7.135] (II) Module fbdev: vendor="X.Org Foundation"
[ 7.135] compiled for 1.19.6, module version = 0.4.4
[ 7.135] Module class: X.Org Video Driver
[ 7.135] ABI class: X.Org Video Driver, version 23.0
[ 7.135] (II) LoadModule: "vesa"
[ 7.135] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 7.139] (II) Module vesa: vendor="X.Org Foundation"
[ 7.139] compiled for 1.19.6, module version = 2.3.4
[ 7.139] Module class: X.Org Video Driver
[ 7.139] ABI class: X.Org Video Driver, version 23.0
[ 7.139] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[ 7.139] (II) intel: Driver for Intel(R) HD Graphics
[ 7.139] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[ 7.139] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[ 7.139] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 7.139] (II) FBDEV: driver for framebuffer: fbdev
[ 7.139] (II) VESA: driver for VESA chipsets: vesa
[ 7.139] (--) using VT number 2

[ 7.147] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20171023
[ 7.149] (WW) Falling back to old probe method for modesetting
[ 7.149] (WW) Falling back to old probe method for fbdev
[ 7.149] (II) Loading sub module "fbdevhw"
[ 7.149] (II) LoadModule: "fbdevhw"
[ 7.150] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 7.153] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 7.153] compiled for 1.19.6, module version = 0.0.2
[ 7.153] ABI class: X.Org Video Driver, version 23.0
[ 7.153] (WW) Falling back to old probe method for vesa
[ 9.290] (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13].
[ 9.290] (II) intel(0): [drm] Contents of '/sys/kernel/debug/dri/0/clients':
[ 9.290] (II) intel(0): [drm] command pid dev master a uid magic
[ 9.290] (II) intel(0): [drm] ffplay 226 0 y y 0 0
[ 9.290] (II) intel(0): [drm] X 924 0 n y 0 0
[ 9.290] (EE) intel(0): Failed to claim DRM device.
[ 9.290] (II) UnloadModule: "intel"
[ 9.290] (EE) Screen(s) found, but none have a usable configuration.
[ 9.290] (EE)
Fatal server error:
[ 9.290] (EE) no screens found(EE)
[ 9.290] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 9.290] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 9.290] (EE)
[ 9.304] (EE) Server terminated with error (1). Closing log file.

Ответ на: комментарий от Artur-

[code]

/etc/inittab

This inittab is a basic inittab sample for sysvinit, which mimics

Buildroot’s default inittab for BusyBox.

id:3:initdefault:

si0::sysinit:/bin/mount -t proc proc /proc #si1::sysinit:/bin/mount -o remount,rw / si2::sysinit:/bin/mkdir -p /dev/pts si3::sysinit:/bin/mkdir -p /dev/shm si4::sysinit:/bin/mount -a si5::sysinit:/bin/hostname -F /etc/hostname si6::sysinit:/etc/init.d/rcS

S0:1:respawn:/sbin/getty -L ttyS0 115200 vt100 # GENERIC_SERIAL

2:3:respawn:/sbin/getty 38400 tty2

Stuff to do for the 3-finger salute

ca::ctrlaltdel:/sbin/reboot

Stuff to do before rebooting

shd0:06:wait:/etc/init.d/rcK shd1:06:wait:/sbin/swapoff -a shd2:06:wait:/bin/umount -a -r -f

The usual halt or reboot actions

hlt0:0:wait:/sbin/halt -dhp reb0:6:wait:/sbin/reboot

[/code]

Artur- ()
Ответ на: комментарий от Artur-

нет. не inittab. у тебя в первом листинге вот это: 7.027] Kernel command line: BOOT_IMAGE=/boot/bzImage label=RECALBOX console=tty3 quiet loglevel=0

загрузчик grub2? если да то ищи в поиске ‘grub2 config’ или ‘update grub’

у меня grub4dos, все меняю в menu.lst,руками,поэтому по grub2 не очень. он конфигурируется скриптами

alex00 ()
Ответ на: комментарий от alex00

что первый, что второй вариант выдают туже ошибку

/boot/EFI/BOOT/grub.cfg

set default="1"
set timeout="0"

set menu_color_normal=cyan/blue
set menu_color_highlight=white/blue

menuentry "Recalbox" {
	linux /boot/bzImage label=RECALBOX console=tty3 quiet loglevel=0
	initrd /boot/initrd.gz
}

menuentry "Recalbox (verbose)" {
	linux /boot/bzImage label=RECALBOX console=tty1 loglevel=7
	initrd /boot/initrd.gz
}
Artur- ()
Ответ на: комментарий от alex00

ничего не меняется

сколько разделов на диске ? сколько линуксов в них ? на флешке установлен Recalbox 6.1.1 (PC x64)

тут не понятно то, что если зайти под рутом через putty и прописать startx, то запускается, а при загрузке линукса сам запускаться не хочет

если прописать startx в inittab, то после загрузки линукса, в левом верхнем углу, появляется предложение ввести логин и пароль

Artur- ()
Ответ на: комментарий от Anoxemian

После записи образа рекалбокса на флешку, первый запуск проходит нормально, со второго не стартует startx, стартует только вручную из под рута.

(EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

Это все видели, нужно решение)

Как я и говорил, в линуксе я не силен, по этому если есть что предложить в плане решения, буду благодарен)

Artur- ()
Ответ на: комментарий от alex00

в том то и дело, что по этим запросам:

/dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
intel(0): [drm] failed to set drm interface version: Permission denied [13]
intel(0): Failed to claim DRM device.

я еще вчера перелопатил весь интернет, ничего не помогло.

Section «DRI»
 Group «video»
 Mode 0666
EndSection

Также не помогает.

Права после загрузки на /dev/dri.card0 остаются 0660

Artur- ()
Ответ на: комментарий от alex00

Если дело в правах на /dev/dri/card0, то как выставить права 0666 при запуске системы, до запуска startx?

И почему самый первый запуск после записи образа OS на флешку проходит нормально с теми же правами на все это, а уже со второго что то ломается?

Artur- ()
Ответ на: комментарий от alex00

Эти секции были добавлены во все места куда их можно было добавить:

/etc/X11/xorg.conf
/etc/X11/xorg.conf.d/10-dri.conf
/usr/share/X11/xorg.conf.d/10-dri.conf

права на файл /dev/dri/card0 оно не поменяло

но права поменялись костылем при запуске линукса:

chmod 777 /dev/dri/card0
startx

но проблему это также не решило, таже ошибка

Artur- ()
Ответ на: комментарий от alex00

вот все пользователи:

root:x:0:0:root:/recalbox/share/system:/bin/sh
daemon:x:1:1:daemon:/usr/sbin:/bin/false
bin:x:2:2:bin:/bin:/bin/false
sys:x:3:3:sys:/dev:/bin/false
sync:x:4:100:sync:/bin:/bin/sync
mail:x:8:8:mail:/var/spool/mail:/bin/false
www-data:x:33:33:www-data:/var/www:/bin/false
operator:x:37:37:Operator:/var:/bin/false
nobody:x:65534:65534:nobody:/home:/bin/false
avahi:x:1000:1000::/:/bin/false
dbus:x:1001:1001:DBus messagebus user:/var/run/dbus:/bin/false

из под рута startx заводится без проблем, по этому мне и интересно, из под какого пользователя сам запускается startx при запуске компьютера?

Artur- ()
Ответ на: комментарий от Artur-

https://losst.ru/gruppy-polzovatelej-linux

$ usermod опции имя_пользователя

-G - дополнительные группы, в которые нужно добавить пользователя
-g изменить основную группу для пользователя
-R удалить пользователя из группы.

Добавить пользователя в группу можно командой usermod:

sudo usermod -G -a имя_группы имя_пользователя

alex00 ()
Ответ на: комментарий от alex00
root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
kmem:x:9:
wheel:x:10:root
cdrom:x:11:
dialout:x:18:
floppy:x:19:
video:x:28:root
audio:x:29:root
tape:x:32:
www-data:x:33:
operator:x:37:
utmp:x:43:
plugdev:x:46:
staff:x:50:
lock:x:54:
netdev:x:82:
users:x:100:
nogroup:x:65534:
avahi:x:1000:
input:x:1002:
dbus:x:1001:dbus

рута я уже добавил в группу video, не помогло

Artur- ()