LINUX.ORG.RU

Как заставить X11 выставлять «лучшее» разрешение экрана?

 ,


0

1

Debian. С минимальным набором пакетов, установлен xorg без менеджера окон и прочего.
При загрузке выставляет разрешение экрана 1024x768. Хотя сам же в логе пишет, что по EDID определил более лучший вариант:

[    97.689]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[    97.689] Build Operating System: Linux 4.9.0-8-arm64 aarch64 Debian
[    97.689] Current Operating System: Linux orangepilite2 5.4.20-sunxi64 #20.02.1 SMP Mon Feb 17 02:37:37 CET 2020 aarch64
[    97.689] Kernel command line: root=UUID=4034b53a-05c9-4d4f-9257-f179d7551743 rootwait rootfstype=ext4  consoleblank=0 loglevel=0 ubootpart=425f501c-01 usb-storage.quirks=0x2537:0x1066:u,
[    97.689] Build Date: 05 March 2019  08:11:12PM
[    97.689] xorg-server 2:1.20.4-1 (https://www.debian.org/support)
[    97.689] Current version of pixman: 0.36.0
[    97.689]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    97.689] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    97.690] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar  9 10:25:07 2020
[    97.694] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    97.694] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    97.702] (==) No Layout section.  Using the first Screen section.
[    97.702] (**) |-->Screen "Screen0" (0)
[    97.703] (**) |   |-->Monitor "<default monitor>"
[    97.703] (==) No monitor specified for screen "Screen0".
        Using a default monitor configuration.
[    97.703] (**) Option "BlankTime" "0"
[    97.703] (**) Option "StandbyTime" "0"
[    97.703] (**) Option "SuspendTime" "0"
[    97.703] (**) Option "OffTime" "0"
[    97.703] (==) Automatically adding devices
[    97.703] (==) Automatically enabling devices
[    97.703] (==) Automatically adding GPU devices
[    97.703] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    97.714] (WW) The directory "/usr/share/fonts/X11/misc" does not exist.
[    97.714]    Entry deleted from font path.
[    97.714] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    97.714]    Entry deleted from font path.
[    97.714] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    97.714]    Entry deleted from font path.
[    97.714] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    97.714]    Entry deleted from font path.
[    97.714] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[    97.714]    Entry deleted from font path.
[    97.714] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    97.714]    Entry deleted from font path.
[    97.714] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    97.714]    Entry deleted from font path.
[    97.714] (==) FontPath set to:
        built-ins
[    97.714] (==) ModulePath set to "/usr/lib/xorg/modules"
[    97.714] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    97.714] (II) Loader magic: 0xaaaae08a6e08
[    97.714] (II) Module ABI versions:
[    97.714]    X.Org ANSI C Emulation: 0.4
[    97.714]    X.Org Video Driver: 24.0
[    97.714]    X.Org XInput driver : 24.1
[    97.715]    X.Org Server Extension : 10.0
[    97.716] (++) using VT number 7

[    97.716] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    97.717] (II) xfree86: Adding drm device (/dev/dri/card0)
[    97.729] (II) no primary bus or device found
[    97.729]    falling back to /sys/devices/platform/display-engine/drm/card0
[    97.729] (II) LoadModule: "glx"
[    97.731] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    97.873] (II) Module glx: vendor="X.Org Foundation"
[    97.874]    compiled for 1.20.4, module version = 1.0.0
[    97.874]    ABI class: X.Org Server Extension, version 10.0
[    97.874] (==) Matched modesetting as autoconfigured driver 0
[    97.874] (==) Matched fbdev as autoconfigured driver 1
[    97.874] (==) Assigned the driver to the xf86ConfigLayout
[    97.874] (II) LoadModule: "modesetting"
[    97.877] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    97.886] (II) Module modesetting: vendor="X.Org Foundation"
[    97.886]    compiled for 1.20.4, module version = 1.20.4
[    97.886]    Module class: X.Org Video Driver
[    97.886]    ABI class: X.Org Video Driver, version 24.0
[    97.886] (II) LoadModule: "fbdev"
[    97.886] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    97.890] (II) Module fbdev: vendor="X.Org Foundation"
[    97.890]    compiled for 1.20.0, module version = 0.5.0
[    97.890]    Module class: X.Org Video Driver
[    97.890]    ABI class: X.Org Video Driver, version 24.0
[    97.890] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    97.890] (II) FBDEV: driver for framebuffer: fbdev
[    97.912] (II) modeset(0): using drv /dev/dri/card0
[    97.912] (WW) Falling back to old probe method for fbdev
[    97.912] (II) Loading sub module "fbdevhw"
[    97.912] (II) LoadModule: "fbdevhw"
[    97.912] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    97.915] (II) Module fbdevhw: vendor="X.Org Foundation"
[    97.916]    compiled for 1.20.4, module version = 0.0.2
[    97.916]    ABI class: X.Org Video Driver, version 24.0
[    97.916] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    97.916] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[    97.916] (==) modeset(0): RGB weight 888
[    97.916] (==) modeset(0): Default visual is TrueColor
[    97.916] (II) Loading sub module "glamoregl"
[    97.916] (II) LoadModule: "glamoregl"
[    97.916] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    97.995] (II) Module glamoregl: vendor="X.Org Foundation"
[    97.996]    compiled for 1.20.4, module version = 1.0.1
[    97.996]    ABI class: X.Org ANSI C Emulation, version 0.4
[   100.521] (II) modeset(0): Refusing to try glamor on llvmpipe
[   100.547] (EE) modeset(0): glamor initialization failed
[   100.547] (II) modeset(0): ShadowFB: preferred NO, enabled NO
[   100.548] (II) modeset(0): Output HDMI-1 has no monitor section
[   100.549] (II) modeset(0): EDID for output HDMI-1
[   100.549] (II) modeset(0): Printing probed modes for output HDMI-1
[   100.549] (II) modeset(0): Modeline "1280x1024"x60.0  108.88  1280 1360 1496 1712  1024 1025 1028 1060 -hsync +vsync (63.6 kHz UP)
[   100.549] (II) modeset(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[   100.549] (II) modeset(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[   100.549] (II) modeset(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz e)
[   100.549] (II) modeset(0): Modeline "848x480"x60.0   33.75  848 864 976 1088  480 486 494 517 +hsync +vsync (31.0 kHz e)
[   100.549] (II) modeset(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[   100.549] (II) modeset(0): Output HDMI-1 connected
[   100.549] (II) modeset(0): Using user preference for initial modes
[   100.549] (II) modeset(0): Output HDMI-1 using initial mode 1280x1024 +0+0
[   100.549] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
[   100.549] (==) modeset(0): DPI set to (96, 96)
[   100.549] (II) Loading sub module "fb"
[   100.549] (II) LoadModule: "fb"
[   100.550] (II) Loading /usr/lib/xorg/modules/libfb.so
[   100.559] (II) Module fb: vendor="X.Org Foundation"
[   100.559]    compiled for 1.20.4, module version = 1.0.0
[   100.559]    ABI class: X.Org ANSI C Emulation, version 0.4
[   100.559] (II) UnloadModule: "fbdev"
[   100.559] (II) Unloading fbdev
[   100.560] (II) UnloadSubModule: "fbdevhw"
[   100.560] (II) Unloading fbdevhw
[   100.579] (==) modeset(0): Backing store enabled
[   100.579] (==) modeset(0): Silken mouse enabled
[   100.596] (II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
[   100.596] (==) modeset(0): DPMS enabled
[   100.596] (II) Initializing extension Generic Event Extension
[   100.597] (II) Initializing extension SHAPE
[   100.597] (II) Initializing extension MIT-SHM
[   100.598] (II) Initializing extension XInputExtension
[   100.603] (II) Initializing extension XTEST
[   100.603] (II) Initializing extension BIG-REQUESTS
[   100.603] (II) Initializing extension SYNC
[   100.604] (II) Initializing extension XKEYBOARD
[   100.604] (II) Initializing extension XC-MISC
[   100.605] (II) Initializing extension SECURITY
[   100.605] (II) Initializing extension XFIXES
[   100.605] (II) Initializing extension RENDER
[   100.606] (II) Initializing extension RANDR
[   100.607] (II) Initializing extension COMPOSITE
[   100.607] (II) Initializing extension DAMAGE
[   100.607] (II) Initializing extension MIT-SCREEN-SAVER
[   100.608] (II) Initializing extension DOUBLE-BUFFER
[   100.608] (II) Initializing extension RECORD
[   100.609] (II) Initializing extension DPMS
[   100.609] (II) Initializing extension Present
[   100.609] (II) Initializing extension DRI3
[   100.609] (II) Initializing extension X-Resource
[   100.610] (II) Initializing extension XVideo
[   100.610] (II) Initializing extension XVideo-MotionCompensation
[   100.610] (II) Initializing extension SELinux
[   100.610] (II) SELinux: Disabled on system
[   100.610] (II) Initializing extension GLX
[   100.611] (II) AIGLX: Screen 0 is not DRI2 capable
[   100.623] (II) IGLX: Loaded and initialized swrast
[   100.623] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[   100.623] (II) Initializing extension XFree86-VidModeExtension
[   100.623] (II) Initializing extension XFree86-DGA
[   100.623] (II) Initializing extension XFree86-DRI
[   100.626] (II) Initializing extension DRI2
[   100.627] (II) modeset(0): Damage tracking initialized
[   100.627] (II) modeset(0): Setting screen physical size to 338 x 270
[   100.880] (II) config/udev: Adding input device axp20x-pek (/dev/input/event0)
[   100.881] (II) No input driver specified, ignoring this device.
[   100.881] (II) This device may have been added with another device file.
[   103.353] (II) modeset(0): Disabling kernel dirty updates, not required.

При этом консоль загружена с параметрами video=1280x1024@60 и это так и есть.

Как-то до этого при том же раскладе всегда выбиралось наибольшее разрешение... Ну понятно что в конфиге прописал нужное - работает.
А почему раньше не так было? :))

Тут в вашем выводе пишется про 1280x1024, или это уже после правки конфига:

[   100.549] (II) modeset(0): Output HDMI-1 connected
[   100.549] (II) modeset(0): Using user preference for initial modes
[   100.549] (II) modeset(0): Output HDMI-1 using initial mode 1280x1024 +0+0

А почему раньше не так было?

С этой же версией X.org X Server?

mky ★★★★★ ()
Ответ на: комментарий от mky

Это я уже добавил Screen0 в conf.d....
На таком же железе с Debian так и было.
Тут купил новый «комп» (конфиг тот же) и скачал новый образ и вот так.
Не я конечно, переживу. Но просто любопытно что отвечает за такое поведение. Раньше я не задумываясь подтыкал любой моник, перезагружал и всё становилось на свои места.

Spider55 ()