LINUX.ORG.RU

Не только debian 17 июля заморозился. Happy 28th birthday, Slackware! :-)

 ,


1

1

a/aaa_base-15.0-x86_64-1.txz: Upgraded. Bump version numbers in /etc/os-release and /etc/slackware-version. Not quite ready to freeze things for a release candidate, but getting there. Initial email to root still needs a refresh

http://www.slackware.com/changelog/current.php?cpu=x86_64

Sat Jul 17 17:55:10 UTC 2021 Happy 28th birthday, Slackware! :-)

К своему стыду ни разу не пробовал Slackware. Прошу рассказать, как установить минимальную версию (WM люблю) с Xorg? Какой путь настройки? Как обновлять? Где и что почитать?

Просто выбираешь установку terse, и снимаешь пометки с некоторых групп пакетов, и всё. Хотя вообще Slackware не очень хорошо подходит для минималистичной системы, так как в базе нет отслеживания зависимостей. Но, я думаю, если снимешь пометки с kde, kdei, xfce, t (нафиг тебе texlive?) и ещё какая-то там группа была с малополезными howto, то в целом система получится не особенно жирной. Потом ещё можешь удалить что точно не нужно из других групп.

Xenius ★★★★★ ()

Прошу рассказать, как установить минимальную версию (WM люблю) с Xorg

Минимальную версию никогда не устанавливал, так как меня KDE устраивает. Но если у тебя комп с UEFI, который не переключается в режим Legacy BIOS, то могут быть проблемы. В Slackware до сих пор в качестве загрузчика используется LILO. Нужно будет ставить ELILO или GRUB. На это есть мануал.

После установки нужно поставить slackpkg+ и подключить репозитории AlenBob’a и Slackonly с дополнительным софтом.

DarthVadimius ★★★ ()

Установщик с ncurses для дебила там - за 5 минут ставится.

Dumppper001 ()
Ответ на: комментарий от DarthVadimius

Никаких проблем с efi нет. Elilo автоматом во время установки предложит внести в efi запись. Единственное, если шифрование присутствует, придется esp раздел делать побольше, потому что elilo только оттуда умеет читать инитрд и ядро.

du -hs /boot/efi/EFI/Slackware/
44M     /boot/efi/EFI/Slackware/

Это на 2 generic ядра.

Valar ()
Ответ на: комментарий от shleemypants

Там есть только категории пакетов. Устанавливаешь пакет при установке ор притягивает зависимости. Правда там пакет менеджер slackpkg который tar.gz. Но вроде это не должно пугать пользователя crux

Dumppper001 ()
Ответ на: комментарий от Dumppper001

Глупости очередной раз пишите. Пакетный менеджер зависимости там регулирует. Просто наборы пакетов так составлены, что все нужные либы и бинарники уже или в минимальной базе, или в том же наборе, в котором программа, которая в них нуждается.

Valar ()
Ответ на: комментарий от Valar

Получается, если я из списка поставлю галочку на пакете, он не подтянт при установке мне нужное? Только Вкл/Выкл набор? И всё?

shleemypants ()
Ответ на: комментарий от Dumppper001

меня ничего не пугает. Только вот времени жалко. Лучше узнать, потом жмакать. Раньше просто «в бой», старею ;)

shleemypants ()
Последнее исправление: shleemypants (всего исправлений: 1)
Ответ на: комментарий от Valar

Я имел ввиду при установке дистра так. А так там все зависимости вместе с пакетом качаются

Dumppper001 ()
Ответ на: комментарий от shleemypants

В экспертном режиме, где нужно самому выбирать пакеты, зависимости автоматом не прилетят. Поэтому не советую с него начинать. Ставь полную систему или целыми наборами. Как выше упомянили, можно много лишнего выбросить исключив наборы xfce, kde, доки, сорцы ядра, техлайв.

Valar ()
Ответ на: комментарий от Valar

сорцы ядра

Это надо. Жаль, что не регулирует связи при установке. А если я что-то в экспертном лишнее грохну, как посмоотреть зависимости?

shleemypants ()
Ответ на: комментарий от shleemypants

А если я пакет выбираю при установке, он зависимости к пакету подтянет?

Нет. В пределах базовой системы зависимости не отслеживаются. Так что просто ставь все категории кроме заведомо ненужных (например доки не нужны, kernel source не нужен, так как всё равно лучше качнуть более новое ядро, а заголовки и так будут)

Xenius ★★★★★ ()
Ответ на: комментарий от shleemypants

А если я что-то в экспертном лишнее грохну, как посмоотреть зависимости?

Для первой установки выбирай только целые категории. Не нужен тебе экспертный режим. И вообще хочешь линукс на минималках — это CRUX, хочешь максимум всего нужного, но минимум всякой хни вроде systemd и графических утилит настройки — Slackware.

Xenius ★★★★★ ()
Ответ на: комментарий от shleemypants

Зачем? current ставь да и всё. Релиз отличаться будет только циферкой и более редкими обновлениями.

Когда выйдет релиз, поменяешь /etc/slackpkg/mirrors на

https://mirrors.slackware.com/slackware/slackware-15.0

Потом обновишься — и всё, у тебя будет релиз.

Xenius ★★★★★ ()
Ответ на: комментарий от shleemypants

Два года назад точно не было. Current по-моему сейчас примерно соответствует 15.0

DarthVadimius ★★★ ()

Прошу рассказать, как установить минимальную версию (WM люблю) с Xorg?

Из-за отсутствия зависимостей не получится.
Попробуй это:
https://www.salixos.org/- они строго на базе слаки делают пакеты и дистр с зависимостями.

Shadow ★★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.